Skip to content

Commit

Permalink
app-admin/fsvs: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Browse files Browse the repository at this point in the history
Gentoo-Bug: 570596
* EAPI=6

Package-Manager: portage-2.2.27
  • Loading branch information
SoapGentoo committed Jan 24, 2016
1 parent 0416510 commit f80fbfa
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 2 deletions.
4 changes: 2 additions & 2 deletions app-admin/fsvs/files/fsvs-1.2.5-as-needed.patch
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@ Fixes --as-needed support(bug #294834)
Verbose build
Fixes underlinking(bug #463684) - patch went upstream

--- src/Makefile.in.orig 2011-11-11 22:19:12.000000000 +0400
+++ src/Makefile.in 2013-08-19 13:30:16.186082295 +0400
--- fsvs-1.2.5/src/Makefile.in.orig 2011-11-11 22:19:12.000000000 +0400
+++ fsvs-1.2.5/src/Makefile.in 2013-08-19 13:30:16.186082295 +0400
@@ -18,7 +18,7 @@
CFLAGS := @CFLAGS@ @NEED_FNESTED_FUNCTIONS@
CFLAGS += -Wall -funsigned-char -Os -DFSVS_VERSION='"$(VERSION)"'
Expand Down
61 changes: 61 additions & 0 deletions app-admin/fsvs/fsvs-1.2.5-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit flag-o-matic toolchain-funcs

DESCRIPTION="Backup/restore for subversion backends"
HOMEPAGE="http://fsvs.tigris.org/"
SRC_URI="http://download.fsvs-software.org/${P}.tar.bz2"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="dev-vcs/subversion
dev-libs/libpcre
sys-libs/gdbm
dev-libs/apr-util
dev-util/ctags"
DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}/${P}-as-needed.patch"
)

src_prepare() {
# fix #570596 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
default
}

src_compile() {
# respect compiler
emake CC="$(tc-getCC)"
}

src_install() {
dobin src/fsvs
dodir /etc/fsvs
keepdir /var/spool/fsvs
doman doc/*5 doc/*1
dodoc doc/{FAQ,IGNORING,PERFORMANCE,USAGE}
}

pkg_postinst() {
elog "Remember, this system works best when you're connecting to a remote"
elog "svn server."
elog
elog "Go to the base path for versioning:"
elog " cd /"
elog "Tell fsvs which URL it should use:"
elog " fsvs url svn+ssh://username@machine/path/to/repos"
elog "Define ignore patterns - all virtual filesystems (/proc, /sys, etc.),"
elog "and (assuming that you're in / currently) the temporary files in /tmp:"
elog " fsvs ignore DEVICE:0 ./tmp/*"
elog "And you're ready to play!"
elog "Check your data in:"
elog " fsvs commit -m \"First import\""
}

0 comments on commit f80fbfa

Please sign in to comment.