Skip to content

Commit

Permalink
dev-games/clanlib: Fix building with GCC-6
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/596112
Closes: gentoo#5915
Package-Manager: Portage-2.3.10, Repoman-2.3.3
  • Loading branch information
Peter-Levine authored and akhuettel committed Oct 13, 2017
1 parent ef61055 commit f928bd3
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 1 deletion.
3 changes: 2 additions & 1 deletion dev-games/clanlib/clanlib-0.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -40,6 +40,7 @@ src_prepare() {
"${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-gcc47.patch \
"${FILESDIR}"/${P}-gcc6.patch \
"${FILESDIR}"/${P}-libpng15.patch
}

Expand Down
16 changes: 16 additions & 0 deletions dev-games/clanlib/files/clanlib-0.8.1-gcc6.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
Bug: https://bugs.gentoo.org/596112

--- a/Sources/Core/IOData/Generic/datafile_inputprovider.h
+++ b/Sources/Core/IOData/Generic/datafile_inputprovider.h
@@ -142,9 +142,9 @@
void insert(const std::string &resource_id, int data_pos, int data_size)
{
cache.insert(
- std::make_pair<std::string const, std::pair<int, int> >(
+ std::pair<std::string const, std::pair<int, int> >(
resource_id,
- std::make_pair<int,int>(data_pos, data_size)));
+ std::pair<int,int>(data_pos, data_size)));
}

private:

0 comments on commit f928bd3

Please sign in to comment.