Skip to content

Commit

Permalink
dev-dotnet/libgdiplus: fix circular deps, remove mono need
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
cnd committed Feb 9, 2017
1 parent 633fb67 commit fa17e04
Showing 1 changed file with 51 additions and 0 deletions.
51 changes: 51 additions & 0 deletions dev-dotnet/libgdiplus/libgdiplus-4.2-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils

DESCRIPTION="Library for using System.Drawing with mono"
HOMEPAGE="http://www.mono-project.com"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.gz"

IUSE="cairo"

RDEPEND=">=dev-libs/glib-2.2.3:2
>=media-libs/freetype-2.3.7
>=media-libs/fontconfig-2.6
>=media-libs/libpng-1.4:0
x11-libs/libXrender
x11-libs/libX11
x11-libs/libXt
>=x11-libs/cairo-1.8.4[X]
media-libs/libexif
>=media-libs/giflib-5.1.2
virtual/jpeg:0
media-libs/tiff:0
!cairo? ( >=x11-libs/pango-1.20 )"
DEPEND="${RDEPEND}"

src_configure() {
econf \
--disable-dependency-tracking \
--disable-static \
$(usex cairo "" "--with-pango")
}

src_install () {
default

dotnet_multilib_comply
local commondoc=( AUTHORS ChangeLog README TODO )
for docfile in "${commondoc[@]}"; do
[[ -e "${docfile}" ]] && dodoc "${docfile}"
done
[[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
prune_libtool_files
}

0 comments on commit fa17e04

Please sign in to comment.