Skip to content

Commit

Permalink
www-apps/hugo: add 0.129.0
Browse files Browse the repository at this point in the history
Signed-off-by: tastytea <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
tastytea authored and juippis committed Aug 4, 2024
1 parent fd3c2a9 commit fa25954
Show file tree
Hide file tree
Showing 2 changed files with 106 additions and 0 deletions.
2 changes: 2 additions & 0 deletions www-apps/hugo/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,5 @@ DIST hugo-0.127.0-vendor.tar.xz 6747376 BLAKE2B 28569618b1398effe5eeafe72b435769
DIST hugo-0.127.0.tar.gz 21132608 BLAKE2B 6fa8ae09d325292715d94f28e13d3bce8efcecc5e729da3644a054857aa3e11893068bd25524857e7dde6bab92efc9acb5b0de823c8a6246b9f5e83b07c4e279 SHA512 829d118f12f153794ed882572a37ec2a3b3ade9c8160a754d3d411d6aede22c15e44dd75a52443e3cc7fc8ea1f65febecac5a47b4e09cc42006d7badd1a0fa2f
DIST hugo-0.128.2-vendor.tar.xz 6698936 BLAKE2B 28762e61a7e7452545889f31a751dea236f90c352bc63ac0b33a1e8cf0c7d9091d5ccc7cefc2b47f37db7a10f44636d4fbda02af3ca7be2e9cba64b564b85b87 SHA512 7576830db0a9058117ab5ba0c7269d5d75114695183882af5184a79088235a22aad3691e114892f179e107bf06048c6d302019fb0bb85d492715922a772b2224
DIST hugo-0.128.2.tar.gz 20239793 BLAKE2B 47d75606053e44a0f863dbb88050ff5323e33c1306a47baff237db7fa41dce0559960785105ad8643dcef1eeb149054b5536da168ff978ac0b5c3c5398379b6f SHA512 4710fceb11872577a1d9c929d296dc79829135af0c509ac0b7b8142568b0e907c2de28c9f482cc1138d9595086363397166eb2ca208fa4fdf1beadd168558787
DIST hugo-0.129.0-vendor.tar.xz 6766128 BLAKE2B 31f723bdefd45a8e595c09b2d579ff68e2d3dc2e48c276a7963348c0d791c443b1a7e09c15a6aec955dca4928e695516c3777c6550230f455bb7f9c7ac3b6483 SHA512 97044f53cab10484731fc42aabcb63484759f00e80e29237d9819af49c6ab5fefeddde37fc971f9c47c9f24e607c0691cfb8a564e6de7f5a017b0ef93e8c7d89
DIST hugo-0.129.0.tar.gz 20241492 BLAKE2B aaa6ced77b936a34e0ebe24f2a2c51cd992464cbfd93b33682f0b0c501e6809d5c13960c1bec82611ebd043631bb2e2bae13348475641e8b7736b4980a3b3a1f SHA512 0845f417af97ee068ad0c971684522fa49fcfca47de5db71f0026fd3c59baddcc03c73560275ff91e4c85286cf855a2b3b0271ee019141d71e04f6b31a91ae87
104 changes: 104 additions & 0 deletions www-apps/hugo/hugo-0.129.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 2018-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module shell-completion

DESCRIPTION="Fast static HTML and CSS website generator"
HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
SRC_URI="
https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
"

# NOTE: To create the vendor tarball, run:
# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`

LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0 Unlicense"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
IUSE="doc +extended test"

BDEPEND="
>=dev-lang/go-1.22.2
test? (
dev-python/docutils
dev-ruby/asciidoctor
)
"
RDEPEND="
extended? (
dev-libs/libsass:=
>=media-libs/libwebp-1.3.2:=
)
"
DEPEND="${RDEPEND}"

RESTRICT="!test? ( test )"

PATCHES=(
"${FILESDIR}"/${PN}-0.121.0-unbundle-libwebp-and-libsass.patch
"${FILESDIR}"/${PN}-0.128.0-skip-some-tests.patch
)

src_configure() {
export CGO_ENABLED=1
export CGO_CFLAGS="${CFLAGS}"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export MY_BUILD_FLAGS="$(usev extended "-tags extended")"

default
}

src_prepare() {
# wants to run command that require network access
rm testscripts/commands/mod{,_vendor,__disable,_get,_get_u,_npm{,_withexisting}}.txt || die

default
}

src_compile() {
mkdir -pv bin || die
ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
${MY_BUILD_FLAGS} -o "${S}/bin/hugo"

bin/hugo gen man --dir man || die

mkdir -pv completions || die
bin/hugo completion bash > completions/hugo || die
bin/hugo completion fish > completions/hugo.fish || die
bin/hugo completion zsh > completions/_hugo || die

if use doc ; then
bin/hugo gen doc --dir doc || die
fi
}

src_test() {
if ! has_version -b virtual/pandoc ; then
elog "You're missing virtual/pandoc - some tests will be skipped."
fi

ego test "./..." ${MY_BUILD_FLAGS}
}

src_install() {
dobin bin/*
doman man/*

dobashcomp completions/${PN}
dofishcomp completions/${PN}.fish
dozshcomp completions/_${PN}

if use doc ; then
dodoc -r doc/*
fi
}

pkg_postinst() {
elog "the sass USE-flag was renamed to extended. the functionality is the" \
"same, except it also toggles the dependency on libwebp (for encoding)"
}

0 comments on commit fa25954

Please sign in to comment.