Skip to content

Commit

Permalink
app-benchmarks/wrk: Bump to version 4.1.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
vikraman committed Feb 4, 2018
1 parent 74b91b1 commit fe0ca74
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-benchmarks/wrk/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST wrk-3.1.2.tar.gz 902868 BLAKE2B 1b979a7b72c41d37ec63759c76770a74ca8cf618bf2e84b30556fa7db47b3cbe4957924a5ad90594580d4fed5194201d6205b04c660195466c6d6fb369604571 SHA512 399f33c2c008c21ac8fae1b561fe16ebcca324b5171340ffa706e84c256bf13a9983b5c18d258be6f87cb9fe8e38a434f9bfa7059395a01cb783f77faf952b15
DIST wrk-4.0.2.tar.gz 6146798 BLAKE2B 62188872a370d4ef3a3ffcf6f0568ca1b003473a1333b51d2b79fc3ce793c39ba5958d95c877fc0382751e89b687c8ee7f20b376c9b2fe3826afc3161aa0ac8e SHA512 4279cf7136e2919779be3f61f462136a7a5288eac481104b844193682a8fc554581fd3942624d0be9317a3e82c82497927a124b9b4dbdf455e30d3f0cad1fdea
DIST wrk-4.1.0.tar.gz 6478125 BLAKE2B d64c172819a32b874e5351ef1088a66af7eb76ae34421577f817f14797a5711665adb8074e90a80e511139a889d4c960dc91caa5855bbd67038229307ef93ed2 SHA512 2c8d05f8e40c3a6234bc1c2862157764532a39046860210fe512c260c2b940e1e3120b831d0721c936c7bca474574600cda1f4c949b53738199d98102e32cb1a
32 changes: 32 additions & 0 deletions app-benchmarks/wrk/wrk-4.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

inherit eutils

DESCRIPTION="A modern HTTP benchmarking tool"
HOMEPAGE="https://github.com/wg/wrk"
SRC_URI="https://github.com/wg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="libressl"

DEPEND=">=dev-lang/luajit-2.0.2
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )"
RDEPEND="${DEPEND}"

src_compile() {
tc-export CC
emake VER="${PV}" WITH_LUAJIT="${EPREFIX}"/usr WITH_OPENSSL="${EPREFIX}"/usr
}

src_install() {
dobin ${PN}
dodoc README.md NOTICE
insinto /usr/share/${PN}
doins -r scripts
}

0 comments on commit fe0ca74

Please sign in to comment.