forked from LiBwrt/openwrt-6.x
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge remote-tracking branch 'op/main'
This is my last update, maybe another developer will maintain it in the future.
- Loading branch information
Showing
80 changed files
with
458 additions
and
248 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
34 changes: 34 additions & 0 deletions
34
...kernel/lantiq/vrx518_tc/patches/206-dcdp-ptm_tc-allow-larger-mtu-to-support-rfc4638.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
From 3983dc1674fec43beb8ce9d9bfdd6302fef86eae Mon Sep 17 00:00:00 2001 | ||
From: Andrew MacIntyre <[email protected]> | ||
Date: Mon, 4 Nov 2024 22:41:25 +1100 | ||
Subject: [PATCH] vrx518_tc: allow larger MTU to support RFC4638 | ||
|
||
vrx518_tc currently sets the interface maximum MTU to the ethernet default | ||
of 1500 bytes by default via ether_setup() called from ptm_setup(). | ||
|
||
To support 1508 byte baby jumbo frames (RFC4638) for PPPoE connections | ||
over VDSL links as already supported by the VR9 ltq_ptm driver ([1], [2]) | ||
set the interface maximum MTU to MAX_MTU. | ||
|
||
MAX_MTU is defined in dcdp/inc/tc_common.h to 2002 bytes and this value is | ||
used in ptm_change_mtu() and elsewhere as the maximum MTU, however this is | ||
short circuited by checks against the interface maximum MTU. | ||
|
||
[1]: https://forum.openwrt.org/t/fritzbox-7530-and-rfc4638-baby-jumbo-frames/181327 | ||
[2]: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=8a2a20e71e2909f84dab47e51dfda9e292a6c1ae | ||
|
||
Signed-off-by: Andrew MacIntyre <[email protected]> | ||
--- | ||
dcdp/ptm_tc.c | 1 + | ||
1 file changed, 1 insertion(+) | ||
|
||
--- a/dcdp/ptm_tc.c 2023-12-17 16:11:22.503500398 +1100 | ||
+++ b/dcdp/ptm_tc.c 2024-01-26 16:48:49.881623474 +1100 | ||
@@ -657,6 +657,7 @@ static void ptm_setup(struct net_device | ||
ether_setup(dev); | ||
dev->watchdog_timeo = 10 * HZ; | ||
dev->netdev_ops = &g_ptm_netdev_ops; | ||
+ dev->max_mtu = MAX_MTU; | ||
} | ||
|
||
static int ptm_dev_init(struct tc_priv *tc_priv, u32 id, |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk | |
|
||
PKG_NAME:=libnftnl | ||
PKG_CPE_ID:=cpe:/a:netfilter:libnftnl | ||
PKG_VERSION:=1.2.6 | ||
PKG_VERSION:=1.2.8 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files | ||
PKG_HASH:=ceeaea2cd92147da19f13a35a7f1a4bc2767ff897e838e4b479cf54b59c777f4 | ||
PKG_HASH:=37fea5d6b5c9b08de7920d298de3cdc942e7ae64b1a3e8b880b2d390ae67ad95 | ||
|
||
PKG_MAINTAINER:=Steven Barth <[email protected]> | ||
PKG_LICENSE:=GPL-2.0-or-later | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -5,9 +5,9 @@ PKG_RELEASE:=1 | |
|
||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git | ||
PKG_SOURCE_DATE:=2024-10-06 | ||
PKG_SOURCE_VERSION:=3c6265fdbd02ebd35fa3e7a58d6dfeed081a09d7 | ||
PKG_MIRROR_HASH:=00b01243b99995dc52a047e5663cf5c7732f8defd6b726f73ac15e142b02b4fa | ||
PKG_SOURCE_DATE:=2024-11-08 | ||
PKG_SOURCE_VERSION:=34eb11eb6f5c62de480d6192f0ca840093127fee | ||
PKG_MIRROR_HASH:=c4c2bc626426d2cd73c9ece54b22ada6ed6254afa992f51b8725312aca240cfd | ||
PKG_MAINTAINER:=Felix Fietkau <[email protected]> | ||
|
||
PKG_LICENSE:=GPL-2.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.