Skip to content

Commit

Permalink
iproute2: update to version 4.15.0
Browse files Browse the repository at this point in the history
The musl compatibility patches are now included in the upstream version.

Signed-off-by: Hauke Mehrtens <[email protected]>
  • Loading branch information
hauke committed Feb 15, 2018
1 parent 75c5ab4 commit e7c1793
Show file tree
Hide file tree
Showing 11 changed files with 23 additions and 225 deletions.
6 changes: 3 additions & 3 deletions package/network/utils/iproute2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=iproute2
PKG_VERSION:=4.14.1
PKG_RELEASE:=2
PKG_VERSION:=4.15.0
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
PKG_HASH:=d43ac068afcc350a448f4581b6e292331ef7e4e7aa746e34981582d5fdb10067
PKG_HASH:=48d4616a99d7b609b7b795c0ae8ec57099fb0271ed89253e8772c02327798355
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=iptables
PKG_LICENSE:=GPL-2.0
Expand Down
2 changes: 1 addition & 1 deletion package/network/utils/iproute2/patches/007-no_arpd.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -5,9 +5,9 @@ TARGETS=ss nstat ifstat rtacct lnstat
@@ -6,9 +6,9 @@ TARGETS=ss nstat ifstat rtacct lnstat

include ../config.mk

Expand Down
2 changes: 1 addition & 1 deletion package/network/utils/iproute2/patches/008-no_netem.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
@@ -57,7 +57,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
YACCFLAGS = -d -t -v

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
@@ -292,7 +292,7 @@ check_selinux()
@@ -293,7 +293,7 @@ check_selinux()

check_mnl()
{
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
@@ -42,7 +42,7 @@ HOSTCC ?= $(CC)
@@ -50,7 +50,7 @@ HOSTCC ?= $(CC)
DEFINES += -D_GNU_SOURCE
# Turn on transparent support for LFS
DEFINES += -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -1,6 +1,6 @@
@@ -1,7 +1,7 @@
# SPDX-License-Identifier: GPL-2.0
include ../config.mk

-CFLAGS += -fPIC
Expand Down

This file was deleted.

This file was deleted.

14 changes: 7 additions & 7 deletions package/network/utils/iproute2/patches/300-ip_tiny.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/ip/Makefile
+++ b/ip/Makefile
@@ -15,6 +15,13 @@ RTMONOBJ=rtmon.o
@@ -16,6 +16,13 @@ RTMONOBJ=rtmon.o

include ../config.mk

Expand All @@ -14,7 +14,7 @@
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
SCRIPTS=ifcfg rtpr routel routef
TARGETS=ip rtmon
@@ -44,7 +51,7 @@ else
@@ -45,7 +52,7 @@ else

ip: static-syms.o
static-syms.o: static-syms.h
Expand All @@ -25,7 +25,7 @@
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
--- a/ip/ip.c
+++ b/ip/ip.c
@@ -49,10 +49,16 @@ static void usage(void)
@@ -48,10 +48,16 @@ static void usage(void)
fprintf(stderr,
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
" ip [ -force ] -batch filename\n"
Expand All @@ -42,7 +42,7 @@
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
" -h[uman-readable] | -iec |\n"
" -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
@@ -74,32 +80,44 @@ static const struct cmd {
@@ -73,32 +79,44 @@ static const struct cmd {
int (*func)(int argc, char **argv);
} cmds[] = {
{ "address", do_ipaddr },
Expand Down Expand Up @@ -89,15 +89,15 @@
{ "help", do_help },
--- a/lib/utils.c
+++ b/lib/utils.c
@@ -817,6 +817,7 @@ const char *rt_addr_n2a_r(int af, int le
@@ -885,6 +885,7 @@ const char *rt_addr_n2a_r(int af, int le
return inet_ntop(af, addr, buf, buflen);
case AF_MPLS:
return mpls_ntop(af, addr, buf, buflen);
+#ifndef IPROUTE2_TINY
case AF_IPX:
return ipx_ntop(af, addr, buf, buflen);
case AF_DECnet:
@@ -826,6 +827,7 @@ const char *rt_addr_n2a_r(int af, int le
@@ -894,6 +895,7 @@ const char *rt_addr_n2a_r(int af, int le
memcpy(dna.a_addr, addr, 2);
return dnet_ntop(af, &dna, buf, buflen);
}
Expand All @@ -107,7 +107,7 @@
default:
--- a/lib/Makefile
+++ b/lib/Makefile
@@ -2,6 +2,10 @@ include ../config.mk
@@ -3,6 +3,10 @@ include ../config.mk

CFLAGS += $(FPIC)

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY

--- a/ip/rtm_map.c
+++ b/ip/rtm_map.c
@@ -49,6 +49,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
@@ -48,6 +48,8 @@ char *rtnl_rtntype_n2a(int id, char *buf
return "nat";
case RTN_XRESOLVE:
return "xresolve";
Expand All @@ -20,7 +20,7 @@ Subject: [PATCH] add support for dropping with FAILED_POLICY
default:
snprintf(buf, len, "%d", id);
return buf;
@@ -84,6 +86,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
@@ -83,6 +85,8 @@ int rtnl_rtntype_a2n(int *id, char *arg)
res = RTN_UNICAST;
else if (strcmp(arg, "throw") == 0)
res = RTN_THROW;
Expand Down
11 changes: 5 additions & 6 deletions package/network/utils/iproute2/patches/950-add-cake-to-tc.patch
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
--- a/include/uapi/linux/pkt_sched.h
+++ b/include/uapi/linux/pkt_sched.h
@@ -872,4 +872,63 @@ struct tc_pie_xstats {
__u32 maxq; /* maximum queue size */
__u32 ecn_mark; /* packets marked with ecn*/
};
+
@@ -934,4 +934,62 @@ enum {

#define TCA_CBS_MAX (__TCA_CBS_MAX - 1)

+/* CAKE */
+enum {
+ TCA_CAKE_UNSPEC,
Expand Down Expand Up @@ -66,7 +65,7 @@
#endif
--- a/tc/Makefile
+++ b/tc/Makefile
@@ -65,6 +65,7 @@ TCMODULES += q_codel.o
@@ -66,6 +66,7 @@ TCMODULES += q_codel.o
TCMODULES += q_fq_codel.o
TCMODULES += q_fq.o
TCMODULES += q_pie.o
Expand Down

0 comments on commit e7c1793

Please sign in to comment.