Skip to content

Commit

Permalink
begin fixing testsuite failures...
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@268053 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
allan committed May 15, 2016
1 parent 0ea3063 commit cddd159
Show file tree
Hide file tree
Showing 4 changed files with 107 additions and 28 deletions.
19 changes: 13 additions & 6 deletions automake/trunk/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

pkgname=automake
pkgver=1.15
pkgrel=1
pkgrel=2
pkgdesc="A GNU tool for automatically creating Makefiles"
arch=('any')
license=('GPL')
Expand All @@ -13,17 +13,24 @@ groups=('base-devel')
depends=('perl' 'bash')
makedepends=('autoconf')
checkdepends=('dejagnu' 'python' 'gcc-fortran' 'java-environment' 'vala' 'emacs' 'cscope')
install=automake.install
source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig})
source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz{,.sig}
automake-1.15-perl-regex.patch
automake-1.15-gzip-envvar.patch)
md5sums=('9a1ddb0e053474d9d1105cfe39b0c48d'
'SKIP')
'SKIP'
'ec24c629cad74c88555ee499c38dbd6e'
'fa71c83d3f9d32d9a4007152b829074c')
validpgpkeys=('E1622F96D2BB4E58018EEF9860F906016E407573') # Stefano Lattarini


prepare() {
cd ${srcdir}/${pkgname}-${pkgver}

# skip failing test...
sed -i "/instmany-python.sh/d" Makefile.in
# fix regex issue with recent perl
patch -p1 -i $srcdir/automake-1.15-perl-regex.patch

# fix testsuite issues with recent gzip
patch -p1 -i $srcdir/automake-1.15-gzip-envvar.patch
}

build() {
Expand Down
68 changes: 68 additions & 0 deletions automake/trunk/automake-1.15-gzip-envvar.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
From 749468ac63042820bc3da85ece5bed64b0c15d62 Mon Sep 17 00:00:00 2001
From: Paul Eggert <eggert at>
Date: Tue, 29 Mar 2016 02:44:19 +0000
Subject: automake: port better to future gzip

* lib/am/distdir.am (dist-gzip, dist-shar, distcheck):
Port better to future versions of gzip, which are planned to
deprecate the GZIP environment variable (Bug#20132).
---
diff --git a/lib/am/distdir.am b/lib/am/distdir.am
index d4dd8cc..87c6730 100644
--- a/lib/am/distdir.am
+++ b/lib/am/distdir.am
@@ -309,6 +309,16 @@ endif %?TOPDIR_P%
## We order DIST_TARGETS by expected duration of the compressors,
## slowest first, for better parallelism in "make dist". Do not
## reorder DIST_ARCHIVES, users may expect gzip to be first.
+##
+## Traditionally, gzip prepended the contents of the GZIP environment
+## variable to its arguments, and the commands below formerly used
+## this by invoking 'GZIP=$(GZIP_ENV) gzip'. The GZIP environment
+## variable is now considered to be obsolescent, so the commands below
+## now use 'eval GZIP= gzip $(GZIP_ENV)' instead; this should work
+## with both older and newer gzip implementations. The 'eval' is to
+## support makefile assignments like 'GZIP_ENV = "-9 -n"' that quote
+## the GZIP_ENV right-hand side because that was needed with the
+## former invocation pattern.

if %?TOPDIR_P%

@@ -316,7 +326,7 @@ if %?TOPDIR_P%
GZIP_ENV = --best
.PHONY: dist-gzip
dist-gzip: distdir
- tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
+ tardir=$(distdir) && $(am__tar) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).tar.gz
$(am__post_remove_distdir)

?BZIP2?DIST_ARCHIVES += $(distdir).tar.bz2
@@ -352,7 +362,7 @@ dist-shar: distdir
@echo WARNING: "Support for shar distribution archives is" \
"deprecated." >&2
@echo WARNING: "It will be removed altogether in Automake 2.0" >&2
- shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
+ shar $(distdir) | eval GZIP= gzip $(GZIP_ENV) -c >$(distdir).shar.gz
$(am__post_remove_distdir)

?ZIP?DIST_ARCHIVES += $(distdir).zip
@@ -412,7 +422,7 @@ endif %?SUBDIRS%
distcheck: dist
case '$(DIST_ARCHIVES)' in \
*.tar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).tar.gz | $(am__untar) ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
bzip2 -dc $(distdir).tar.bz2 | $(am__untar) ;;\
*.tar.lz*) \
@@ -422,7 +432,7 @@ distcheck: dist
*.tar.Z*) \
uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
- GZIP=$(GZIP_ENV) gzip -dc $(distdir).shar.gz | unshar ;;\
+ eval GZIP= gzip $(GZIP_ENV) -dc $(distdir).shar.gz | unshar ;;\
*.zip*) \
unzip $(distdir).zip ;;\
esac
--
cgit v0.9.0.2
26 changes: 26 additions & 0 deletions automake/trunk/automake-1.15-perl-regex.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
From 13f00eb4493c217269b76614759e452d8302955e Mon Sep 17 00:00:00 2001
From: Paul Eggert <[email protected]>
Date: Thu, 31 Mar 2016 23:35:29 +0000
Subject: automake: port to Perl 5.22 and later

Without this change, Perl 5.22 complains "Unescaped left brace in
regex is deprecated" and this is planned to become a hard error in
Perl 5.26. See:
http://search.cpan.org/dist/perl-5.22.0/pod/perldelta.pod#A_literal_%22{%22_should_now_be_escaped_in_a_pattern
* bin/automake.in (substitute_ac_subst_variables): Escape left brace.
---
diff --git a/bin/automake.in b/bin/automake.in
index a3a0aa3..2c8f31e 100644
--- a/bin/automake.in
+++ b/bin/automake.in
@@ -3878,7 +3878,7 @@ sub substitute_ac_subst_variables_worker
sub substitute_ac_subst_variables
{
my ($text) = @_;
- $text =~ s/\${([^ \t=:+{}]+)}/substitute_ac_subst_variables_worker ($1)/ge;
+ $text =~ s/\$[{]([^ \t=:+{}]+)}/substitute_ac_subst_variables_worker ($1)/ge;
return $text;
}

--
cgit v0.9.0.2
22 changes: 0 additions & 22 deletions automake/trunk/automake.install

This file was deleted.

0 comments on commit cddd159

Please sign in to comment.