forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
archrelease: copy trunk to staging-x86_64
git-svn-id: file:///srv/repos/svn-packages/svn@393144 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
alucryd
committed
Aug 4, 2020
1 parent
ab1fbe8
commit 35dc62c
Showing
3 changed files
with
102 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org> | ||
# Maintainer: Eric Bélanger <[email protected]> | ||
|
||
pkgbase=avidemux | ||
pkgname=('avidemux-cli' 'avidemux-qt') | ||
pkgver=2.7.6 | ||
pkgrel=2 | ||
pkgdesc='Graphical tool to edit video (filter/re-encode/split)' | ||
url='http://fixounet.free.fr/avidemux/' | ||
arch=('x86_64') | ||
license=('GPL2') | ||
makedepends=('cmake' 'libxslt' 'qt5-base' 'jack' 'libvorbis' 'libxv' 'opus' 'desktop-file-utils' | ||
'alsa-lib' 'lame' 'xvidcore' 'faad2' 'faac' 'x264' 'x265' 'libsamplerate' | ||
'opencore-amr' 'yasm' 'mesa' 'libvpx' 'libpulse' 'libva' 'intltool' 'sqlite' | ||
'libvdpau' 'libdca' 'fribidi' 'glu' 'qt5-tools' 'twolame' 'libfdk-aac' 'libass') | ||
options=('!emptydirs') | ||
source=(https://downloads.sourceforge.net/avidemux/avidemux_${pkgver}.tar.gz | ||
log.diff qt-5.15.diff) | ||
sha256sums=('9a88741f3535443d4bde35d4207ca2ff96d3b136db2e7232cb50dd6b4eb293cf' | ||
'8b751d137037f22fd4ae6750709014bcf61269a18f1c32e1a91f481285c807aa' | ||
'255a2446d493503dc237482f6fe26e2186f0ea0ef43ac9e17b8059fe232aad43') | ||
sha512sums=('7f40b48a6c688a5a847e46118aef822a0f5f1dfb50b6223ce8a825d9e3817a9114bc3400aa7b7286a495051912b4b54cf1b86ea7064e6164f7ca7455e5a714ee' | ||
'bbae5b4a549113b12e728c4c0ac8c1c92a0b7500be8dcecc791c16c9a913406feaa9f7bc477985970a920d2df391cc9392457512d84b9c4b829981cc072f2b2e' | ||
'ed78c2a3e4ede4fed1d3ea353c7dc350dc73050f76c8112cb24d97b3eda01f7c186d5db199f71f56953c5e5d8104de44dc0e84e1bfa01b6647c050c11fc375f2') | ||
|
||
prepare() { | ||
cd ${pkgbase}_${pkgver} | ||
patch -Np1 -i ../log.diff # don't hide the build output | ||
patch -Np1 -i ../qt-5.15.diff # fix build against Qt 5.15.0 | ||
sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash | ||
sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt | ||
} | ||
|
||
build() { | ||
cd ${pkgbase}_${pkgver} | ||
bash bootStrap.bash --with-core --with-cli --with-plugins | ||
} | ||
|
||
package_avidemux-cli() { | ||
depends=('libxml2' 'fontconfig' 'sqlite' 'libvpx' 'libva' 'libvdpau') | ||
optdepends=('lame: for the corresponding audio encoder plugin' | ||
'faac: for the corresponding audio encoder plugin' | ||
'faad2: for the corresponding audio decoder plugin' | ||
'opus: for the corresponding audio decoder plugin' | ||
'opencore-amr: for the corresponding audio decoder plugin' | ||
'jack: for the corresponding audio device plugin' | ||
'libpulse: for the corresponding audio device plugin' | ||
'x264: for the corresponding video encoder plugin' | ||
'libx264: for the corresponding video encoder plugin' | ||
'x265: for the corresponding video encoder plugin' | ||
'xvidcore: for the corresponding video encoder plugin' | ||
'qt5-base: for the QtScript scripting support' | ||
'libdca: for the corresponding audio decoder plugin' | ||
'libfdk-aac: for the corresponding audio decoder plugin' | ||
'twolame: for the corresponding audio decoder plugin' | ||
'libass: for the corresponding video filter plugin' | ||
'fribidi: for the corresponding video filter plugin') | ||
|
||
cd ${pkgbase}_${pkgver} | ||
make -C buildCli DESTDIR="${pkgdir}" install | ||
make -C buildCore DESTDIR="${pkgdir}" install | ||
make -C buildPluginsCLI DESTDIR="${pkgdir}" install | ||
make -C buildPluginsCommon DESTDIR="${pkgdir}" install | ||
|
||
install -Dm 644 avidemux_icon.png "${pkgdir}/usr/share/pixmaps/avidemux.png" | ||
install -Dm 644 man/avidemux.1 -t "${pkgdir}/usr/share/man/man1" | ||
} | ||
|
||
package_avidemux-qt() { | ||
pkgdesc='Graphical tool to edit video (filter/re-encode/split) - Qt GUI' | ||
depends=("avidemux-cli=${pkgver}" 'qt5-base' 'x264' 'x265' 'glu' 'libxv' 'desktop-file-utils') | ||
replaces=('avidemux-gtk') | ||
|
||
cd ${pkgbase}_${pkgver} | ||
make -C buildQt5 DESTDIR="${pkgdir}" install | ||
make -C buildPluginsQt5 DESTDIR="${pkgdir}" install | ||
} | ||
|
||
# vim: ts=2 sw=2 et: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
diff -u -r avidemux_2.7.4/bootStrap.bash avidemux_2.7.4-fix/bootStrap.bash | ||
--- avidemux_2.7.4/bootStrap.bash 2019-08-15 07:25:40.000000000 +0000 | ||
+++ avidemux_2.7.4-fix/bootStrap.bash 2020-06-05 13:40:10.633140851 +0000 | ||
@@ -66,7 +66,7 @@ | ||
fi | ||
cd $BUILDDIR | ||
cmake $COMPILER $PKG $FAKEROOT $QT_FLAVOR -DCMAKE_EDIT_COMMAND=vim $INSTALL_PREFIX $EXTRA $BUILD_QUIRKS $ASAN $DEBUG -G "$BUILDER" $SOURCEDIR || fail cmakeZ | ||
- make $PARAL >& /tmp/log$BUILDDIR || fail "make, result in /tmp/log$BUILDDIR" | ||
+ make $PARAL || fail make | ||
if [ "x$PKG" != "x" ] ; then | ||
$FAKEROOT_COMMAND make package DESTDIR=$FAKEROOT_DIR/tmp || fail package | ||
fi |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
diff -u -r avidemux_2.7.4/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp avidemux_2.7.4-fix/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp | ||
--- avidemux_2.7.4/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp 2019-08-15 07:25:39.000000000 +0000 | ||
+++ avidemux_2.7.4-fix/avidemux/qt4/ADM_UIs/src/T_RubberControl.cpp 2020-06-05 13:48:28.014061206 +0000 | ||
@@ -8,6 +8,7 @@ | ||
***************************************************************************/// | ||
|
||
#include <QPainter> | ||
+#include <QPainterPath> | ||
#include <QRubberBand> | ||
#include <QBoxLayout> | ||
#include <QSizeGrip> |