Skip to content

Commit

Permalink
archrelease: copy trunk to extra-i686
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@99601 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
andrea committed Nov 15, 2010
1 parent 94d4bde commit 39fd016
Show file tree
Hide file tree
Showing 4 changed files with 143 additions and 0 deletions.
40 changes: 40 additions & 0 deletions alsa-utils/repos/extra-i686/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# $Id$
# Maintainer: Tobias Powalowski <[email protected]>
# Contributor: judd <[email protected]>

pkgname=alsa-utils
pkgver=1.0.23
pkgrel=3
pkgdesc="An alternative implementation of Linux sound support"
arch=('i686' 'x86_64')
url="http://www.alsa-project.org"
#can not use >=$pkgver due to use of letters in alsa-lib update versioning
depends=("alsa-lib>1.0.22.99" 'dialog' 'pciutils' 'ncurses')
makedepends=('xmlto' 'docbook-xsl')
license=('GPL')
source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2
alsa
alsaconf.patch
alsa.conf.d)
backup=(etc/conf.d/alsa)

build() {
cd ${srcdir}/${pkgname}-${pkgver}
patch -Np1 -i ../alsaconf.patch
./configure --prefix=/usr
make
}

package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
install -D -m755 ../alsa ${pkgdir}/etc/rc.d/alsa
install -D -m644 ../alsa.conf.d ${pkgdir}/etc/conf.d/alsa

# dir where to save ALSA state
install -d ${pkgdir}/var/lib/alsa
}
md5sums=('cb0cf46029ac9549cf3a31bff6a4f4e1'
'3ef812cae83053d01cd560284efad71f'
'62ebef77d5617d0036012cc541dcf23c'
'4c8ae9f976c7df5e271a4cb91ccc7767')
56 changes: 56 additions & 0 deletions alsa-utils/repos/extra-i686/alsa
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
#!/bin/bash

. /etc/rc.conf
. /etc/conf.d/alsa
. /etc/rc.d/functions

case "$1" in
start)
stat_busy "Restoring ALSA Levels"
/usr/sbin/alsactl $ALSA_ARGS restore
if [ $? -gt 0 ]; then
stat_fail
else
stat_done
add_daemon alsa
fi

POWERSAVE=${POWERSAVE:-0}
if [ -e /sys/module/snd_ac97_codec/parameters/power_save \
-a $POWERSAVE -ne 0 ]; then
echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
[ -c /dev/dsp ] && echo 1 > /dev/dsp
fi

if [ -e /sys/module/snd_hda_intel/parameters/power_save \
-a $POWERSAVE -ne 0 ]; then
echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
[ -c /dev/dsp ] && echo 1 > /dev/dsp
fi
;;
stop)
SAVE_VOLUME=${SAVE_VOLUME:-yes}
if [ "$SAVE_VOLUME" == "yes" ]; then
stat_busy "Saving ALSA Levels"
/usr/sbin/alsactl $ALSA_ARGS store
else
stat_busy "Stopping ALSA"
fi
if [ "$MUTE_VOLUME" == "yes" ]; then
/usr/bin/amixer -q set Master 0 mute
fi
if [ $? -gt 0 ]; then
stat_fail
else
stat_done
rm_daemon alsa
fi
;;
restart)
$0 stop
sleep 1
$0 start
;;
*)
echo "usage: $0 {start|stop|restart}"
esac
15 changes: 15 additions & 0 deletions alsa-utils/repos/extra-i686/alsa.conf.d
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
# Arguments for alsactl
# example: ALSA_ARGS="--file /var/lib/alsa/asound.state"
ALSA_ARGS="--file /var/lib/alsa/asound.state"

# Enables powersaving mode for AC97 and hda_intel audio chips.
# Set to 1 to enable powersaving.
# Set to 0 to disable powersaving (default).
POWERSAVE=0

# Whether to save volume levels when stopped ("yes" or "no").
SAVE_VOLUME="yes"

# Whether to mute the master volume when stopped ("yes" or "no").
# Useful for bad audio cards which make a noise on system poweroff.
MUTE_VOLUME="no"
32 changes: 32 additions & 0 deletions alsa-utils/repos/extra-i686/alsaconf.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
diff -Naur alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in alsa-utils-1.0.9a/alsaconf/alsaconf.in
--- alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2005-03-24 00:24:52.000000000 -0800
+++ alsa-utils-1.0.9a/alsaconf/alsaconf.in 2005-07-18 09:25:02.000000000 -0700
@@ -58,6 +58,8 @@
distribution="redhat"
elif test -f /etc/fedora-release && grep -q "Fedora" /etc/fedora-release; then
distribution="fedora"
+elif test -f /etc/arch-release && grep -q "Arch" /etc/arch-release; then
+ distribution="arch"
elif [ -f /etc/slackware-version -o -f /etc/slamd64-version ]; then
distribution="slackware"
else
@@ -382,6 +384,8 @@
rcalsasound=/etc/rc.d/init.d/alsasound
elif [ -x /etc/init.d/alsa ]; then
rcalsasound=/etc/init.d/alsa
+elif [ -x /etc/rc.d/alsa ]; then
+ rcalsasound=/etc/rc.d/alsa
else
rcalsasound=rcalsasound
fi
--- alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
+++ alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
@@ -315,7 +315,7 @@
3.[789]*)
;;
*)
- cfgout="/etc/modprobe.d/sound"
+ cfgout="/etc/modprobe.d/sound.conf"
cfgoldout=""
;;
esac

0 comments on commit 39fd016

Please sign in to comment.