forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Closes: https://bugs.gentoo.org/889258 Signed-off-by: Florian Schmaus <[email protected]>
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST xml2rfc-3.15.3.gh.tar.gz 2857354 BLAKE2B 936c1f0c37d8de85b7a9966b6239da55dca090c3cb3e712a1198683244e436ccf6827fc6d00325e8c13a7be829af6954d311f690e4aa0367f2399c4d5cf9321f SHA512 3022bfc071e9bbef2e8e6b73c9c6539690e18f0935e3d22f99d1fc3faa642b75f998d6dfbd8d8c019f7fc789c38957994e06667870638dff8e907c928578c904 | ||
DIST xml2rfc-3.16.0.gh.tar.gz 2859379 BLAKE2B 537815a648b9f5ed59b37a82a29ee092b7e2ad3d10c191a08c752a43d3aed0b81270a855b3a3ee1df935a1d14192715e62f82fe15c2de98eddf329ac554a4ba5 SHA512 893a71bd33c6971103188e624b91d1370f8324bb2316a542fa9496c02368875582b57336e57abd8753e207d80a5aed508c15407ea734056f91002dde9aafdad2 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=setuptools | ||
PYTHON_COMPAT=( python3_{9..11} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Generates RFCs and IETF drafts from document source in XML" | ||
HOMEPAGE="https://ietf-tools.github.io/xml2rfc/ https://github.com/ietf-tools/xml2rfc" | ||
SRC_URI="https://github.com/ietf-tools/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz" | ||
|
||
RESTRICT="!test? ( test )" | ||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
BDEPEND=" | ||
test? ( | ||
>=dev-python/pypdf-3.2.1[${PYTHON_USEDEP}] | ||
dev-python/decorator[${PYTHON_USEDEP}] | ||
dev-python/dict2xml[${PYTHON_USEDEP}] | ||
dev-python/weasyprint[${PYTHON_USEDEP}] | ||
media-fonts/noto[cjk] | ||
) | ||
" | ||
|
||
RDEPEND=" | ||
dev-python/appdirs[${PYTHON_USEDEP}] | ||
dev-python/ConfigArgParse[${PYTHON_USEDEP}] | ||
dev-python/intervaltree[${PYTHON_USEDEP}] | ||
dev-python/google-i18n-address[${PYTHON_USEDEP}] | ||
>=dev-python/html5lib-1.0.1[${PYTHON_USEDEP}] | ||
>=dev-python/jinja-3.1.2[${PYTHON_USEDEP}] | ||
dev-python/lxml[${PYTHON_USEDEP}] | ||
>=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}] | ||
dev-python/pycountry[${PYTHON_USEDEP}] | ||
>=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}] | ||
dev-python/requests[${PYTHON_USEDEP}] | ||
dev-python/six[${PYTHON_USEDEP}] | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/xml2rfc-Remove-broken-test.patch" | ||
) | ||
|
||
distutils_enable_tests setup.py | ||
|
||
#src_test() { | ||
# https://github.com/ietf-tools/xml2rfc/issues/561 | ||
# emake tests-no-network | ||
#} |