Skip to content

Commit

Permalink
media-libs/libpano13: add static-libs flag for bug #829960
Browse files Browse the repository at this point in the history
Signed-off-by: Markus Meier <[email protected]>
  • Loading branch information
maekke committed Dec 19, 2022
1 parent a13a332 commit 7360eca
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions media-libs/libpano13/libpano13-2.9.21-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="8"

inherit cmake

DESCRIPTION="Helmut Dersch's panorama toolbox library"
HOMEPAGE="http://panotools.sourceforge.net/"
SRC_URI="mirror://sourceforge/panotools/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0/3"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="java static-libs suitesparse"

DEPEND="media-libs/libpng:=
media-libs/tiff:=
media-libs/libjpeg-turbo:=
sys-libs/zlib
java? ( >=virtual/jdk-1.8:* )
suitesparse? ( sci-libs/suitesparse )"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}-$(ver_cut 1-3)"

src_configure() {
local mycmakeargs=(
-DSUPPORT_JAVA_PROGRAMS=$(usex java)
-DUSE_SPARSE_LEVMAR=$(usex suitesparse)
)
cmake_src_configure
}

src_install() {
cmake_src_install

if ! use static-libs ; then
find "${D}" -name "*.a" -type f -delete || die
fi
}

0 comments on commit 7360eca

Please sign in to comment.