Skip to content

Commit

Permalink
x11-misc/autorandr: add 1.13.2
Browse files Browse the repository at this point in the history
Signed-off-by: Florian Schmaus <[email protected]>
  • Loading branch information
Flowdalic committed Jan 24, 2023
1 parent 0eda39e commit 96e8dbc
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/autorandr/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST autorandr-1.12.1.tar.gz 45550 BLAKE2B 5b434325d13c00c3fa70b5d09edb540cdcf3bb921307c60f2c616231e7a87ea85f60e39500ed8116f28619139f71ecc4a8fa153ffadc6b8d74df570736a0d815 SHA512 a7e095eb96e7e0d3a5b3b2122d68a3d3a5121d8be7a86ddd9f837ad42b7a53ed5ee45151f23861c5b900e214a4dfc0c575f45fe70c8c5587562a4035458137a0
DIST autorandr-1.13.1.tar.gz 47380 BLAKE2B f3173d795294eaa89d4f8c98d8bf6dc6a9c09d57649c228d17759e76d9c15d66b32803a63a07f44090b8d4580af8ae9dd42a3c8ff76d91f47d82f58896aebea6 SHA512 b090de5b4c7ff3d886d6aabac695a694983704678eedb31b4cbfdc88e6569e1f1c4e32ed5d16e59d0c98702c93c8600e7625d4d88dd6c988c7db131364cfb6f7
DIST autorandr-1.13.2.tar.gz 47607 BLAKE2B 8e4fe1b8ece98abb5ee88218db512e18822cf96e0587b3b117f0bcb07130b1c8bc473c987cf110d1ab0f2a8ea2fed64833610c951cee5ed5b899d180b3a80704 SHA512 79c344317be2f881a19a4dbd798441da49c6dbeeba555ad6c4d6fe1e4cba97587f2016910f850472b78341e1b6b16467f0ad33b496f68300054442e5c1675e4a
72 changes: 72 additions & 0 deletions x11-misc/autorandr/autorandr-1.13.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )

inherit bash-completion-r1 distutils-r1 systemd udev

if [[ "${PV}" = "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
else
SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Automatically select a display configuration based on connected devices"
HOMEPAGE="https://github.com/phillipberndt/autorandr"

LICENSE="GPL-3"
SLOT="0"
IUSE="launcher systemd udev"

RDEPEND="
x11-apps/xrandr
launcher? ( x11-libs/libxcb )
udev? ( virtual/udev )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_compile() {
distutils-r1_src_compile

if use launcher; then
emake contrib/autorandr_launcher/autorandr-launcher
fi
}

src_install() {
distutils-r1_src_install

doman autorandr.1

local targets=(
autostart_config
bash_completion
$(usev launcher)
$(usev systemd)
$(usev udev)
)

emake DESTDIR="${D}" \
BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
$(printf "install_%s " "${targets[@]}")
}

pkg_postinst() {
if use udev; then
udev_reload
fi
}

pkg_postrm() {
if use udev; then
udev_reload
fi
}

0 comments on commit 96e8dbc

Please sign in to comment.