Skip to content

Commit

Permalink
Merge pull request openwrt#4209 from lynxis/upstream-ipmis
Browse files Browse the repository at this point in the history
add ipmitool: Command-line interface to IPMI-enabled devices
  • Loading branch information
hnyman authored Apr 30, 2017
2 parents 092b4d0 + a1d8ddb commit 170258c
Showing 1 changed file with 53 additions and 0 deletions.
53 changes: 53 additions & 0 deletions admin/ipmitool/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
#
# Copyright (C) 2017 Alexander Couzens <[email protected]>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

include $(TOPDIR)/rules.mk

PKG_NAME:=ipmitool
PKG_VERSION:=1.8.18
PKG_RELEASE:=1

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_HASH:=0c1ba3b1555edefb7c32ae8cd6a3e04322056bc087918f07189eeedfc8b81e01
PKG_LICENSE:=BSD-3-clause
PKG_LICENSE_FILES:=COPYING

include $(INCLUDE_DIR)/package.mk

define Package/ipmitool
SECTION:=admin
CATEGORY:=Administration
DEPENDS:=+libopenssl +libncurses +libreadline
TITLE:=Command-line interface to IPMI-enabled devices
URL:=http://sourceforge.net/projects/ipmitool/
MAINTAINER:=Alexander Couzens <[email protected]>
endef

define Package/ipmitool/Default/description
Command-line interface to IPMI-enabled devices
endef

define Package/ipmitool/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ipmievd $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ipmitool $(1)/usr/sbin/
endef

define Package/ipmitool/conffiles
endef

CONFIGURE_ARGS += \
--enable-intf-lan \
--enable-intf-lanplus \
--enable-intf-serial \
--enable-intf-free \
--enable-intf-open \
--enable-intf-imb \
--enable-ipmishell

$(eval $(call BuildPackage,ipmitool))

0 comments on commit 170258c

Please sign in to comment.