Skip to content

Commit

Permalink
KDE Applications 19.08 beta
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@358165 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
antonio-rojas committed Jul 19, 2019
1 parent a992d5b commit cc09ff9
Show file tree
Hide file tree
Showing 222 changed files with 8,821 additions and 0 deletions.
36 changes: 36 additions & 0 deletions akonadi-calendar-tools/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-calendar-tools
pkgver=19.07.80
pkgrel=1
pkgdesc="CLI tools to manage akonadi calendars"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(calendarsupport)
makedepends=(extra-cmake-modules kdoctools boost)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('4c5ca4dbed2678fe07ffe1c1519eda9570bcaab5935331947c6ad252172bae96'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
34 changes: 34 additions & 0 deletions akonadi-calendar/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-calendar
pkgver=19.07.80
pkgrel=1
pkgdesc="Akonadi calendar integration"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(kmailtransport kcalutils akonadi-contacts)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('8e7902d090def7fca0486c0e827b3388a120e7862df03cab445aa7e26519d393'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
34 changes: 34 additions & 0 deletions akonadi-contacts/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-contacts
pkgver=19.07.80
pkgrel=1
pkgdesc="Libraries and daemons to implement Contact Management in Akonadi"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(libakonadi kcontacts kmime prison)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('d363f7b4bd6cbddc27ed8897d6567f2d35439687c521eba812f2f324e2a22573'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
37 changes: 37 additions & 0 deletions akonadi-import-wizard/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-import-wizard
pkgver=19.07.80
pkgrel=1
pkgdesc="Import data from other mail clients to KMail"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(mailcommon)
makedepends=(extra-cmake-modules boost kdoctools)
optdepends=('kdepim-addons: additional import plugins')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('e6e40b40fb049413d956b8d5b792cefee1ae6b7d509b25cd0159b624d9f772bf'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
34 changes: 34 additions & 0 deletions akonadi-mime/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-mime
pkgver=19.07.80
pkgrel=1
pkgdesc="Libraries and daemons to implement basic email handling"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(libakonadi kmime)
makedepends=(extra-cmake-modules kdoctools boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('a6ee12bc4156bc7023a94bc6f76dd8723c34e6adf3f99819c381c0758f454b7a'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
34 changes: 34 additions & 0 deletions akonadi-notes/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-notes
pkgver=19.07.80
pkgrel=1
pkgdesc="Libraries and daemons to implement management of notes in Akonadi"
arch=(x86_64)
url="https://kontact.kde.org"
license=(LGPL)
depends=(kmime)
makedepends=(extra-cmake-modules)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('416d29290460e264fcc635e70bb284921397984753cd8f97e788fb32968ba529'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
35 changes: 35 additions & 0 deletions akonadi-search/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Gustavo Alvarez <[email protected]>

pkgname=akonadi-search
pkgver=19.07.80
pkgrel=1
pkgdesc="Libraries and daemons to implement searching in Akonadi"
url='https://kontact.kde.org'
arch=(x86_64)
license=(GPL LGPL FDL)
depends=(xapian-core akonadi-mime kcontacts kcalcore krunner kcmutils)
makedepends=(extra-cmake-modules boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('a30458c314822209524fd9678645a57c94a5899a63702bb3d7e90bb04b882cf4'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
50 changes: 50 additions & 0 deletions akonadi/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Pierre Schmitz <[email protected]>

pkgbase=akonadi
pkgname=(akonadi libakonadi)
pkgver=19.07.80
pkgrel=1
pkgdesc="PIM layer, which provides an asynchronous API to access all kind of PIM data"
arch=(x86_64)
url='https://kontact.kde.org'
license=(LGPL)
makedepends=(extra-cmake-modules postgresql qt5-tools boost kdesignerplugin kio kitemmodels)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('df539ab1883915f35a1dfd94b0cafc016b36309064b4732966625e64191203b8'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package_libakonadi() {
pkgdesc='Libraries used by applications based on Akonadi'
depends=(kio kitemmodels hicolor-icon-theme)

cd build
make DESTDIR="$pkgdir" install
rm -r "$pkgdir"/usr/bin # Provided by akonadi
}

package_akonadi() {
depends=(libakonadi mariadb)
optdepends=('postgresql: PostgreSQL backend')

cd build
make DESTDIR="$pkgdir" install
rm -r "$pkgdir"/{etc,usr/{include,lib,share}} # Provided by libakonadi
}
36 changes: 36 additions & 0 deletions akonadiconsole/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadiconsole
pkgver=19.07.80
pkgrel=1
pkgdesc="Akonadi management and debugging console"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(calendarsupport messagelib)
makedepends=(extra-cmake-modules kdoctools boost)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('634257316035cefadd5311128ee065341a16909b9c0abdcd89cdf32ae2af2ce2'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
37 changes: 37 additions & 0 deletions akregator/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akregator
pkgver=19.07.80
pkgrel=1
pkgdesc="A Feed Reader by KDE"
arch=(x86_64)
url="https://kontact.kde.org"
license=(GPL2)
depends=(kontactinterface messagelib knotifyconfig ktexteditor syndication)
makedepends=(extra-cmake-modules boost kdoctools)
optdepends=('kdepim-addons: additional plugins')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('0bb2f3bd960c4f20c38a27ad3e30ff0810e06da515855a7bbdac3fe92a99fcdc'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
Loading

0 comments on commit cc09ff9

Please sign in to comment.