Tags: NVIDIA-Merlin/dataloader
Tags
update workflow on which docs pr preview depends (#141) Co-authored-by: Oliver Holworthy <[email protected]> Co-authored-by: Karl Higley <[email protected]>
adding ops-bot yaml file (#149) Co-authored-by: Oliver Holworthy <[email protected]>
Use Dictionary lookup for supplied IDs to Embedding Operator (#148) * Use lookup dict for Embedding operator with ids to speed up transform * Add test for embedding operator with unknown value * Update typehint for unknown_value * Remove embedding tag from input schema to embeddings tests The op now adds the embedding tag automatically, and the input schema cannot have both a CATEGORICAL and EMBEDDING tag * Flatten array passed as ids to EmbeddingOperator * Add assertion for ids shape * Set default value of `embedding_index_mapping` * Correct casing of message in test
Warn users when a batch size may not work on GPU (#136) * Warn users when a batch size may not work on GPU * lint
Replace `nnzs` with `row_lengths` for clarity (#99) * Replace `nnzs` with `row_lengths` for clarity The term `nnzs` (i.e. number of non-zeros) comes from sparse tensor nomenclature, but sparse tensors are an implementation detail of the dataloaders, not a domain concept we should be propagating throughout our code base. Instead, let's call them `row_lengths` which make sense as part of a ragged tensor representation throughout Merlin. * Autoupdate precommit package versions * Apply auto-formatting to appease the linter
PreviousNext