Skip to content

Commit

Permalink
Add Interix-specific system call bits.
Browse files Browse the repository at this point in the history
  • Loading branch information
tv committed Mar 10, 2005
1 parent 24839ff commit 01f69d2
Show file tree
Hide file tree
Showing 4 changed files with 43 additions and 13 deletions.
7 changes: 4 additions & 3 deletions shells/es/distinfo
Original file line number Diff line number Diff line change
@@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.6 2005/02/24 13:14:41 agc Exp $
$NetBSD: distinfo,v 1.7 2005/03/10 15:18:31 tv Exp $

SHA1 (es-0.9-alpha1.tar.gz) = 5027c9dade742c437b8e471a356d15883ebc4732
RMD160 (es-0.9-alpha1.tar.gz) = ca2307202ab6e65c49188e3228d1af6426a23952
Size (es-0.9-alpha1.tar.gz) = 125913 bytes
SHA1 (patch-aa) = 54f061989aa9317cdc32470302978129d8186b13
SHA1 (patch-ab) = bd58fbbf71d5c9dc76bdc380cb7b93ad3f5f1c72
SHA1 (patch-ac) = 52091c57f8f5bdcbf62069ae19200a7fc4bb88c0
SHA1 (patch-ad) = 6b292f5decf0dbd247450ffece21166e7da214d5
SHA1 (patch-ae) = f3b28abd1520c2d98e2424f45fc780ae09cc00ea
SHA1 (patch-ad) = ef0552148d9d0fdabb1dec72b3084eaaa33513c8
SHA1 (patch-ae) = 3625310b30bbf64f24d6efbcd1864b7e8a92ff59
SHA1 (patch-af) = e637be09b74092fb2fc5c34a7c09b824da4eea26
19 changes: 14 additions & 5 deletions shells/es/patches/patch-ad
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: patch-ad,v 1.3 2005/01/25 04:46:29 tv Exp $
$NetBSD: patch-ad,v 1.4 2005/03/10 15:18:31 tv Exp $

--- stdenv.h.orig 1995-05-30 13:13:53.000000000 +0200
+++ stdenv.h 2004-02-26 09:51:16.000000000 +0100
--- stdenv.h.orig 1995-05-30 07:13:53.000000000 -0400
+++ stdenv.h
@@ -44,9 +44,7 @@
#include <signal.h>
#include <ctype.h>
Expand All @@ -12,15 +12,24 @@ $NetBSD: patch-ad,v 1.3 2005/01/25 04:46:29 tv Exp $

#if REQUIRE_IOCTL
#include <sys/ioctl.h>
@@ -283,6 +281,7 @@
@@ -239,7 +237,7 @@ extern int getgroups(int, int *);
* hacks to present a standard system call interface
*/

-#ifdef linux
+#if defined(linux) || defined(__INTERIX)
#include "unistd.h"
#define setpgrp(a, b) setpgid(a, b)
#endif
@@ -283,6 +281,7 @@ extern int getgroups(int, int *);

/* stdlib */

+#if !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__INTERIX)
extern noreturn exit(int);
extern noreturn abort(void);
extern long strtol(const char *num, char **end, int base);
@@ -290,6 +289,7 @@
@@ -290,6 +289,7 @@ extern void *qsort(
void *base, size_t nmemb, size_t size,
int (*compar)(const void *, const void *)
);
Expand Down
10 changes: 5 additions & 5 deletions shells/es/patches/patch-ae
Original file line number Diff line number Diff line change
@@ -1,19 +1,19 @@
$NetBSD: patch-ae,v 1.1 2004/02/26 07:47:48 uebayasi Exp $
$NetBSD: patch-ae,v 1.2 2005/03/10 15:18:31 tv Exp $

--- util.c 1997/10/24 14:23:46 1.1
+++ util.c 1997/10/24 14:25:01
--- util.c.orig 1995-05-30 07:13:52.000000000 -0400
+++ util.c
@@ -2,6 +2,10 @@

#include "es.h"

+#include <sys/param.h>
+
+#if !(defined(BSD) && BSD >= 199306)
+#if !(defined(BSD) && BSD >= 199306) && !defined(__INTERIX)
+/* agc - just use the system strerror here */
/* strerror -- turn an error code into a string */
extern char *strerror(int n) {
extern int sys_nerr;
@@ -10,6 +14,7 @@
@@ -10,6 +14,7 @@ extern char *strerror(int n) {
return "unknown error";
return sys_errlist[n];
}
Expand Down
20 changes: 20 additions & 0 deletions shells/es/patches/patch-af
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
$NetBSD: patch-af,v 1.1 2005/03/10 15:18:31 tv Exp $

--- config.h.orig 1995-05-30 07:13:53.000000000 -0400
+++ config.h
@@ -378,6 +378,15 @@
#endif
#endif

+#ifdef __INTERIX
+#ifndef USE_WAIT3
+#define USE_WAIT3 0
+#endif
+#ifndef USE_SIGACTION
+#define USE_SIGACTION 1
+#endif
+#endif
+

/*
* default defaults -- don't change this section

0 comments on commit 01f69d2

Please sign in to comment.