Skip to content

Commit

Permalink
Update delegate to 5.9.3
Browse files Browse the repository at this point in the history
Notable changes are:
    1999-06-25 DeleGate/5.9.3 bug fix (cache/Linux), etc.
    1999-06-02 DeleGate/5.9.2 URICONV, Y2K, host=-Host, LDAP, etc.
    1999-03-15 DeleGate/5.9.1 bug fix (Win, HTTPS, filters, etc.)
    1999-03-09 DeleGate/5.9.0 MAX_ARGC, bug fix
  • Loading branch information
rh committed Aug 22, 1999
1 parent c93189c commit 03c2659
Show file tree
Hide file tree
Showing 5 changed files with 24 additions and 42 deletions.
12 changes: 8 additions & 4 deletions net/delegate/Makefile
Original file line number Diff line number Diff line change
@@ -1,16 +1,20 @@
# $NetBSD: Makefile,v 1.4 1999/04/04 18:01:38 hubertf Exp $
# $NetBSD: Makefile,v 1.5 1999/08/22 15:55:50 rh Exp $
# FreeBSD Id: Makefile,v 1.14 1998/11/09 09:24:20 max Exp
#

DISTNAME= delegate5.8.8
PKGNAME= delegate-5.8.8
DISTNAME= delegate5.9.3
PKGNAME= delegate-5.9.3
CATEGORIES= net
MASTER_SITES= ftp://etlport.etl.go.jp/pub/DeleGate/ \
ftp://ftp.kyushu-u.ac.jp/pub/Net/WWW/server/delegate/ \
ftp://ftp.nec.co.jp/pub/infosys/WWW/DeleGate/ \
ftp://ftp.fujitsu.co.jp/pub/networking/DeleGate/ \
ftp://ftp.u-aizu.ac.jp/pub/net/DeleGate/ \
ftp://ftp.eni.co.jp/pub/mirrors/delegate/
ftp://ftp.eni.co.jp/pub/mirrors/delegate/ \
ftp://ftp.ntua.gr/pub/net/gwtools/DeleGate/ \
ftp://ftp.netsw.org/netsw/Network/IP/Firewall/Proxy/delegate/ \
ftp://ftp.ecrc.net/pub/netsw/Network/IP/Firewall/Proxy/delegate/ \
ftp://ftp.ecrc.de/ftp/data/ftp.ecrc.net/pub/netsw/Network/IP/Firewall/Proxy/delegate/

MAINTAINER= [email protected]
HOMEPAGE= http://wall.etl.go.jp/delegate/
Expand Down
4 changes: 2 additions & 2 deletions net/delegate/files/md5
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 1999/02/23 18:28:35 rh Exp $
$NetBSD: md5,v 1.3 1999/08/22 15:55:51 rh Exp $

MD5 (delegate5.8.8.tar.gz) = e9df3c4e6fc2bb154f0f9f3f908276fe
MD5 (delegate5.9.3.tar.gz) = c7ebe910d48f9ff9e3a4ce9b0d97b9ad
6 changes: 3 additions & 3 deletions net/delegate/files/patch-sum
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 14:12:19 agc Exp $
$NetBSD: patch-sum,v 1.2 1999/08/22 15:55:51 rh Exp $

MD5 (patch-aa) = 60eb60f0b50ca56a79a71810c58bdb0d
MD5 (patch-aa) = eaad38bea7b23b391d45acdbe536049f
MD5 (patch-ab) = 9ec290fe19ec4b9a99a642865f0eb870
MD5 (patch-ac) = 1d7e7a4523da25d4fe2e90e6e92fdba5
MD5 (patch-ac) = a4d11fee5d789f3cc8cf32e086282e64
MD5 (patch-ad) = c0bcdf43f92e533f4f0ff9bb9f731e33
33 changes: 5 additions & 28 deletions net/delegate/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -1,39 +1,16 @@
$NetBSD: patch-aa,v 1.2 1999/02/23 18:28:35 rh Exp $
$NetBSD: patch-aa,v 1.3 1999/08/22 15:55:51 rh Exp $

--- src/lock.c.orig Tue Aug 4 09:13:18 1998
+++ src/lock.c Mon Feb 22 15:36:21 1999
--- src/lock.c.orig Wed Jun 23 09:28:03 1999
+++ src/lock.c Sun Aug 22 16:56:39 1999
@@ -18,6 +18,7 @@
History:
970403 extracted from cache.c
//////////////////////////////////////////////////////////////////////#*/
+#include <errno.h>
#include <stdio.h>
#include <sys/types.h>
extern double Time();
@@ -112,6 +113,22 @@
rcode = 0;
break;
}
+#ifdef EWOULDBLOCK
+ /*
+ * Only retry the lock if it was busy. Other
+ * possible sources for the lock to fail are:
+ * invalid argument, bad filedescriptor, and
+ * operation not supported by device. The latter
+ * happens if you start DeleGateD with -v, so it
+ * logs to stderr (which usually doesn't support
+ * locking at all).
+ */
+ if (rcode == -1 && errno != EWOULDBLOCK) {
+ /* pretend lock succeeded */
+ rcode = 0;
+ break;
+ }
+#endif
remain = timeout - elapsed;
if( remain <= 0 )
break;
@@ -122,6 +139,13 @@
#include <errno.h>
@@ -144,6 +145,13 @@

start = Time();
rcode = callFuncTimeout(remain/1000,-1,func,fd);
Expand Down
11 changes: 6 additions & 5 deletions net/delegate/patches/patch-ac
Original file line number Diff line number Diff line change
@@ -1,12 +1,13 @@
$NetBSD: patch-ac,v 1.1 1999/02/23 18:28:35 rh Exp $
$NetBSD: patch-ac,v 1.2 1999/08/22 15:55:51 rh Exp $

--- doc/Manual.txt.orig Wed Jan 13 13:29:59 1999
+++ doc/Manual.txt Tue Feb 23 15:56:56 1999
@@ -1,8 +1,3 @@
->>>>>>>>>>>>>>>>>>>>>>>>>>>>>> HALF DONE (^_^; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<
--- doc/Manual.txt.orig Wed Jun 2 05:31:41 1999
+++ doc/Manual.txt Sun Aug 22 17:05:59 1999
@@ -1,9 +1,3 @@
-
-((((((( ``DeleGate Home Page'' is at http://wall.etl.go.jp/delegate/ )))))))
-((((((( Read http://wall.etl.go.jp/delegate/tutorial/ first. )))))))
-
->>>>>>>>>>>>>>>>>>>>>>>>>>>>>> HALF DONE (^_^; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<
-
DELEGATED(8) MAINTENANCE COMMANDS DELEGATED(8)

Expand Down

0 comments on commit 03c2659

Please sign in to comment.