-
Notifications
You must be signed in to change notification settings - Fork 163
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Build modules with -fPIC. Bump revision. Add destdir support.
- Loading branch information
Showing
3 changed files
with
24 additions
and
6 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,15 +1,17 @@ | ||
# $NetBSD: Makefile,v 1.27 2008/04/12 22:43:13 jlam Exp $ | ||
# $NetBSD: Makefile,v 1.28 2009/11/26 17:16:47 joerg Exp $ | ||
# | ||
|
||
DISTNAME= golem-0.0.5 | ||
PKGREVISION= 3 | ||
PKGREVISION= 4 | ||
CATEGORIES= wm | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=golem/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://golem.sourceforge.net/ | ||
COMMENT= Fast and lightweight yet customizable window manager | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake yacc lex | ||
GNU_CONFIGURE= YES | ||
|
||
|
@@ -44,10 +46,13 @@ SUBST_FILES.paths= sample.golem/golemrc | |
SUBST_SED.paths+= -e 's,@PREFIX@,${PREFIX},g' | ||
SUBST_STAGE.paths= post-patch | ||
|
||
INSTALLATION_DIRS= ${EGDIR} | ||
INSTALL_MAKE_FLAGS+= prefix=${DESTDIR}${PREFIX} \ | ||
mandir=${DESTDIR}${PREFIX}/${PKGMANDIR} | ||
|
||
post-install: | ||
${RM} -f ${PREFIX}/share/golem/golemrc* | ||
${INSTALL_DATA_DIR} ${EGDIR} | ||
${INSTALL_DATA} ${WRKSRC}/sample.golem/golemrc ${EGDIR}/golemrc.default | ||
${RM} -f ${DESTDIR}${PREFIX}/share/golem/golemrc* | ||
${INSTALL_DATA} ${WRKSRC}/sample.golem/golemrc ${DESTDIR}${EGDIR}/golemrc.default | ||
|
||
BUILDLINK_DEPMETHOD.libXt?= build | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
$NetBSD: patch-ag,v 1.1 2009/11/26 17:16:47 joerg Exp $ | ||
|
||
--- plugins/Makefile.plugin.in.orig 2009-11-26 18:10:10.000000000 +0100 | ||
+++ plugins/Makefile.plugin.in | ||
@@ -1,6 +1,6 @@ | ||
# plugin makefiles include this | ||
CC= @CC@ | ||
-CFLAGS= @CFLAGS@ -I../../src/ -I../include/ @X_CFLAGS@ | ||
+CFLAGS= @CFLAGS@ -fPIC -I../../src/ -I../include/ @X_CFLAGS@ | ||
CFLAGS+= @DEFS@ | ||
LDFLAGS= @SHARED_FLAG@ | ||
|