Skip to content

Commit

Permalink
Convert to buildlink3.
Browse files Browse the repository at this point in the history
  • Loading branch information
snj committed Apr 11, 2004
1 parent 7f306eb commit 0865b39
Show file tree
Hide file tree
Showing 7 changed files with 38 additions and 18 deletions.
8 changes: 4 additions & 4 deletions chat/i2cb/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2004/03/08 19:52:50 minskim Exp $
# $NetBSD: Makefile,v 1.9 2004/04/11 05:48:49 snj Exp $
#

DISTNAME= i2cb-6.0_ALPHA
Expand All @@ -10,7 +10,7 @@ HOMEPAGE= http://www.draga.com/~jwise/i2cb/
COMMENT= Next generation Internet Citicen's Band chat client

WRKSRC= ${WRKDIR}/icb
USE_BUILDLINK2= yes
USE_BUILDLINK3= yes
USE_GNU_READLINE= yes

post-extract:
Expand All @@ -28,6 +28,6 @@ do-install:
${WRKSRC}/contrib/echofile \
${PREFIX}/libdata/i2cb

.include "../../lang/tcl83/buildlink2.mk"
.include "../../devel/readline/buildlink2.mk"
.include "../../lang/tcl83/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
4 changes: 2 additions & 2 deletions chat/i2cbd/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2003/10/24 21:12:18 jwise Exp $
# $NetBSD: Makefile,v 1.9 2004/04/11 05:50:10 snj Exp $
#

DISTNAME= i2cbd-2.0_BETA1
Expand All @@ -9,7 +9,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://www.draga.com/~jwise/i2cb/
COMMENT= Next generation Internet Citizens Band chat server

USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
USE_PKGINSTALL= YES

.include "../../mk/bsd.prefs.mk"
Expand Down
6 changes: 3 additions & 3 deletions chat/ircd-hybrid/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2004/01/22 08:47:32 grant Exp $
# $NetBSD: Makefile,v 1.10 2004/04/11 05:51:24 snj Exp $
#

DISTNAME= ircd-hybrid-6.2
Expand All @@ -13,7 +13,7 @@ COMMENT= IRC server with many options

GNU_CONFIGURE= YES

USE_BUILDLINK2= # defined
USE_BUILDLINK3= # defined
USE_PKGINSTALL= YES

PKG_SYSCONFSUBDIR= ircd-hybrid
Expand Down Expand Up @@ -146,5 +146,5 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/ircd-hybrid-6.2/doc/$$f ${PREFIX}/share/doc/ircd-hybrid/$$f ; \
done

.include "../../devel/zlib/buildlink2.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
6 changes: 3 additions & 3 deletions chat/ircservices/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2004/01/24 18:58:53 kristerw Exp $
# $NetBSD: Makefile,v 1.8 2004/04/11 05:53:08 snj Exp $
#

DISTNAME= ircservices-5.0.16
Expand All @@ -12,13 +12,13 @@ HOMEPAGE= http://www.ircservices.za.net/
COMMENT= Services for IRC networks

HAS_CONFIGURE= YES
USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
USE_GNU_TOOLS+= make

USE_GNU_TOOLS+= grep
USE_PERL5= build

CONFIGURE_ARGS= -prefix ${PREFIX}

.include "../../lang/perl5/buildlink2.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
8 changes: 4 additions & 4 deletions chat/libirc/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2004/02/14 17:21:34 jlam Exp $
# $NetBSD: Makefile,v 1.8 2004/04/11 05:55:45 snj Exp $
#

DISTNAME= libirc-0.2
Expand All @@ -8,11 +8,11 @@ MASTER_SITES= http://www.cs.kau.se/~jorgen/software/

MAINTAINER= [email protected]
HOMEPAGE= http://www.cs.kau.se/~jorgen/software/
COMMENT= libirc is a C-library for the IRC protocol
COMMENT= C library for the IRC protocol

GNU_CONFIGURE= yes
USE_BUILDLINK2= yes
USE_BUILDLINK3= yes
USE_LIBTOOL= yes

.include "../../devel/glib/buildlink2.mk"
.include "../../devel/glib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
20 changes: 20 additions & 0 deletions chat/libirc/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
# $NetBSD: buildlink3.mk,v 1.1 2004/04/11 05:55:45 snj Exp $

BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
LIBIRC_BUILDLINK3_MK:= ${LIBIRC_BUILDLINK3_MK}+

.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= libirc
.endif

BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibirc}
BUILDLINK_PACKAGES+= libirc

.if !empty(LIBIRC_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.libirc+= libirc>=0.2nb1
BUILDLINK_PKGSRCDIR.libirc?= ../../chat/libirc
.endif # LIBIRC_BUILDLINK3_MK

.include "../../devel/glib/buildlink3.mk"

BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}
4 changes: 2 additions & 2 deletions chat/ninja/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.5 2004/01/22 07:49:20 grant Exp $
# $NetBSD: Makefile,v 1.6 2004/04/11 05:57:30 snj Exp $
#

DISTNAME= ninja-1.5.8.1
Expand All @@ -9,7 +9,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://ninja.qoop.org/
COMMENT= Another IRC client based on ircII

USE_BUILDLINK2= YES
USE_BUILDLINK3= YES
GNU_CONFIGURE= YES
USE_GNU_TOOLS+= make

Expand Down

0 comments on commit 0865b39

Please sign in to comment.