-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
audiocd/cdparanoia patches from Chris Gilbert. Changes: * KRec: Corrected calculation of position in KB. * kio (audiocd): Fix kio-audiocd gives no error message when device permissions are wrong * kio (audiocd): Fix kaudiocreator error "/By Track/Track 01.wav" should start with "audiocd:/" * kmid: Fix KMid doesn't support international characters * juk: Fix Not adding m3u, pls... lists when refreshing directory * juk: Fix Show Total running time of selection/playlist * juk: Fix extra option (random play) in popup-window * juk: Fix TimeLeft widget listens to too many signals * juk: Fix Juk crashed when I was retagging a bunch of songs and started to play with search * Fix FLAC dependency isn't mentioned anywhere and can cause compilation errors * Fix kdemultimedia build fails with parallel make * configure: Fix Extraneous message in admin/Makefile.common using --prefix * kmix: Fix the executable linking against the part, by adding a common library.
- Loading branch information
markd
committed
Apr 20, 2004
1 parent
62a449c
commit 0bef727
Showing
8 changed files
with
139 additions
and
32 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2004/04/20 13:13:42 markd Exp $ | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+ | ||
KDEMULTIMEDIA_BUILDLINK3_MK:= ${KDEMULTIMEDIA_BUILDLINK3_MK}+ | ||
|
||
.if !empty(BUILDLINK_DEPTH:M+) | ||
BUILDLINK_DEPENDS+= kdemultimedia | ||
.endif | ||
|
||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nkdemultimedia} | ||
BUILDLINK_PACKAGES+= kdemultimedia | ||
|
||
.if !empty(KDEMULTIMEDIA_BUILDLINK3_MK:M+) | ||
BUILDLINK_DEPENDS.kdemultimedia+= kdemultimedia>=3.2.2 | ||
BUILDLINK_PKGSRCDIR.kdemultimedia?= ../../multimedia/kdemultimedia3 | ||
.endif # KDEMULTIMEDIA_BUILDLINK3_MK | ||
|
||
.include "../../audio/musicbrainz/buildlink3.mk" | ||
.include "../../audio/taglib/buildlink3.mk" | ||
.include "../../audio/arts/buildlink3.mk" | ||
.include "../../multimedia/xine-lib/buildlink3.mk" | ||
.include "../../x11/kdebase3/buildlink3.mk" | ||
.include "../../x11/kdelibs3/buildlink3.mk" | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-ab,v 1.3 2004/04/20 13:13:42 markd Exp $ | ||
|
||
--- mpeglib/lib/input/cddaInputStream.h.orig 2004-04-12 15:12:43.000000000 +0100 | ||
+++ mpeglib/lib/input/cddaInputStream.h 2004-04-12 15:13:01.000000000 +0100 | ||
@@ -33,8 +33,8 @@ | ||
typedef int32_t size32; | ||
|
||
extern "C" { | ||
-#include <cdda_interface.h> | ||
-#include <cdda_paranoia.h> | ||
+#include <cdparanoia/cdda_interface.h> | ||
+#include <cdparanoia/cdda_paranoia.h> | ||
void paranoiaCallback(long, int); | ||
} | ||
//#define CDDA_INCLUDE |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-ac,v 1.3 2004/04/20 13:13:42 markd Exp $ | ||
|
||
--- mpeglib/lib/decoder/cddaPlugin.cpp.orig 2004-04-12 16:32:14.000000000 +0100 | ||
+++ mpeglib/lib/decoder/cddaPlugin.cpp 2004-04-12 16:32:31.000000000 +0100 | ||
@@ -25,8 +25,8 @@ | ||
typedef int32_t size32; | ||
|
||
extern "C" { | ||
-#include <cdda_interface.h> | ||
-#include <cdda_paranoia.h> | ||
+#include <cdparanoia/cdda_interface.h> | ||
+#include <cdparanoia/cdda_paranoia.h> | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters