-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Update to 1.3.31. Changes since 1.2.0:
Implement Parallel Index Lines (PILs) Use an EBL to generate a perpendicular index line Allow Ctrl-Left Mouse click to select multiple boundaries. Right click then allows Merge with keep and Merge with delete Add ability to move boundaries and point using left click and drag. Ability is set in general properties of plugin Add ability to constrain boundary movement Add ability to move a single boundary segment
- Loading branch information
bouyer
committed
Apr 14, 2017
1 parent
0175fba
commit 146bc73
Showing
4 changed files
with
46 additions
and
42 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,15 +1,14 @@ | ||
# $NetBSD: Makefile,v 1.8 2017/02/12 06:25:23 ryoon Exp $ | ||
# $NetBSD: Makefile,v 1.9 2017/04/14 16:28:40 bouyer Exp $ | ||
# | ||
|
||
VERSION= 1.2.0 | ||
VERSION= 1.3.31 | ||
#PKGREVISION= 2 | ||
DISTNAME= ocpn_draw_pi-${VERSION} | ||
PKGNAME= opencpn-plugin-draw-${VERSION} | ||
PKGREVISION= 3 | ||
CATEGORIES= geography | ||
MASTER_SITES= ${MASTER_SITE_GITHUB:=jongough/} | ||
GITHUB_PROJECT= ocpn_draw_pi | ||
GITHUB_TAG= 64ea0fb527069231d3d1b9519628f722348ebd6f | ||
GITHUB_TAG= 0ec00a16785bbaa786f99f19ac9f8a6a5558e500 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://opencpn.org/ocpn/Plugins_external_odraw | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,8 @@ | ||
$NetBSD: distinfo,v 1.6 2016/07/18 14:18:51 bouyer Exp $ | ||
$NetBSD: distinfo,v 1.7 2017/04/14 16:28:40 bouyer Exp $ | ||
|
||
SHA1 (ocpn_draw_pi-1.2.0-64ea0fb527069231d3d1b9519628f722348ebd6f.tar.gz) = c6abb6bec42e2d5d24f4a58d970381574a185954 | ||
RMD160 (ocpn_draw_pi-1.2.0-64ea0fb527069231d3d1b9519628f722348ebd6f.tar.gz) = 779d5602050c2db32b33f239e51278943bcdff03 | ||
SHA512 (ocpn_draw_pi-1.2.0-64ea0fb527069231d3d1b9519628f722348ebd6f.tar.gz) = f6e9e0fe1670029ea1ac60e74845060e0e84c9272b918bb411854e512eacd5792123c0aed845706a14691d2c63f328419dedfcff3a8b6f03eee02a3fdfa40452 | ||
Size (ocpn_draw_pi-1.2.0-64ea0fb527069231d3d1b9519628f722348ebd6f.tar.gz) = 1335780 bytes | ||
SHA1 (patch-cmake_PluginConfigure.cmake) = 62dbbc6d13959fa313e6ea91ad6a28ee37da5fdd | ||
SHA1 (ocpn_draw_pi-1.3.31-0ec00a16785bbaa786f99f19ac9f8a6a5558e500.tar.gz) = 4b75516efa9c4db4f6483086346c4f1fb3155eab | ||
RMD160 (ocpn_draw_pi-1.3.31-0ec00a16785bbaa786f99f19ac9f8a6a5558e500.tar.gz) = 630065b71581d215c755807708df1fb76eb64710 | ||
SHA512 (ocpn_draw_pi-1.3.31-0ec00a16785bbaa786f99f19ac9f8a6a5558e500.tar.gz) = 4d1b6f7d27bcca5620a80b8b04676f0100e81e8cde04671d1b71ce13fb9e3ea92c6a127bb6214161f066e93fc335ad7ceca47b6c13f7be8773577971b90edffc | ||
Size (ocpn_draw_pi-1.3.31-0ec00a16785bbaa786f99f19ac9f8a6a5558e500.tar.gz) = 1258618 bytes | ||
SHA1 (patch-cmake_PluginConfigure.cmake) = e5fc9c0516c93ebe36cc83dce7703769266dfd5d | ||
SHA1 (patch-cmake_PluginInstall.cmake) = 43a906b0a75a1e358ccd96992e1c14d526d07b4b |
17 changes: 8 additions & 9 deletions
17
geography/opencpn-plugin-draw/patches/patch-cmake_PluginConfigure.cmake
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,23 +1,22 @@ | ||
$NetBSD: patch-cmake_PluginConfigure.cmake,v 1.2 2016/05/21 10:50:41 bouyer Exp $ | ||
$NetBSD: patch-cmake_PluginConfigure.cmake,v 1.3 2017/04/14 16:28:40 bouyer Exp $ | ||
Do not overwrite CMAKE_SHARED_LINKER_FLAGS | ||
|
||
--- cmake/PluginConfigure.cmake.orig 2016-04-13 08:28:11.000000000 +0200 | ||
+++ cmake/PluginConfigure.cmake 2016-05-21 12:20:47.579936156 +0200 | ||
--- cmake/PluginConfigure.cmake.orig 2017-03-12 09:27:12.000000000 +0100 | ||
+++ cmake/PluginConfigure.cmake 2017-04-14 13:29:02.000000000 +0200 | ||
@@ -45,11 +45,13 @@ | ||
# ADD_DEFINITIONS( "-Wall -Wno-unused-result -g -O2 -fexceptions" ) | ||
ENDIF(PROFILING) | ||
|
||
- IF(NOT APPLE) | ||
- SET(CMAKE_SHARED_LINKER_FLAGS "-Wl,-Bsymbolic") | ||
- ELSE(NOT APPLE) | ||
+ IF(CMAKE_SYSTEM_NAME MATCHES ".*Linux") | ||
+ SET(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,-Bsymbolic") | ||
+ ADD_DEFINITIONS( "-fPIC") | ||
SET( CMAKE_SHARED_LINKER_FLAGS "-Wl,-Bsymbolic") | ||
- ELSE(NOT APPLE) | ||
+ ADD_DEFINITIONS( "-fPIC") | ||
+ ENDIF(CMAKE_SYSTEM_NAME MATCHES ".*Linux") | ||
+ IF(APPLE) | ||
SET(CMAKE_SHARED_LINKER_FLAGS "-Wl -undefined dynamic_lookup") | ||
SET( CMAKE_SHARED_LINKER_FLAGS "-Wl -undefined dynamic_lookup") | ||
- ENDIF(NOT APPLE) | ||
+ ENDIF(APPLE) | ||
|
||
ENDIF(NOT MSVC) | ||
|
||
ENDIF(NOT MSVC) |