-
Notifications
You must be signed in to change notification settings - Fork 163
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Move Xrandr to liboldXrandr (name suggested by joerg) so it can be
checked out on a case-insensitive filesystem without interfering with lowercase xrandr. PKGNAME stays the same. Moved Xrandr to Xrandr-mixedcase in the repository [schmonz 2007-06-07]
- Loading branch information
Showing
8 changed files
with
216 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
This package contains the X RandR extension. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# $NetBSD: Makefile,v 1.1 2007/05/30 01:22:12 schmonz Exp $ | ||
# | ||
|
||
DISTNAME= libXrandr-1.0.2 | ||
PKGNAME= Xrandr-1.0.2 | ||
PKGREVISION= 3 | ||
CATEGORIES= x11 devel | ||
MASTER_SITES= http://xlibs.freedesktop.org/release/ | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://xlibs.freedesktop.org/ | ||
COMMENT= X RandR extension (Library) | ||
|
||
CONFLICTS+= libXrandr-[0-9]* | ||
|
||
PKG_INSTALLATION_TYPES= overwrite pkgviews | ||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= pkg-config | ||
USE_LIBTOOL= yes | ||
GNU_CONFIGURE= yes | ||
|
||
PKGCONFIG_OVERRIDE+= xrandr.pc.in | ||
|
||
BUILDLINK_API_DEPENDS.Xrender+= Xrender>=0.8 | ||
|
||
.include "../../x11/libXext/buildlink3.mk" | ||
.include "../../x11/libXrender/buildlink3.mk" | ||
.include "../../x11/randrproto/buildlink3.mk" | ||
.include "../../x11/xextproto/buildlink3.mk" | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
@comment $NetBSD: PLIST,v 1.1 2007/05/30 01:22:12 schmonz Exp $ | ||
include/X11/extensions/Xrandr.h | ||
lib/libXrandr.la | ||
lib/pkgconfig/xrandr.pc |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
# $NetBSD: buildlink3.mk,v 1.1 2007/05/30 01:22:12 schmonz Exp $ | ||
|
||
.include "../../mk/bsd.fast.prefs.mk" | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+ | ||
XRANDR_BUILDLINK3_MK:= ${XRANDR_BUILDLINK3_MK}+ | ||
|
||
.if !empty(BUILDLINK_DEPTH:M+) | ||
BUILDLINK_DEPENDS+= Xrandr | ||
.endif | ||
|
||
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:NXrandr} | ||
BUILDLINK_PACKAGES+= Xrandr | ||
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}Xrandr | ||
|
||
.if !empty(XRANDR_BUILDLINK3_MK:M+) | ||
BUILDLINK_API_DEPENDS.Xrandr+= Xrandr>=0.99 | ||
BUILDLINK_ABI_DEPENDS.Xrandr+= Xrandr>=1.0.2nb3 | ||
BUILDLINK_PKGSRCDIR.Xrandr?= ../../x11/Xrandr | ||
.endif # XRANDR_BUILDLINK3_MK | ||
|
||
.include "../../x11/libXrender/buildlink3.mk" | ||
.include "../../x11/randrproto/buildlink3.mk" | ||
|
||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,113 @@ | ||
# $NetBSD: builtin.mk,v 1.1 2007/05/30 01:22:13 schmonz Exp $ | ||
|
||
BUILTIN_PKG:= Xrandr | ||
|
||
BUILTIN_FIND_FILES_VAR:= H_XRANDR | ||
BUILTIN_FIND_FILES.H_XRANDR= ${X11BASE}/include/X11/extensions/Xrandr.h | ||
|
||
.include "../../mk/buildlink3/bsd.builtin.mk" | ||
|
||
### | ||
### Determine if there is a built-in implementation of the package and | ||
### set IS_BUILTIN.<pkg> appropriately ("yes" or "no"). | ||
### | ||
.if !defined(IS_BUILTIN.Xrandr) | ||
IS_BUILTIN.Xrandr= no | ||
. if empty(H_XRANDR:M__nonexistent__) | ||
BUILTIN_IMAKE_CHECK:= Xrandr:BuildRandRLibrary | ||
. include "../../mk/buildlink3/imake-check.mk" | ||
IS_BUILTIN.Xrandr= ${BUILTIN_IMAKE_CHECK.Xrandr} | ||
. endif | ||
.endif | ||
MAKEVARS+= IS_BUILTIN.Xrandr | ||
|
||
### | ||
### If there is a built-in implementation, then set BUILTIN_PKG.<pkg> to | ||
### a package name to represent the built-in package. | ||
### | ||
.if !defined(BUILTIN_PKG.Xrandr) && \ | ||
!empty(IS_BUILTIN.Xrandr:M[yY][eE][sS]) && \ | ||
empty(H_XRANDR:M__nonexistent__) | ||
# | ||
# Xrandr doesn't provide a method of discovering the version number of | ||
# the software. Match up Xrandr versions with X11 versions for an | ||
# approximate determination of the Xrandr version. | ||
# | ||
_BLTN_XRANDR_VERSIONS= 1.0.2 1.0.1 1.0 0.99 | ||
_BLTN_XRANDR_0.99.XFree86= 4.2 4.2.* | ||
_BLTN_XRANDR_1.0.XFree86= 4.3 4.3.[0-9] 4.3.[0-9].* \ | ||
4.3.[1-8][0-9]* 4.3.9[0-8]* \ | ||
4.3.99.* 4.[4-9]* 4.[1-9][0-9]* | ||
_BLTN_XRANDR_1.0.xorg= 6.[7-9]* 6.[1-9][0-9]* | ||
. for _version_ in ${_BLTN_XRANDR_VERSIONS} | ||
. for _pattern_ in ${_BLTN_XRANDR_${_version_}.${BUILTIN_X11_TYPE.${X11_TYPE}}} | ||
. if defined(BUILTIN_X11_VERSION.${X11_TYPE}) && \ | ||
!empty(BUILTIN_X11_VERSION.${X11_TYPE}:M${_pattern_}) | ||
BUILTIN_VERSION.Xrandr?= ${_version_} | ||
. endif | ||
. endfor | ||
. endfor | ||
. if defined(BUILTIN_VERSION.Xrandr) | ||
BUILTIN_PKG.Xrandr= Xrandr-${BUILTIN_VERSION.Xrandr} | ||
. endif | ||
.endif | ||
MAKEVARS+= BUILTIN_PKG.Xrandr | ||
|
||
### | ||
### Determine whether we should use the built-in implementation if it | ||
### exists, and set USE_BUILTIN.<pkg> appropriate ("yes" or "no"). | ||
### | ||
# | ||
# These are dependencies of Xrandr. If we need to use the pkgsrc | ||
# versions of any of these, then also use the pkgsrc version of | ||
# Xrandr. | ||
# | ||
.if defined(USE_BUILTIN.Xrender) && !empty(USE_BUILTIN.Xrender:M[nN][oO]) | ||
USE_BUILTIN.Xrender= no | ||
.endif | ||
.if defined(USE_BUILTIN.randrproto) && !empty(USE_BUILTIN.randrproto:M[nN][oO]) | ||
USE_BUILTIN.randrproto= no | ||
.endif | ||
|
||
.if !defined(USE_BUILTIN.Xrandr) | ||
. if ${PREFER.Xrandr} == "pkgsrc" | ||
USE_BUILTIN.Xrandr= no | ||
. else | ||
USE_BUILTIN.Xrandr= ${IS_BUILTIN.Xrandr} | ||
. if defined(BUILTIN_PKG.Xrandr) && \ | ||
!empty(IS_BUILTIN.Xrandr:M[yY][eE][sS]) | ||
USE_BUILTIN.Xrandr= yes | ||
. for _dep_ in ${BUILDLINK_API_DEPENDS.Xrandr} | ||
. if !empty(USE_BUILTIN.Xrandr:M[yY][eE][sS]) | ||
USE_BUILTIN.Xrandr!= \ | ||
if ${PKG_ADMIN} pmatch ${_dep_:Q} ${BUILTIN_PKG.Xrandr:Q}; then \ | ||
${ECHO} yes; \ | ||
else \ | ||
${ECHO} no; \ | ||
fi | ||
. endif | ||
. endfor | ||
. endif | ||
. endif # PREFER.Xrandr | ||
.endif | ||
MAKEVARS+= USE_BUILTIN.Xrandr | ||
|
||
### | ||
### The section below only applies if we are not including this file | ||
### solely to determine whether a built-in implementation exists. | ||
### | ||
CHECK_BUILTIN.Xrandr?= no | ||
.if !empty(CHECK_BUILTIN.Xrandr:M[nN][oO]) | ||
|
||
. if !empty(USE_BUILTIN.Xrandr:M[nN][oO]) | ||
BUILDLINK_API_DEPENDS.Xrandr+= Xrandr>=1.0.1 | ||
BUILDLINK_API_DEPENDS.Xrender+= Xrender>=0.8 | ||
. endif | ||
|
||
. if !empty(USE_BUILTIN.Xrandr:M[yY][eE][sS]) | ||
BUILDLINK_PREFIX.Xrandr= ${X11BASE} | ||
USE_BUILTIN.Xrender= yes | ||
USE_BUILTIN.randrproto= yes | ||
. endif | ||
|
||
.endif # CHECK_BUILTIN.Xrandr |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
$NetBSD: distinfo,v 1.1 2007/05/30 01:22:13 schmonz Exp $ | ||
|
||
SHA1 (libXrandr-1.0.2.tar.bz2) = 9d0d5fe7ddab5c976a75cc848afa56aa6beabf18 | ||
RMD160 (libXrandr-1.0.2.tar.bz2) = a75443dabe360398d8de287f6885cd7569190132 | ||
Size (libXrandr-1.0.2.tar.bz2) = 187231 bytes | ||
SHA1 (patch-aa) = a8e0b3ef460f21125ebf9058dcaa3d9066e06841 | ||
SHA1 (patch-ab) = 54d37f78e7f61cb82957b7526e2a426bf1e41d8a |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
$NetBSD: patch-aa,v 1.1 2007/05/30 01:22:13 schmonz Exp $ | ||
|
||
--- configure.orig 2003-12-04 18:33:43.000000000 +0100 | ||
+++ configure | ||
@@ -19967,9 +19967,9 @@ echo "${ECHO_T}$RANDR_LIBS" >&6 | ||
if test $succeeded = yes; then | ||
: | ||
else | ||
- { { echo "$as_me:$LINENO: error: Library requirements (randr >= $RANDR_VERSION xext xrender) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5 | ||
-echo "$as_me: error: Library requirements (randr >= $RANDR_VERSION xext xrender) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;} | ||
- { (exit 1); exit 1; }; } | ||
+ RANDR_CFLAGS="$CFLAGS" | ||
+ RANDR_LIBS="$LDFLAGS" | ||
+ X_LIBS="-lXrender -lXext $X_LIBS" | ||
fi | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
$NetBSD: patch-ab,v 1.1 2007/05/30 01:22:13 schmonz Exp $ | ||
|
||
--- Xrandr.c.orig 2003-05-28 00:26:42.000000000 +0200 | ||
+++ Xrandr.c | ||
@@ -27,10 +27,9 @@ | ||
#include <stdio.h> | ||
#include <X11/Xlib.h> | ||
/* we need to be able to manipulate the Display structure on events */ | ||
-#include <X11/Xlibint.h> | ||
+#include "Xrandrint.h" | ||
#include <X11/extensions/render.h> | ||
#include <X11/extensions/Xrender.h> | ||
-#include "Xrandrint.h" | ||
|
||
XExtensionInfo XRRExtensionInfo; | ||
char XRRExtensionName[] = RANDR_NAME; |