-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Rewrite the extraction commands to be more intuitive.
In the vast majority of cases, nothing has changed (i.e. .tgz, .tar.gz, and .tar.bz2). EXTRACT_USING_PAX can be set as before. For custom extractions, instead of using EXTRACT_BEFORE_ARGS, EXTRACT_AFTER_ARGS and EXTRACT_CMD, simply set EXTRACT_CMD to be the command needed to decompress and extract the lements from the archive. ${DOWNLOADED_DISTFILE} can be used to reference the distfile(s). e.g. for compressed shars, where previously there was: EXTRACT_CMD= ${GZCAT} EXTRACT_BEFORE_ARGS= EXTRACT_AFTER_ARGS= |sh now use: EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH}
- Loading branch information
agc
committed
Apr 1, 1999
1 parent
cedce59
commit 171e025
Showing
26 changed files
with
79 additions
and
95 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.7 1998/11/12 15:19:59 agc Exp $ | ||
# $NetBSD: Makefile,v 1.8 1999/04/01 14:07:52 agc Exp $ | ||
|
||
DISTNAME= macutil2.0b3 | ||
PKGNAME= macutil-2.0b3 | ||
|
@@ -9,9 +9,7 @@ EXTRACT_SUFX= .shar.Z | |
MAINTAINER= [email protected] | ||
|
||
MAKEFILE= makefile | ||
EXTRACT_CMD= zcat | ||
EXTRACT_BEFORE_ARGS= | ||
EXTRACT_AFTER_ARGS= |sh | ||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH} | ||
|
||
WRKSRC= ${WRKDIR}/macutil | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.12 1999/03/28 15:34:24 hubertf Exp $ | ||
# $NetBSD: Makefile,v 1.13 1999/04/01 14:07:52 agc Exp $ | ||
# FreeBSD Id: Makefile,v 1.7 1997/08/10 22:31:27 fenner Exp | ||
# | ||
|
||
|
@@ -15,8 +15,7 @@ MAINTAINER= [email protected] | |
NO_PACKAGE= Only unmodified original package can be distributed | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= | ||
EXTRACT_BEFORE_ARGS= | ||
EXTRACT_CMD= ${DOWNLOADED_DISTFILE} | ||
|
||
pre-extract: | ||
chmod a+x ${DISTDIR}/${DISTFILES} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.6 1999/02/10 18:49:17 explorer Exp $ | ||
# $NetBSD: Makefile,v 1.7 1999/04/01 14:07:52 agc Exp $ | ||
# FreeBSD: Makefile,v 1.1.1.1 1998/06/15 18:09:43 ghelmer Exp | ||
# | ||
|
||
|
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tar | |
MAINTAINER= [email protected] | ||
HOMEPAGE= http://www.scl.ameslab.gov/Projects/HINT/ | ||
|
||
EXTRACT_BEFORE_ARGS=-xf | ||
EXTRACT_CMD= ${GTAR} -xf ${DOWNLOADED_DISTFILE} | ||
WRKSRC= ${WRKDIR}/unix | ||
ALL_TARGET= DOUBLE INT | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.5 1999/03/16 08:53:43 agc Exp $ | ||
# $NetBSD: Makefile,v 1.6 1999/04/01 14:07:53 agc Exp $ | ||
|
||
DISTNAME= paranoia | ||
PKGNAME= paranoia-960101 | ||
|
@@ -9,9 +9,7 @@ EXTRACT_SUFX= .c | |
MAINTAINER= [email protected] | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= ${CP} | ||
EXTRACT_BEFORE_ARGS= #empty | ||
EXTRACT_AFTER_ARGS= ${WRKSRC} | ||
EXTRACT_CMD= ${CP} ${DOWNLOADED_DISTFILE} ${WRKSRC} | ||
|
||
do-build: | ||
(cd ${WRKSRC} ; ${CC} -ffloat-store -o paranoia paranoia.c -lm) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.5 1999/03/16 09:02:27 agc Exp $ | ||
# $NetBSD: Makefile,v 1.6 1999/04/01 14:07:53 agc Exp $ | ||
|
||
DISTNAME= whetstone | ||
PKGNAME= whetstone-1.2 | ||
|
@@ -9,9 +9,7 @@ EXTRACT_SUFX= .c | |
MAINTAINER= [email protected] | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= ${CP} | ||
EXTRACT_BEFORE_ARGS= #empty | ||
EXTRACT_AFTER_ARGS= ${WRKSRC} | ||
EXTRACT_CMD= ${CP} ${DOWNLOADED_DISTFILE} ${WRKSRC} | ||
|
||
do-build: | ||
(cd ${WRKSRC} ; ${CC} -O2 -o whetstone whetstone.c -lm) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 1999/03/03 00:06:53 kim Exp $ | ||
# $NetBSD: Makefile,v 1.2 1999/04/01 14:07:53 agc Exp $ | ||
|
||
DISTNAME= perl5.004_04 | ||
PKGNAME= p5-gdbm-5.4.4 | ||
|
@@ -11,7 +11,7 @@ MAINTAINER= [email protected] | |
USE_PERL5= YES | ||
DEPENDS+= gdbm-1.7.3:../../databases/gdbm | ||
|
||
EXTRACT_AFTER_ARGS= perl5.004_04/ext/GDBM_File | ||
EXTRACT_ELEMENTS= perl5.004_04/ext/GDBM_File | ||
WRKSRC= ${WRKDIR}/${EXTRACT_AFTER_ARGS} | ||
|
||
do-configure: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.8 1999/02/04 18:54:35 agc Exp $ | ||
# $NetBSD: Makefile,v 1.9 1999/04/01 14:07:56 agc Exp $ | ||
# FreeBSD Id: Makefile,v 1.3 1996/11/12 02:19:40 obrien Exp | ||
# | ||
|
||
|
@@ -11,9 +11,7 @@ EXTRACT_SUFX= .msg.gz | |
MAINTAINER= [email protected] | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= zcat | ||
EXTRACT_BEFORE_ARGS= | ||
EXTRACT_AFTER_ARGS= |sh | ||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH} | ||
|
||
OPSYS!= uname -s | ||
.if (${OPSYS} == "NetBSD") | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.1 1998/09/07 03:23:09 garbled Exp $ | ||
# $NetBSD: Makefile,v 1.2 1999/04/01 14:07:53 agc Exp $ | ||
|
||
DISTNAME= svb | ||
PKGNAME= svb-1.0 | ||
|
@@ -10,9 +10,7 @@ MAINTAINER= [email protected] | |
|
||
USE_IMAKE= yes | ||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= zcat | ||
EXTRACT_BEFORE_ARGS= #empty | ||
EXTRACT_AFTER_ARGS= |sh | ||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH} | ||
NO_INSTALL_MANPAGES= yes | ||
|
||
post-install: | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.2 1998/08/20 15:17:08 tsarna Exp $ | ||
# $NetBSD: Makefile,v 1.3 1999/04/01 14:07:54 agc Exp $ | ||
# | ||
|
||
DISTNAME= html-1.5.1 | ||
|
@@ -10,7 +10,6 @@ EXTRACT_SUFX= .tgz | |
MAINTAINER= [email protected] | ||
HOMEPAGE= http://www.python.org/doc/ | ||
|
||
EXTRACT_ONLY= | ||
NO_CONFIGURE= yes | ||
NO_BUILD= yes | ||
|
||
|
@@ -20,10 +19,7 @@ PLIST_SRC= ${WRKDIR}/.PLIST_SRC | |
do-install: | ||
${INSTALL_DATA_DIR} ${PREFIX}/${HTMLDIR} | ||
${CAT} ${PKGDIR}/PLIST.pre >${PLIST_SRC} | ||
(cd ${PREFIX}/${HTMLDIR}; \ | ||
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \ | ||
${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} \ | ||
${EXTRACT_AFTER_ARGS}) | ||
(cd ${WRKSRC}; pax -r -w -v -p -e . ${PREFIX}/${HTMLDIR}) | ||
(cd ${PREFIX}; find ${HTMLDIR} -type f -print >>${PLIST_SRC}) | ||
(cd ${PREFIX}; find -d ${HTMLDIR} -type d -print | \ | ||
${SED} -e "s/^/@dirrm /" >>${PLIST_SRC}) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.9 1998/08/20 15:17:23 tsarna Exp $ | ||
# $NetBSD: Makefile,v 1.10 1999/04/01 14:07:55 agc Exp $ | ||
# FreeBSD Id: Makefile,v 1.4 1997/05/28 06:18:20 fenner Exp | ||
# | ||
|
||
|
@@ -11,9 +11,7 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://dhog.g7.org/dhog/9wm.html | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= zcat | ||
EXTRACT_BEFORE_ARGS= | ||
EXTRACT_AFTER_ARGS= |sh | ||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH} | ||
USE_IMAKE= yes | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.8 1999/02/04 18:54:35 agc Exp $ | ||
# $NetBSD: Makefile,v 1.9 1999/04/01 14:07:56 agc Exp $ | ||
# FreeBSD Id: Makefile,v 1.3 1996/11/12 02:19:40 obrien Exp | ||
# | ||
|
||
|
@@ -11,9 +11,7 @@ EXTRACT_SUFX= .msg.gz | |
MAINTAINER= [email protected] | ||
|
||
NO_WRKSUBDIR= yes | ||
EXTRACT_CMD= zcat | ||
EXTRACT_BEFORE_ARGS= | ||
EXTRACT_AFTER_ARGS= |sh | ||
EXTRACT_CMD= ${GZCAT} ${DOWNLOADED_DISTFILE} | ${SH} | ||
|
||
OPSYS!= uname -s | ||
.if (${OPSYS} == "NetBSD") | ||
|
Oops, something went wrong.