Skip to content

Commit

Permalink
py-django-treebeard: updated to 4.7
Browse files Browse the repository at this point in the history
Release 4.7 (Apr 7, 2023)

Drop support for Django 4.0.
Add support for Django 4.2.


Release 4.6.1 (Feb 5, 2023)

Fix unescaped string representation of AL_Node models in the Django admin. Thanks to goodguyandy for reporting the issue.
Optimise MP_Node.get_descendants to avoid database queries when called on a leaf node.


Release 4.6 (Jan 2, 2023)

Drop support for Django 3.1 and lower.
Add support for Django 4.0 and 4.1.
Drop support for Python 3.7 and lower.
Add support for Python 3.10 and Python 3.11.
Change the return value of delete() for all node classes to be consistent with Django, and return a tuple of the number of objects deleted and a dictionary with the number of deletions per object type.
Change the delete() methods for all node classes to accept arbitrary positional and keyword arguments which are passed to the parent method.
Set alters_data and queryset_only attributes on the delete() methods for all node classes to prevent them being used in an unwanted context (e.g., in Django templates).
Drop dependency on jQuery UI in the admin.
  • Loading branch information
adam committed Aug 30, 2023
1 parent 035ec14 commit 189cb88
Show file tree
Hide file tree
Showing 3 changed files with 28 additions and 10 deletions.
7 changes: 3 additions & 4 deletions www/py-django-treebeard/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.16 2023/07/13 10:03:30 wiz Exp $
# $NetBSD: Makefile,v 1.17 2023/08/30 14:39:23 adam Exp $

DISTNAME= django-treebeard-4.5.1
DISTNAME= django-treebeard-4.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_PYPI:=d/django-treebeard/}

Expand All @@ -11,7 +10,7 @@ HOMEPAGE= https://github.com/django-treebeard/django-treebeard
COMMENT= Efficient tree implementations for the Django Web Framework
LICENSE= apache-2.0

DEPENDS+= ${PYPKGPREFIX}-django>=3:../../www/py-django3
DEPENDS+= ${PYPKGPREFIX}-django>=3.2:../../www/py-django3

USE_LANGUAGES= # none

Expand Down
23 changes: 21 additions & 2 deletions www/py-django-treebeard/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2021/01/16 09:01:04 adam Exp $
@comment $NetBSD: PLIST,v 1.5 2023/08/30 14:39:23 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand Down Expand Up @@ -27,6 +27,14 @@ ${PYSITELIB}/treebeard/locale/es/LC_MESSAGES/django.mo
${PYSITELIB}/treebeard/locale/es/LC_MESSAGES/django.po
${PYSITELIB}/treebeard/locale/es/LC_MESSAGES/djangojs.mo
${PYSITELIB}/treebeard/locale/es/LC_MESSAGES/djangojs.po
${PYSITELIB}/treebeard/locale/fr/LC_MESSAGES/django.mo
${PYSITELIB}/treebeard/locale/fr/LC_MESSAGES/django.po
${PYSITELIB}/treebeard/locale/fr/LC_MESSAGES/djangojs.mo
${PYSITELIB}/treebeard/locale/fr/LC_MESSAGES/djangojs.po
${PYSITELIB}/treebeard/locale/hu/LC_MESSAGES/django.mo
${PYSITELIB}/treebeard/locale/hu/LC_MESSAGES/django.po
${PYSITELIB}/treebeard/locale/hu/LC_MESSAGES/djangojs.mo
${PYSITELIB}/treebeard/locale/hu/LC_MESSAGES/djangojs.po
${PYSITELIB}/treebeard/locale/nl/LC_MESSAGES/django.mo
${PYSITELIB}/treebeard/locale/nl/LC_MESSAGES/django.po
${PYSITELIB}/treebeard/locale/nl/LC_MESSAGES/djangojs.mo
Expand All @@ -50,7 +58,6 @@ ${PYSITELIB}/treebeard/numconv.py
${PYSITELIB}/treebeard/numconv.pyc
${PYSITELIB}/treebeard/numconv.pyo
${PYSITELIB}/treebeard/static/treebeard/expand-collapse.png
${PYSITELIB}/treebeard/static/treebeard/jquery-ui-1.8.5.custom.min.js
${PYSITELIB}/treebeard/static/treebeard/treebeard-admin.css
${PYSITELIB}/treebeard/static/treebeard/treebeard-admin.js
${PYSITELIB}/treebeard/templates/admin/tree_change_list.html
Expand All @@ -75,12 +82,24 @@ ${PYSITELIB}/treebeard/tests/admin.pyo
${PYSITELIB}/treebeard/tests/conftest.py
${PYSITELIB}/treebeard/tests/conftest.pyc
${PYSITELIB}/treebeard/tests/conftest.pyo
${PYSITELIB}/treebeard/tests/manage.py
${PYSITELIB}/treebeard/tests/manage.pyc
${PYSITELIB}/treebeard/tests/manage.pyo
${PYSITELIB}/treebeard/tests/migrations/0001_initial.py
${PYSITELIB}/treebeard/tests/migrations/0001_initial.pyc
${PYSITELIB}/treebeard/tests/migrations/0001_initial.pyo
${PYSITELIB}/treebeard/tests/migrations/__init__.py
${PYSITELIB}/treebeard/tests/migrations/__init__.pyc
${PYSITELIB}/treebeard/tests/migrations/__init__.pyo
${PYSITELIB}/treebeard/tests/models.py
${PYSITELIB}/treebeard/tests/models.pyc
${PYSITELIB}/treebeard/tests/models.pyo
${PYSITELIB}/treebeard/tests/settings.py
${PYSITELIB}/treebeard/tests/settings.pyc
${PYSITELIB}/treebeard/tests/settings.pyo
${PYSITELIB}/treebeard/tests/test_migrations.py
${PYSITELIB}/treebeard/tests/test_migrations.pyc
${PYSITELIB}/treebeard/tests/test_migrations.pyo
${PYSITELIB}/treebeard/tests/test_treebeard.py
${PYSITELIB}/treebeard/tests/test_treebeard.pyc
${PYSITELIB}/treebeard/tests/test_treebeard.pyo
Expand Down
8 changes: 4 additions & 4 deletions www/py-django-treebeard/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.17 2021/12/30 13:37:12 adam Exp $
$NetBSD: distinfo,v 1.18 2023/08/30 14:39:23 adam Exp $

BLAKE2s (django-treebeard-4.5.1.tar.gz) = e8d511524dbf9ddac25a050d0a5e34ce42758204a7fd7acd65cccaefa7237e6f
SHA512 (django-treebeard-4.5.1.tar.gz) = 27fa6ad50b25d0f9dd7dacddb36ec7165fa49abb26f17b744df3ba90c681107488f812e617d233dd54f86381f55986bd487687411a15dd90f911bc0cb3d8369e
Size (django-treebeard-4.5.1.tar.gz) = 784384 bytes
BLAKE2s (django-treebeard-4.7.tar.gz) = 8444476642d02e526072321d222c3ed23f7392d58384d3af8d35475a61baf7cf
SHA512 (django-treebeard-4.7.tar.gz) = e4f51cbe212ab26682ee8c34058aebaf8e1ea3c657a28d905b96523e336d76bfb6344d37aba66c8270a86b2ea97c5385afaa3aa9ca18954d787b4682c655810c
Size (django-treebeard-4.7.tar.gz) = 294303 bytes

0 comments on commit 189cb88

Please sign in to comment.