Skip to content

Commit

Permalink
py-limits: updated to 3.5.0
Browse files Browse the repository at this point in the history
v3.5.0
------
* Bug Fix

  * Handle ``cost`` > 8000 when using redis
  * Remove arbitrary default timeout for redis+sentinel

v3.4.0
------
* Bug Fix

  * Remove use of weakreferences to storages in strategy
    classes as this was not documented or required and
    led to usability issues.

* Chores

  * Update documentation dependencies
  * Remove unused gcra lua script

v3.3.1
------
* Compatibility

  * Block incompatible versions of redis-py

* Chores

  * Force error on warnings in tests

v3.3.0
------
* Compatibility

  * Remove deprecated use of `pkg_resources` and switch
    to `importlib_resource`

* Chores

  * Update documentation dependencies
  * Update github actions versions

v3.2.0
------
* Bug Fix

  * Fix handling of authentication details in storage url of redis cluster

* Chores

  * Add test coverage for redis cluster with auth required

v3.1.6
------
* Bug Fix

  * Disallow acquiring amounts > limit in moving window

* Usability

  * Use a named tuple for the response from `RateLimiter.get_window_stats`

v3.1.5
------
* Performance

  * Reduce rpc calls to etcd for counter increment

* Compatibility

  * Relax version requirements for packaging dependency

* Chores

  * Improve benchmark outputs
  * Improve documentation for etcd

v3.1.4
------
* Chores

  * Fix benchmark result artifact capture

v3.1.3
------
* Chores

  * Fix benchmark result artifact capture

v3.1.2
------
* Chores

  * Collapse benchmark & ci workflows

v3.1.1
------
* Chores

  * Fix compatibility tests for etcd in CI
  * Improve visual identifiers of tests
  * Add benchmark tests in CI

v3.1.0
------
* Compatibility

  * Increase minimum version of pymongo to 4.1

* Chores

  * Refactor storage tests
  * Improve test coverage across python versions in CI

v3.0.0
------
* Features

  * Added etcd storage support for fixed window strategies

* Compatibility

  * Removed deprecated GAE Memcached storage
  * Updated minimum dependencies for mongodb
  * Updated dependency for async memcached on python 3.11
  • Loading branch information
adam committed Aug 29, 2023
1 parent fbc3f68 commit 212b368
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 11 deletions.
5 changes: 3 additions & 2 deletions devel/py-limits/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.11 2022/12/12 07:53:33 adam Exp $
# $NetBSD: Makefile,v 1.12 2023/08/29 07:38:04 adam Exp $

DISTNAME= limits-2.7.2
DISTNAME= limits-3.5.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=l/limits/}
Expand All @@ -11,6 +11,7 @@ COMMENT= Rate limiting utilities
LICENSE= mit

DEPENDS+= ${PYPKGPREFIX}-deprecated>=1.2:../../devel/py-deprecated
DEPENDS+= ${PYPKGPREFIX}-importlib-resources>=1.3:../../devel/py-importlib-resources
DEPENDS+= ${PYPKGPREFIX}-packaging>=21:../../devel/py-packaging
DEPENDS+= ${PYPKGPREFIX}-typing-extensions-[0-9]*:../../devel/py-typing-extensions

Expand Down
12 changes: 7 additions & 5 deletions devel/py-limits/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2022/10/21 07:55:18 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2023/08/29 07:38:04 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
Expand All @@ -20,6 +20,9 @@ ${PYSITELIB}/limits/aio/storage/__init__.pyo
${PYSITELIB}/limits/aio/storage/base.py
${PYSITELIB}/limits/aio/storage/base.pyc
${PYSITELIB}/limits/aio/storage/base.pyo
${PYSITELIB}/limits/aio/storage/etcd.py
${PYSITELIB}/limits/aio/storage/etcd.pyc
${PYSITELIB}/limits/aio/storage/etcd.pyo
${PYSITELIB}/limits/aio/storage/memcached.py
${PYSITELIB}/limits/aio/storage/memcached.pyc
${PYSITELIB}/limits/aio/storage/memcached.pyo
Expand All @@ -44,7 +47,6 @@ ${PYSITELIB}/limits/limits.pyo
${PYSITELIB}/limits/py.typed
${PYSITELIB}/limits/resources/redis/lua_scripts/acquire_moving_window.lua
${PYSITELIB}/limits/resources/redis/lua_scripts/clear_keys.lua
${PYSITELIB}/limits/resources/redis/lua_scripts/gcra_consume.lua
${PYSITELIB}/limits/resources/redis/lua_scripts/incr_expire.lua
${PYSITELIB}/limits/resources/redis/lua_scripts/moving_window.lua
${PYSITELIB}/limits/storage/__init__.py
Expand All @@ -53,9 +55,9 @@ ${PYSITELIB}/limits/storage/__init__.pyo
${PYSITELIB}/limits/storage/base.py
${PYSITELIB}/limits/storage/base.pyc
${PYSITELIB}/limits/storage/base.pyo
${PYSITELIB}/limits/storage/gae_memcached.py
${PYSITELIB}/limits/storage/gae_memcached.pyc
${PYSITELIB}/limits/storage/gae_memcached.pyo
${PYSITELIB}/limits/storage/etcd.py
${PYSITELIB}/limits/storage/etcd.pyc
${PYSITELIB}/limits/storage/etcd.pyo
${PYSITELIB}/limits/storage/memcached.py
${PYSITELIB}/limits/storage/memcached.pyc
${PYSITELIB}/limits/storage/memcached.pyo
Expand Down
8 changes: 4 additions & 4 deletions devel/py-limits/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.11 2022/12/12 07:53:33 adam Exp $
$NetBSD: distinfo,v 1.12 2023/08/29 07:38:04 adam Exp $

BLAKE2s (limits-2.7.2.tar.gz) = 5502ac0eafb969c4486bc9f7cac0374ae98dad53b9a617e17067d994f8455d64
SHA512 (limits-2.7.2.tar.gz) = 0d0f05634f189b5cdc47aa0c644ce12eec215be2f3af2bd901a521fff27ece7353e13f2e3e5ec49c27f89f099740c02783fb48a8ca91eb5483e703feeb642870
Size (limits-2.7.2.tar.gz) = 61684 bytes
BLAKE2s (limits-3.5.0.tar.gz) = bbf3a53554a2d3ed96994531a662682da777f0855106a91b1730b0d5d3dd37ff
SHA512 (limits-3.5.0.tar.gz) = 07c7c5430aa15b14bf663b854a33e716f7e74850ab63527a26f2b45ae043ea8af67c512fd6e51504dd110bff50f052c347717e84aeb47eb48a408fe271ffab03
Size (limits-3.5.0.tar.gz) = 67255 bytes

0 comments on commit 212b368

Please sign in to comment.