Skip to content

Commit

Permalink
archivers: align variable assignments
Browse files Browse the repository at this point in the history
pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
  • Loading branch information
rillig committed Nov 2, 2019
1 parent 53ce333 commit 226a02d
Show file tree
Hide file tree
Showing 27 changed files with 109 additions and 109 deletions.
14 changes: 7 additions & 7 deletions archivers/bsdtar/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.25 2018/02/13 12:50:40 ryoon Exp $
# $NetBSD: Makefile,v 1.26 2019/11/02 22:54:25 rillig Exp $

.include "../../archivers/libarchive/Makefile.common"
.include "../../mk/bsd.prefs.mk"
Expand All @@ -8,7 +8,7 @@ COMMENT= Fast multi-format tape archiver

# Explicitly do not depend on libtool as this can be used
# as bootstrap dependency.
#USE_LIBTOOL= yes
#USE_LIBTOOL= yes
CONFIGURE_ARGS+= --enable-bsdtar=static
CONFIGURE_ARGS+= --disable-bsdcpio
CONFIGURE_ARGS+= --disable-shared
Expand All @@ -24,17 +24,17 @@ CHECK_BUILTIN.openssl:= yes
CHECK_BUILTIN.openssl:= no

.if empty(USE_BUILTIN.bzip2:M[yY][eE][sS])
CPPFLAGS+= -I${WRKDIR}/bzip2
LDFLAGS+= -L${WRKDIR}/bzip2
CPPFLAGS+= -I${WRKDIR}/bzip2
LDFLAGS+= -L${WRKDIR}/bzip2
.endif
.if empty(USE_BUILTIN.zlib:M[yY][eE][sS])
CPPFLAGS+= -I${WRKDIR}/zlib
LDFLAGS+= -L${WRKDIR}/zlib
CPPFLAGS+= -I${WRKDIR}/zlib
LDFLAGS+= -L${WRKDIR}/zlib
.endif
.if empty(USE_BUILTIN.openssl:M[yY][eE][sS])
CONFIGURE_ARGS+= --without-openssl
.else
LDFLAGS+= -lcrypto
LDFLAGS+= -lcrypto
.endif
.if empty(USE_BUILTIN.xz:M[yY][eE][sS])
CONFIGURE_ARGS+= --without-lzma
Expand Down
8 changes: 4 additions & 4 deletions archivers/bzip2/builtin.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: builtin.mk,v 1.9 2013/11/23 10:51:09 obache Exp $
# $NetBSD: builtin.mk,v 1.10 2019/11/02 22:54:26 rillig Exp $

BUILTIN_PKG:= bzip2

Expand All @@ -18,7 +18,7 @@ IS_BUILTIN.bzip2= no
IS_BUILTIN.bzip2= yes
. endif
.endif
MAKEVARS+= IS_BUILTIN.bzip2
MAKEVARS+= IS_BUILTIN.bzip2

###
### If there is a built-in implementation, then set BUILTIN_PKG.<pkg> to
Expand All @@ -43,7 +43,7 @@ BUILTIN_VERSION.bzip2!= \

BUILTIN_PKG.bzip2= bzip2-${BUILTIN_VERSION.bzip2}
.endif
MAKEVARS+= BUILTIN_PKG.bzip2
MAKEVARS+= BUILTIN_PKG.bzip2

###
### Determine whether we should use the built-in implementation if it
Expand Down Expand Up @@ -80,7 +80,7 @@ USE_BUILTIN.bzip2= no
. endfor
. endif # PREFER.bzip2
.endif
MAKEVARS+= USE_BUILTIN.bzip2
MAKEVARS+= USE_BUILTIN.bzip2

# if USE_BZIP2 is defined, then force the use of a true bzip2
# implementation.
Expand Down
4 changes: 2 additions & 2 deletions archivers/dar/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.55 2019/07/06 16:29:10 bsiegert Exp $
# $NetBSD: Makefile,v 1.56 2019/11/02 22:54:26 rillig Exp $

DISTNAME= dar-2.4.13
PKGREVISION= 1
Expand Down Expand Up @@ -35,7 +35,7 @@ REPLACE_BASH+= doc/samples/*.bash doc/samples/*.sh doc/samples/*.duc
## Our threading check here is the same as the one used in devel/perl5.
#
CHECK_BUILTIN.pthread:=yes
. include "../../mk/pthread.builtin.mk"
.include "../../mk/pthread.builtin.mk"
CHECK_BUILTIN.pthread:=no

## XXX I'm following the USE_FEATURES semantics used in security/openssl.
Expand Down
4 changes: 2 additions & 2 deletions archivers/fastjar/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.21 2016/09/18 11:17:41 wiz Exp $
# $NetBSD: Makefile,v 1.22 2019/11/02 22:54:26 rillig Exp $

DISTNAME= fastjar-0.98
PKGREVISION= 1
Expand All @@ -12,7 +12,7 @@ LICENSE= gnu-gpl-v2

GNU_CONFIGURE= YES

INFO_FILES= YES
INFO_FILES= YES
INSTALLATION_DIRS= ${PKGMANDIR}/man1

post-install:
Expand Down
16 changes: 8 additions & 8 deletions archivers/lha/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.40 2016/02/25 09:28:36 jperkin Exp $
# $NetBSD: Makefile,v 1.41 2019/11/02 22:54:26 rillig Exp $

DISTNAME= lha-114i
PKGNAME= lha-114.9
Expand All @@ -11,18 +11,18 @@ HOMEPAGE= http://www2m.biglobe.ne.jp/~dolphin/lha/lha-unix.htm
COMMENT= Archive files using LZW compression (.lzh files)
LICENSE= lha-license

RESTRICTED= Other than for-free distribution of the unmodified source \
RESTRICTED= Other than for-free distribution of the unmodified source \
over a network, redistribution terms are complex.
NO_SRC_ON_CDROM=${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
NO_BIN_ON_CDROM=${RESTRICTED}
NO_SRC_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
NO_BIN_ON_CDROM= ${RESTRICTED}

MAKE_FLAGS+= MAKE=${MAKE_PROGRAM:Q}

OPSYSVARS+= LHA_CPPFLAGS
LHA_CPPFLAGS= -DSYSTIME_HAS_NO_TM -DMKTIME -DUSESTRCASECMP -DSYSV_SYSTEM_DIR
OPSYSVARS+= LHA_CPPFLAGS
LHA_CPPFLAGS= -DSYSTIME_HAS_NO_TM -DMKTIME -DUSESTRCASECMP -DSYSV_SYSTEM_DIR
LHA_CPPFLAGS.Darwin+= -DHAVE_NO_LCHOWN
MAKE_FLAGS+= MACHINE=${LHA_CPPFLAGS:Q}
MAKE_FLAGS+= MACHINE=${LHA_CPPFLAGS:Q}

INSTALLATION_DIRS= bin ${PKGMANDIR}/ja_JP.EUC/man1

Expand Down
8 changes: 4 additions & 4 deletions archivers/libarchive/builtin.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: builtin.mk,v 1.10 2019/04/10 08:24:03 adam Exp $
# $NetBSD: builtin.mk,v 1.11 2019/11/02 22:54:26 rillig Exp $

BUILTIN_PKG:= libarchive

Expand All @@ -17,7 +17,7 @@ IS_BUILTIN.libarchive= no
IS_BUILTIN.libarchive= yes
. endif
.endif
MAKEVARS+= IS_BUILTIN.libarchive
MAKEVARS+= IS_BUILTIN.libarchive

###
### If there is a built-in implementation, then set BUILTIN_PKG.<pkg> to
Expand Down Expand Up @@ -60,7 +60,7 @@ BUILTIN_PKG.libarchive= libarchive-${BUILTIN_VERSION.libarchive}
IS_BUILTIN.libarchive= no
. endif
.endif
MAKEVARS+= BUILTIN_PKG.libarchive
MAKEVARS+= BUILTIN_PKG.libarchive

###
### Determine whether we should use the built-in implementation if it
Expand All @@ -87,7 +87,7 @@ USE_BUILTIN.libarchive!= \
. endif
. endif # PREFER.libarchive
.endif
MAKEVARS+= USE_BUILTIN.libarchive
MAKEVARS+= USE_BUILTIN.libarchive

###
### The section below only applies if we are not including this file
Expand Down
16 changes: 8 additions & 8 deletions archivers/libcomprex/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.43 2019/08/22 12:22:48 ryoon Exp $
# $NetBSD: Makefile,v 1.44 2019/11/02 22:54:26 rillig Exp $

DISTNAME= libcomprex-0.3.3
PKGREVISION= 20
Expand All @@ -9,14 +9,14 @@ MAINTAINER= [email protected]
HOMEPAGE= http://gnupdate.sourceforge.net/components/libcomprex/index.xml
COMMENT= Library to handle (de)compression of files

USE_LIBTOOL= yes
USE_TOOLS+= pkg-config
USE_PKGLOCALEDIR= yes
PKGCONFIG_OVERRIDE= libcomprex.pc.in
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= pkg-config
USE_PKGLOCALEDIR= yes
PKGCONFIG_OVERRIDE= libcomprex.pc.in
GNU_CONFIGURE= yes
BROKEN_GETTEXT_DETECTION= yes
CONFIGURE_ENV+= ac_cv_lib_curl_curl_formparse=yes
REPLACE_SH= comprex-config.in
CONFIGURE_ENV+= ac_cv_lib_curl_curl_formparse=yes
REPLACE_SH= comprex-config.in

.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
Expand Down
4 changes: 2 additions & 2 deletions archivers/libunrar/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.1 2018/12/14 16:02:55 bsiegert Exp $
# $NetBSD: buildlink3.mk,v 1.2 2019/11/02 22:54:26 rillig Exp $

BUILDLINK_TREE+= libunrar

.if !defined(LIBUNRAR_BUILDLINK3_MK)
LIBUNRAR_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.libunrar+= libunrar>=5.6.8
BUILDLINK_PKGSRCDIR.libunrar?= ../../archivers/libunrar
BUILDLINK_PKGSRCDIR.libunrar?= ../../archivers/libunrar
.endif # LIBUNRAR_BUILDLINK3_MK

BUILDLINK_TREE+= -libunrar
4 changes: 2 additions & 2 deletions archivers/nulib2/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2016/01/23 05:15:22 zafer Exp $
# $NetBSD: Makefile,v 1.25 2019/11/02 22:54:26 rillig Exp $
#

DISTNAME= nulibdist-220
Expand All @@ -19,7 +19,7 @@ GNU_CONFIGURE= yes

.include "../../mk/bsd.prefs.mk"

CONFIGURE_ARGS+=--cache-file=${WRKDIR}/config.cache
CONFIGURE_ARGS+= --cache-file=${WRKDIR}/config.cache

CFLAGS+= -D__unix__

Expand Down
8 changes: 4 additions & 4 deletions archivers/ocaml-bz2/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.18 2018/11/12 16:10:17 jaapb Exp $
# $NetBSD: Makefile,v 1.19 2019/11/02 22:54:26 rillig Exp $

PKGNAME= ocaml-bz2-${VERSION}
DISTNAME= camlbz2-${VERSION}
Expand All @@ -12,9 +12,9 @@ COMMENT= OCaml library to manipulate bz2 archives
HOMEPAGE= http://camlbz2.forge.ocamlcore.org/
LICENSE= gnu-lgpl-v2.1

GNU_CONFIGURE= yes
USE_TOOLS+= gmake
MAKE_JOBS_SAFE= no
GNU_CONFIGURE= yes
USE_TOOLS+= gmake
MAKE_JOBS_SAFE= no
OCAML_USE_FINDLIB= yes

.include "../../mk/ocaml.mk"
Expand Down
4 changes: 2 additions & 2 deletions archivers/ocaml-decompress/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.1 2019/03/12 18:00:02 jaapb Exp $
# $NetBSD: buildlink3.mk,v 1.2 2019/11/02 22:54:27 rillig Exp $

BUILDLINK_TREE+= ocaml-decompress

.if !defined(OCAML_DECOMPRESS_BUILDLINK3_MK)
OCAML_DECOMPRESS_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.ocaml-decompress+= ocaml-decompress>=0.8.1
BUILDLINK_PKGSRCDIR.ocaml-decompress?= ../../archivers/ocaml-decompress
BUILDLINK_PKGSRCDIR.ocaml-decompress?= ../../archivers/ocaml-decompress

.endif # OCAML_DECOMPRESS_BUILDLINK3_MK

Expand Down
8 changes: 4 additions & 4 deletions archivers/ocaml-zip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.24 2018/11/12 16:10:17 jaapb Exp $
# $NetBSD: Makefile,v 1.25 2019/11/02 22:54:27 rillig Exp $
#

VERSION= 1.07
Expand All @@ -15,9 +15,9 @@ MAINTAINER= [email protected]
HOMEPAGE= https://github.com/xavierleroy/camlzip
COMMENT= OCaml library to manipulate ZIP/GZIP/JAR archives

BUILD_TARGET= all
INSTALL_TARGET= install-findlib
USE_TOOLS+= gmake
BUILD_TARGET= all
INSTALL_TARGET= install-findlib
USE_TOOLS+= gmake
OCAML_USE_FINDLIB= yes

.include "../../mk/ocaml.mk"
Expand Down
4 changes: 2 additions & 2 deletions archivers/pax/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.53 2018/10/29 20:18:02 triaxx Exp $
# $NetBSD: Makefile,v 1.54 2019/11/02 22:54:27 rillig Exp $

DISTNAME= pax-20080110
PKGREVISION= 4
Expand All @@ -12,7 +12,7 @@ COMMENT= POSIX standard archiver with many extensions
LICENSE= 2-clause-bsd AND modified-bsd AND public-domain

BOOTSTRAP_PKG= yes
CHECK_PERMS= no
CHECK_PERMS= no

MAKE_ENV+= CATMAN_SECTION_SUFFIX=${CATMAN_SECTION_SUFFIX:Q}
MAKE_ENV+= MANINSTALL=${MANINSTALL:Q}
Expand Down
4 changes: 2 additions & 2 deletions archivers/py-czipfile/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2019/09/02 13:19:58 adam Exp $
# $NetBSD: Makefile,v 1.7 2019/11/02 22:54:27 rillig Exp $

DISTNAME= czipfile-1.0.0
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
Expand All @@ -10,7 +10,7 @@ HOMEPAGE= https://pypi.python.org/pypi/czipfile
COMMENT= Replacement for builtin zipfile, with fast, C-based zipfile decryption
LICENSE= python-software-foundation

PYTHON_VERSIONS_ACCEPTED= 27 # for 2.x only
PYTHON_VERSIONS_ACCEPTED= 27 # for 2.x only

.include "../../lang/python/egg.mk"
.include "../../devel/py-cython/buildlink3.mk"
Expand Down
4 changes: 2 additions & 2 deletions archivers/rox-archive/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2019/04/25 07:32:34 maya Exp $
# $NetBSD: Makefile,v 1.14 2019/11/02 22:54:27 rillig Exp $
#

DISTNAME= archive-2.0
Expand All @@ -22,7 +22,7 @@ USE_TOOLS+= pax
NO_BUILD= yes

REPLACE_PYTHON= AppRun tests/testall.py
REPLACE_SH= Messages/dist Messages/update-po
REPLACE_SH= Messages/dist Messages/update-po

INSTALLATION_DIRS= share/rox/Archive

Expand Down
4 changes: 2 additions & 2 deletions archivers/rzip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.12 2016/01/23 05:47:38 zafer Exp $
# $NetBSD: Makefile,v 1.13 2019/11/02 22:54:27 rillig Exp $

DISTNAME= rzip-2.1
CATEGORIES= archivers
Expand All @@ -8,7 +8,7 @@ MAINTAINER= [email protected]
HOMEPAGE= http://rzip.samba.org/
COMMENT= Create or extract .rz files, like gzip but smaller

GNU_CONFIGURE= yes
GNU_CONFIGURE= yes
INSTALL_MAKE_FLAGS+= INSTALL_BIN=${DESTDIR}${PREFIX}/bin \
INSTALL_MAN=${DESTDIR}${PREFIX}/${PKGMANDIR}

Expand Down
8 changes: 4 additions & 4 deletions archivers/sarab/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2018/07/04 13:40:08 jperkin Exp $
# $NetBSD: Makefile,v 1.9 2019/11/02 22:54:27 rillig Exp $

DISTNAME= sarab-1.0.0
CATEGORIES= archivers
Expand All @@ -20,9 +20,9 @@ REPLACE.bash.new= ${TOOLS_PATH.bash}
REPLACE_FILES.bash= sarab.sh

EGDIR= ${PREFIX}/share/examples/sarab
CONF_FILES+= ${EGDIR}/rotation.schedule ${PKG_SYSCONFDIR}/rotation.schedule
CONF_FILES+= ${EGDIR}/sarab.conf ${PKG_SYSCONFDIR}/sarab.conf
CONF_FILES+= ${EGDIR}/sarab.dcf ${PKG_SYSCONFDIR}/sarab.dcf
CONF_FILES+= ${EGDIR}/rotation.schedule ${PKG_SYSCONFDIR}/rotation.schedule
CONF_FILES+= ${EGDIR}/sarab.conf ${PKG_SYSCONFDIR}/sarab.conf
CONF_FILES+= ${EGDIR}/sarab.dcf ${PKG_SYSCONFDIR}/sarab.dcf

SUBST_CLASSES+= dar
SUBST_STAGE.dar= pre-configure
Expand Down
4 changes: 2 additions & 2 deletions archivers/szip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.18 2017/09/04 18:08:18 wiz Exp $
# $NetBSD: Makefile,v 1.19 2019/11/02 22:54:27 rillig Exp $

DISTNAME= szip-2.1
PKGREVISION= 3
Expand All @@ -8,7 +8,7 @@ MASTER_SITES= ftp://ftp.hdfgroup.org/lib-external/szip/2.1/src/
MAINTAINER= [email protected]
HOMEPAGE= https://www.hdfgroup.org/doc_resource/SZIP/
COMMENT= Extended-Rice lossless compression
LICENSE= szip-license
LICENSE= szip-license

RESTRICTED= No permission to redistribute
NO_SRC_ON_FTP= ${RESTRICTED}
Expand Down
6 changes: 3 additions & 3 deletions archivers/torrentzip/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.5 2017/09/06 09:02:59 wiz Exp $
# $NetBSD: Makefile,v 1.6 2019/11/02 22:54:28 rillig Exp $
#

DISTNAME= trrntzip_v02_src
Expand All @@ -10,8 +10,8 @@ MAINTAINER= [email protected]
HOMEPAGE= https://sourceforge.net/projects/trrntzip/
COMMENT= Create identical zip archives from identical files

USE_TOOLS+= aclocal autoconf automake autoheader
GNU_CONFIGURE= yes
USE_TOOLS+= aclocal autoconf automake autoheader
GNU_CONFIGURE= yes
INSTALLATION_DIRS= share/doc/torrentzip

WRKSRC= ${WRKDIR}/trrntzip
Expand Down
Loading

0 comments on commit 226a02d

Please sign in to comment.