Skip to content

Commit

Permalink
When calling bootstrap-register from the bootstrap script for the
Browse files Browse the repository at this point in the history
various packages, pass down PKG_PRESERVE. Remove the default setting of
PKG_PRESERVE, it makes perfect sense to install e.g. pkgtools/mtree
and be able to remove it again, if it is not an essientiel tool.

OK jlam@
  • Loading branch information
jsonn committed Apr 12, 2007
1 parent a679efd commit 2a722b7
Show file tree
Hide file tree
Showing 5 changed files with 7 additions and 11 deletions.
6 changes: 3 additions & 3 deletions bootstrap/bootstrap
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
#! /bin/sh

# $NetBSD: bootstrap,v 1.92 2007/03/02 16:48:48 wiz Exp $
# $NetBSD: bootstrap,v 1.93 2007/04/12 14:36:40 joerg Exp $
#
#
# Copyright (c) 2001-2002 Alistair G. Crooks. All rights reserved.
Expand Down Expand Up @@ -889,11 +889,11 @@ echo ".endif # end pkgsrc settings" >> ${MKCONF_EXAMPLE}
# register packages
# usage: register_package <packagedirectory> [additional arguments]
register_package() {
run_cmd "(cd $pkgsrcdir/$1 && $bmake MAKECONF=${MKCONF_EXAMPLE} WRKOBJDIR=${wrkobjdir} ${2-} bootstrap-register)"
run_cmd "(cd $pkgsrcdir/$1 && $bmake -DPKG_PRESERVE MAKECONF=${MKCONF_EXAMPLE} WRKOBJDIR=${wrkobjdir} ${2-} bootstrap-register)"
}

echo_msg "Registering installed packages"
run_cmd "(cd $pkgsrcdir/pkgtools/bootstrap-mk-files && $bmake MAKECONF=${MKCONF_EXAMPLE} WRKOBJDIR=$wrkobjdir bootstrap-register)"
register_package "pkgtools/bootstrap-mk-files"
case "$need_awk" in
yes) register_package "lang/nawk";;
esac
Expand Down
3 changes: 1 addition & 2 deletions pkgtools/bootstrap-mk-files/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3 2006/11/11 18:24:52 jschauma Exp $
# $NetBSD: Makefile,v 1.4 2007/04/12 14:36:40 joerg Exp $

DISTNAME= bootstrap-mk-files-20061111
CATEGORIES= pkgtools
Expand All @@ -12,7 +12,6 @@ HOMEPAGE= http://www.pkgsrc.org/
COMMENT= *.mk files for the bootstrap bmake utility

NO_PKGTOOLS_REQD_CHECK= # defined
PKG_PRESERVE= # defined

NO_CHECKSUM= yes
NO_MTREE= yes
Expand Down
3 changes: 1 addition & 2 deletions pkgtools/mtree/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.20 2006/07/14 20:11:10 jlam Exp $
# $NetBSD: Makefile,v 1.21 2007/04/12 14:36:40 joerg Exp $
#
# This version of mtree installs into ${PKG_TOOLS_BIN}.
#
Expand All @@ -8,7 +8,6 @@
CATEGORIES= pkgtools

NO_PKGTOOLS_REQD_CHECK= # defined
PKG_PRESERVE= # defined

PKG_TOOLS_PREFIX= ${PKG_TOOLS_BIN:C|/[^/]?bin$||}

Expand Down
3 changes: 1 addition & 2 deletions pkgtools/pax/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.13 2006/07/14 20:11:10 jlam Exp $
# $NetBSD: Makefile,v 1.14 2007/04/12 14:36:40 joerg Exp $
#
# This version of pax installs into ${PKG_TOOLS_BIN}.
#
Expand All @@ -8,7 +8,6 @@
CATEGORIES= pkgtools

NO_PKGTOOLS_REQD_CHECK= yes
PKG_PRESERVE= yes

PKG_TOOLS_PREFIX= ${PKG_TOOLS_BIN:C|/[^/]?bin$||}

Expand Down
3 changes: 1 addition & 2 deletions pkgtools/tnftp/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.1 2006/07/14 21:41:42 jlam Exp $
# $NetBSD: Makefile,v 1.2 2007/04/12 14:36:41 joerg Exp $
#
# This version of tnftp installs into ${PKG_TOOLS_BIN}.
#
Expand All @@ -8,7 +8,6 @@
CATEGORIES= pkgtools

NO_PKGTOOLS_REQD_CHECK= yes
PKG_PRESERVE= yes

PKG_TOOLS_PREFIX= ${PKG_TOOLS_BIN:C|/[^/]?bin$||}

Expand Down

0 comments on commit 2a722b7

Please sign in to comment.