Skip to content

Commit

Permalink
New "dict-server" package submitted by Michael Santos in PR pkg/7999:
Browse files Browse the repository at this point in the history
Dictionary Service Protocol server.
  • Loading branch information
tron committed Jul 28, 1999
1 parent fdeae52 commit 2c4770f
Show file tree
Hide file tree
Showing 10 changed files with 186 additions and 0 deletions.
53 changes: 53 additions & 0 deletions textproc/dict-server/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/07/28 16:17:19 tron Exp $

DISTNAME= dictd-1.4.9
PKGNAME= dict-server-1.4.9
CATEGORIES= textproc
MASTER_SITES= ftp://ftp.cs.unc.edu/pub/users/faith/dict/ \
ftp://ftp.cs.unc.edu/pub/users/faith/dict/pre/ \
ftp://ftp.dict.org/pub/dict/ \
ftp://ftp.dict.org/pub/dict/pre/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
dict-gazetteer-1.2-pre.tar.gz \
dict-misc-1.5-pre.tar.gz \
dict-web1913-1.4-pre.tar.gz \
dict-wn-1.5-pre.tar.gz

MAINTAINER= [email protected]
HOMEPAGE= http://www.dict.org/

USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-etcdir=${PREFIX}/etc

ALL_TARGET= dictd dictzip
INSTALL_TARGET= install.dictd install.dictzip

LEXICONS= easton.dict.dz \
easton.index \
elements.dict.dz \
elements.index \
foldoc.dict.dz \
foldoc.index \
gazetteer.dict.dz \
gazetteer.index \
hitchcock.dict.dz \
hitchcock.index \
jargon.dict.dz \
jargon.index \
web1913.dict.dz \
web1913.index \
wn.dict.dz \
wn.index \
world95.dict.dz \
world95.index

post-install:
${SED} "s#/usr/lib/dict#${PREFIX}/share/dictd#" \
${WRKSRC}/dictd.conf >${PREFIX}/etc/dictd.conf
${MKDIR} ${PREFIX}/share/dictd
.for FILE in ${LEXICONS}
${INSTALL_DATA} ${WRKDIR}/${FILE} ${PREFIX}/share/dictd
.endfor

.include "../../mk/bsd.pkg.mk"
7 changes: 7 additions & 0 deletions textproc/dict-server/files/md5
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
$NetBSD: md5,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

MD5 (dictd-1.4.9.tar.gz) = 90e69ac4783b8836dbe98f8367b5f391
MD5 (dict-gazetteer-1.2-pre.tar.gz) = d67cd81e90bc98e738c19693a97ab9e2
MD5 (dict-misc-1.5-pre.tar.gz) = bd95a1cf95b1abd5c3fdaf181dd50be3
MD5 (dict-web1913-1.4-pre.tar.gz) = 63a8d25ace68dff135185a8c96dd5f3c
MD5 (dict-wn-1.5-pre.tar.gz) = 1f6ae6284018044dbd9e3c5fae914f32
6 changes: 6 additions & 0 deletions textproc/dict-server/files/patch-sum
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
$NetBSD: patch-sum,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

MD5 (patch-aa) = 0bb6daba8ca5ee8018dcd07d67749e10
MD5 (patch-ab) = f64f0942d769e20cc3640a37be30a255
MD5 (patch-ac) = 80ddcbd09b5f37aefdd4e4194f21817d
MD5 (patch-ad) = 39929f0f159e075f38d67ba6a801cdcf
28 changes: 28 additions & 0 deletions textproc/dict-server/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

--- configure.orig Mon Jul 6 03:38:03 1998
+++ configure Wed Jul 28 17:57:42 1999
@@ -46,11 +46,13 @@
# dashes changed to underlines.
build=NONE
cache_file=./config.cache
+etcdir=/etc
exec_prefix=NONE
host=NONE
no_create=
nonopt=NONE
no_recursion=
+piddir=/var/run
prefix=NONE
program_prefix=NONE
program_suffix=NONE
@@ -549,9 +551,6 @@



-prefix=/usr
-etcdir=/etc
-piddir=/var/run

echo Configuring for dict
echo .
27 changes: 27 additions & 0 deletions textproc/dict-server/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

--- Makefile.in.orig Mon Jul 6 00:09:59 1998
+++ Makefile.in Wed Jul 28 17:57:42 1999
@@ -141,16 +141,16 @@
$(CC) -c $(XTRACFLAGS) $(CFLAGS) -Wno-implicit $<

install.dict: dict
- install dict $(bindir)
- install -m 644 dict.1 $(man1_prefix)
+ ${INSTALL_PROGRAM} dict $(bindir)
+ ${BSD_INSTALL_MAN} dict.1 $(man1_prefix)

install.dictzip: dictzip
- install dictzip $(bindir)
- install -m 644 dictzip.1 $(man1_prefix)
+ ${INSTALL_PROGRAM} dictzip $(bindir)
+ ${BSD_INSTALL_MAN} dictzip.1 $(man1_prefix)

install.dictd: dictd
- install dictd $(sbindir)
- install -m 644 dictd.8 $(man8_prefix)
+ ${INSTALL_PROGRAM} dictd $(sbindir)
+ ${BSD_INSTALL_MAN} dictd.8 $(man8_prefix)

install: $(EXES) install.dict install.dictzip install.dictd

16 changes: 16 additions & 0 deletions textproc/dict-server/patches/patch-ac
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

--- libmaa/maaP.h.orig Sun Feb 22 14:41:19 1998
+++ libmaa/maaP.h Wed Jul 28 17:57:42 1999
@@ -103,9 +103,11 @@
#else
#if !defined(__FreeBSD__) && !defined(__DGUX__) && !defined(__hpux__)
#if !defined(__bsdi__) && !(defined(__sparc) && defined(__svr4__))
+#if !defined(__NetBSD__)
extern int getopt( int, char **, char * );
extern int optind;
extern char *optarg;
+#endif
#endif
#endif
#endif
10 changes: 10 additions & 0 deletions textproc/dict-server/patches/patch-ad
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
$NetBSD: patch-ad,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $

--- dictd.conf.orig Sun Feb 22 19:53:29 1998
+++ dictd.conf Wed Jul 28 17:57:42 1999
@@ -14,3 +14,5 @@
index "/usr/lib/dict/easton.index" }
database hitchcock { data "/usr/lib/dict/hitchcock.dict.dz"
index "/usr/lib/dict/hitchcock.index" }
+database world95 { data "/usr/lib/dict/world95.dict.dz"
+ index "/usr/lib/dict/world95.index" }
1 change: 1 addition & 0 deletions textproc/dict-server/pkg/COMMENT
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
Dictionary Service Protocol server.
13 changes: 13 additions & 0 deletions textproc/dict-server/pkg/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
The Dictionary Server Protocol (DICT) is a TCP transaction based
query/response protocol that allows a client to access dictionary
definitions from a set of natural language dictionary databases.

dictd(8) is a server which supports the DICT protocol.

dictzip(1) is a compression program which creates compressed files in the
gzip format (see RFC 1952). However, unlike gzip(1), dictzip(1) compresses
the file in pieces and stores an index to the pieces in the gzip header.
This allows random access to the file at the granularity of the compressed
pieces (currently about 64kB) while maintaining good compression ratios
(within 5% of the expected ratio for dictionary data). dictd(8) uses files
stored in this format.
25 changes: 25 additions & 0 deletions textproc/dict-server/pkg/PLIST
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/07/28 16:17:20 tron Exp $
sbin/dictd
man/man8/dictd.8
bin/dictzip
man/man1/dictzip.1
etc/dictd.conf
share/dictd/web1913.dict.dz
share/dictd/web1913.index
share/dictd/wn.dict.dz
share/dictd/wn.index
share/dictd/gazetteer.dict.dz
share/dictd/gazetteer.index
share/dictd/jargon.dict.dz
share/dictd/jargon.index
share/dictd/foldoc.dict.dz
share/dictd/foldoc.index
share/dictd/elements.dict.dz
share/dictd/elements.index
share/dictd/easton.dict.dz
share/dictd/easton.index
share/dictd/hitchcock.dict.dz
share/dictd/hitchcock.index
share/dictd/world95.dict.dz
share/dictd/world95.index
@dirrm share/dictd

0 comments on commit 2c4770f

Please sign in to comment.