-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Update gauche to 0.9.3.3. Also, take over maintainership from uebayashi.
Changes are: + Bug fixes: o If DESTDIR was set and the platform didn't have previous Gauche installed, make install failed saying something like "libgauche-0.9.so.0.3: cannot open shared object file: No such file or directory". The order of installation was adjusted to avoid it. o On FreeBSD, a bug in signal setup routine caused memory corruption. o every with more than one argument list didn't return the last return value of the predicate when all the arguments satisfied it, as specified in srfi-1 (it returned #t instead). It was also the case in stream-every. Both are fixed. o On MinGW, info command didn't work. o On MinGW, when you used non-console version gosh-noconsole.exe and tried to spawn a child process to communicate via pipes, gosh-noconsole.exe just died. + Improvements: o New procedure: string-scan-right o GC is now 7.2b
- Loading branch information
enami
committed
May 30, 2012
1 parent
87262ab
commit 2f06857
Showing
5 changed files
with
97 additions
and
52 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,10 @@ | ||
$NetBSD: distinfo,v 1.30 2012/05/14 23:44:56 enami Exp $ | ||
$NetBSD: distinfo,v 1.31 2012/05/30 02:50:11 enami Exp $ | ||
|
||
SHA1 (Gauche-0.9.3.2.tgz) = e2e3f4553674d02a0800c981325de3fef858d9f6 | ||
RMD160 (Gauche-0.9.3.2.tgz) = 5dabfcc8da758d6c5df53b57407c8adf7fb2311e | ||
Size (Gauche-0.9.3.2.tgz) = 5009978 bytes | ||
SHA1 (Gauche-0.9.3.3.tgz) = 71d7ca3eceb9adc1de33455c1616cbed89d226f7 | ||
RMD160 (Gauche-0.9.3.3.tgz) = d5a2fd474b068f8bbc52cb5fe93685ba4bc73b90 | ||
Size (Gauche-0.9.3.3.tgz) = 5042189 bytes | ||
SHA1 (patch-aa) = 44221973454aeb2b4ad1a4c9675f801a64de2806 | ||
SHA1 (patch-af) = 0741e1a047ee7935bffa215a69cc417ba67b81f2 | ||
SHA1 (patch-ag) = ee9946e364d6723b0efe3b260fc5d02ccb04621d | ||
SHA1 (patch-src_Makefile.in) = 54da3a1776a54c48fa194f302e486fff40537c47 | ||
SHA1 (patch-gc_configure) = 58af779f9610199ec538d37b2c359607eddbae9b | ||
SHA1 (patch-gc_dyn__load.c) = 72e09b13b060fbc6dc17b689fc4c9f496901e5b8 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
$NetBSD: patch-gc_configure,v 1.1 2012/05/30 02:50:11 enami Exp $ | ||
|
||
Copied from devel/boehm-gc/patches/patch-ab. | ||
|
||
--- gc/configure.orig 2012-05-28 16:01:24.000000000 +0000 | ||
+++ gc/configure | ||
@@ -5228,7 +5228,7 @@ $as_echo "#define DARWIN_DONT_PARSE_STAC | ||
|
||
fi | ||
|
||
-if test "$GCC" == yes; then | ||
+if test "$GCC" = yes; then | ||
# Disable aliasing optimization unless forced to. | ||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether gcc supports -fno-strict-aliasing" >&5 | ||
$as_echo_n "checking whether gcc supports -fno-strict-aliasing... " >&6; } | ||
@@ -5436,8 +5436,8 @@ esac | ||
$as_echo "$enable_shared" >&6; } | ||
|
||
# Compile with GC_DLL defined unless building static libraries. | ||
-if test "${enable_shared}" == yes; then | ||
- if test "${enable_static}" == no; then | ||
+if test "${enable_shared}" = yes; then | ||
+ if test "${enable_static}" = no; then | ||
$as_echo "#define GC_DLL 1" >>confdefs.h | ||
|
||
# FIXME: Also pass -fvisibility=hidden option if GCC v4+ and not Win32. | ||
@@ -5491,6 +5491,9 @@ $as_echo "#define SOLARIS25_PROC_VDB_BUG | ||
sparc*-*-openbsd*) | ||
machdep="mach_dep.lo sparc_mach_dep.lo" | ||
;; | ||
+ sparc64-*-netbsd*) | ||
+ machdep="mach_dep.lo sparc_mach_dep.lo" | ||
+ ;; | ||
sparc-sun-solaris2.3) | ||
machdep="mach_dep.lo sparc_mach_dep.lo" | ||
|
||
@@ -16422,7 +16425,7 @@ $as_echo "#define SMALL_CONFIG 1" >>conf | ||
|
||
fi | ||
|
||
-if test "$enable_gc_debug" == "no"; then | ||
+if test "$enable_gc_debug" = "no"; then | ||
|
||
$as_echo "#define NO_DEBUGGING 1" >>confdefs.h | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,43 @@ | ||
$NetBSD: patch-gc_dyn__load.c,v 1.1 2012/05/30 02:50:11 enami Exp $ | ||
|
||
commit a378494312ac9aedcb08fa7a9593506ce5620878 | ||
Author: Shiro Kawai <shiro@acm.org> | ||
Date: Mon May 28 17:22:14 2012 -1000 | ||
|
||
Backport a gc patch for NetBSD 6 | ||
|
||
--- gc/dyn_load.c.orig 2012-05-26 10:42:03.000000000 +0000 | ||
+++ gc/dyn_load.c | ||
@@ -77,6 +77,8 @@ STATIC GC_has_static_roots_func GC_has_s | ||
#endif | ||
|
||
#if defined(NETBSD) | ||
+# include <sys/param.h> | ||
+# include <dlfcn.h> | ||
# include <machine/elf_machdep.h> | ||
# define ELFSIZE ARCH_ELFSIZE | ||
#endif | ||
@@ -644,6 +646,15 @@ GC_FirstDLOpenedLinkMap(void) | ||
return(0); | ||
} | ||
if( cachedResult == 0 ) { | ||
+#if defined(NETBSD) && defined(RTLD_DI_LINKMAP) | ||
+ struct link_map *lm = NULL; | ||
+ int rv = dlinfo(RTLD_SELF, RTLD_DI_LINKMAP, &lm); | ||
+ if (rv != 0) | ||
+ return (0); | ||
+ if (lm == NULL) | ||
+ return (0); | ||
+ cachedResult = lm; | ||
+#else /* !(defined(NETBSD) && defined(RTLD_DI_LINKMAP)) */ | ||
int tag; | ||
for( dp = _DYNAMIC; (tag = dp->d_tag) != 0; dp++ ) { | ||
if( tag == DT_DEBUG ) { | ||
@@ -653,6 +664,7 @@ GC_FirstDLOpenedLinkMap(void) | ||
break; | ||
} | ||
} | ||
+#endif /* !(defined(NETBSD) && defined(RTLD_DI_LINKMAP)) */ | ||
} | ||
return cachedResult; | ||
} |
This file was deleted.
Oops, something went wrong.