-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Include a patch taken from the main Courier CVS repository that adds
a new TLS_PROTOCOL selection "SSL23" that allows for trying to negotiate initially with SSLv3 but falling back to SSLv2: courier/tcpd/libcouriertls.c:1.21 This allows Courier to interoperate with older mail servers and clients that are still using SSLv2 when advertising or attempting to use advertised STARTTLS capabilities. This change modifies the following packages and bumps their PKGREVISIONs: mail/courier-imap to 1. mail/courier-mta to 6. meta-pkgs/courier to 2. net/couriertcpd to 1.
- Loading branch information
1 parent
3e50b17
commit 2f710b3
Showing
10 changed files
with
57 additions
and
14 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
$NetBSD: patch-am,v 1.1 2007/09/17 15:28:04 jlam Exp $ | ||
|
||
--- tcpd/libcouriertls.c.orig Sat Oct 28 17:47:32 2006 | ||
+++ tcpd/libcouriertls.c | ||
@@ -418,7 +418,8 @@ SSL_CTX *tls_create(int isserver, const | ||
|
||
ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0 | ||
? SSLv2_method(): | ||
- protocol && strcmp(protocol, "SSL3") == 0 ? SSLv23_method(): | ||
+ protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method(): | ||
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method(): | ||
TLSv1_method()); | ||
|
||
if (!ctx) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
$NetBSD: patch-av,v 1.1 2007/09/17 15:28:05 jlam Exp $ | ||
|
||
--- tcpd/libcouriertls.c.orig Tue May 22 10:59:26 2007 | ||
+++ tcpd/libcouriertls.c | ||
@@ -419,6 +419,7 @@ SSL_CTX *tls_create(int isserver, const | ||
ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0 | ||
? SSLv2_method(): | ||
protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method(): | ||
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method(): | ||
TLSv1_method()); | ||
|
||
if (!ctx) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.4 2007/08/10 17:57:17 jlam Exp $ | ||
$NetBSD: distinfo,v 1.5 2007/09/17 15:28:03 jlam Exp $ | ||
|
||
SHA1 (courier-0.56.0.tar.bz2) = 536f24db9f33f8d93445c03dd4edb50c7ec2f6b2 | ||
RMD160 (courier-0.56.0.tar.bz2) = ce8e2d99f5b7baf500d748c18fbd126df8331398 | ||
Size (courier-0.56.0.tar.bz2) = 7022057 bytes | ||
SHA1 (patch-aa) = df4847bcf1127766f35cfecd65a293fa2bf7d6c9 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
$NetBSD: patch-aa,v 1.3 2007/09/17 15:28:03 jlam Exp $ | ||
|
||
--- tcpd/libcouriertls.c.orig Tue May 22 10:59:26 2007 | ||
+++ tcpd/libcouriertls.c | ||
@@ -419,6 +419,7 @@ SSL_CTX *tls_create(int isserver, const | ||
ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0 | ||
? SSLv2_method(): | ||
protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method(): | ||
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method(): | ||
TLSv1_method()); | ||
|
||
if (!ctx) |