Skip to content

Commit

Permalink
Include a patch taken from the main Courier CVS repository that adds
Browse files Browse the repository at this point in the history
a new TLS_PROTOCOL selection "SSL23" that allows for trying to negotiate
initially with SSLv3 but falling back to SSLv2:

	courier/tcpd/libcouriertls.c:1.21

This allows Courier to interoperate with older mail servers and clients
that are still using SSLv2 when advertising or attempting to use
advertised STARTTLS capabilities.

This change modifies the following packages and bumps their PKGREVISIONs:

	mail/courier-imap	to 1.
	mail/courier-mta	to 6.
	meta-pkgs/courier	to 2.
	net/couriertcpd		to 1.
  • Loading branch information
johnnylam88 committed Sep 17, 2007
1 parent 3e50b17 commit 2f710b3
Show file tree
Hide file tree
Showing 10 changed files with 57 additions and 14 deletions.
5 changes: 3 additions & 2 deletions mail/courier-imap/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.62 2007/08/10 17:56:57 jlam Exp $
# $NetBSD: Makefile,v 1.63 2007/09/17 15:28:04 jlam Exp $

DISTNAME= courier-imap-4.1.3
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
Expand All @@ -10,7 +11,7 @@ COMMENT= IMAP server for access to maildir-style mailboxes
HOMEPAGE= http://www.courier-mta.org/imap/

DEPENDS+= courier-maildir>=0.53.1:../../mail/courier-maildir
DEPENDS+= couriertcpd>=0.53.2nb2:../../net/couriertcpd
DEPENDS+= couriertcpd>=0.56.0nb1:../../net/couriertcpd

USE_TOOLS+= env gmake openssl:run perl
USE_LANGUAGES= c c++
Expand Down
3 changes: 2 additions & 1 deletion mail/courier-imap/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.20 2007/08/10 17:56:57 jlam Exp $
$NetBSD: distinfo,v 1.21 2007/09/17 15:28:04 jlam Exp $

SHA1 (courier-imap-4.1.3.tar.bz2) = d0042e585d6df658a41a1768887d135c89e51ac0
RMD160 (courier-imap-4.1.3.tar.bz2) = b1422973a7c3b13cf35e895a8494761aa4b80834
Expand All @@ -11,3 +11,4 @@ SHA1 (patch-ag) = 6ddd8b3f6a2cfbab4d814b51552dbf364384cf57
SHA1 (patch-ah) = 1870daea8320cc9748961fc7e37237bd5cde1b3c
SHA1 (patch-ak) = 8919d48a0bc8093f30e2cc8316ff242752bcbc4a
SHA1 (patch-al) = 5e3d549c96a0d25f963ecd08f8bf9f077263cd38
SHA1 (patch-am) = dad09106cda99b6f43f5dff01ee7b33fc33def51
14 changes: 14 additions & 0 deletions mail/courier-imap/patches/patch-am
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
$NetBSD: patch-am,v 1.1 2007/09/17 15:28:04 jlam Exp $

--- tcpd/libcouriertls.c.orig Sat Oct 28 17:47:32 2006
+++ tcpd/libcouriertls.c
@@ -418,7 +418,8 @@ SSL_CTX *tls_create(int isserver, const

ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0
? SSLv2_method():
- protocol && strcmp(protocol, "SSL3") == 0 ? SSLv23_method():
+ protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method():
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method():
TLSv1_method());

if (!ctx)
6 changes: 3 additions & 3 deletions mail/courier-mta/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.15 2007/09/11 02:35:04 jlam Exp $
# $NetBSD: Makefile,v 1.16 2007/09/17 15:28:04 jlam Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/-mta-/}
PKGREVISION= 5
PKGREVISION= 6
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
Expand All @@ -14,7 +14,7 @@ COMMENT= Courier mail transport agent
HOMEPAGE= http://www.courier-mta.org/

DEPENDS+= courier-maildir>=${COURIER_VERSION}:../../mail/courier-maildir
DEPENDS+= couriertcpd>=${COURIER_VERSION}:../../net/couriertcpd
DEPENDS+= couriertcpd>=${COURIER_VERSION}nb1:../../net/couriertcpd
DEPENDS+= maildrop>=2.0.4:../../mail/maildrop

USE_TOOLS+= gmake openssl:run perl:run
Expand Down
3 changes: 2 additions & 1 deletion mail/courier-mta/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2007/09/06 04:05:39 jlam Exp $
$NetBSD: distinfo,v 1.7 2007/09/17 15:28:04 jlam Exp $

SHA1 (courier-0.56.0.tar.bz2) = 536f24db9f33f8d93445c03dd4edb50c7ec2f6b2
RMD160 (courier-0.56.0.tar.bz2) = ce8e2d99f5b7baf500d748c18fbd126df8331398
Expand All @@ -22,3 +22,4 @@ SHA1 (patch-ar) = ab2c3e40928933eced0856a7c378c908e8a4689d
SHA1 (patch-as) = 08bd540d92a3ef9db533a92b48c653ed2a256f9b
SHA1 (patch-at) = 7c93cabfe5b1164c6699111cd74e612af887881c
SHA1 (patch-au) = 794fdd49f7994689e4e4ee809293d2e67d9bc4c2
SHA1 (patch-av) = df4847bcf1127766f35cfecd65a293fa2bf7d6c9
12 changes: 12 additions & 0 deletions mail/courier-mta/patches/patch-av
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
$NetBSD: patch-av,v 1.1 2007/09/17 15:28:05 jlam Exp $

--- tcpd/libcouriertls.c.orig Tue May 22 10:59:26 2007
+++ tcpd/libcouriertls.c
@@ -419,6 +419,7 @@ SSL_CTX *tls_create(int isserver, const
ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0
? SSLv2_method():
protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method():
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method():
TLSv1_method());

if (!ctx)
10 changes: 5 additions & 5 deletions meta-pkgs/courier/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2007/09/11 13:52:58 jlam Exp $
# $NetBSD: Makefile,v 1.3 2007/09/17 15:28:05 jlam Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= meta-pkgs mail
MASTER_SITES= # empty
DISTFILES= # empty
Expand All @@ -20,17 +20,17 @@ COURIER_VERSION= 0.56.0
#
# net/couriertcpd, mail/courier-maildir, mail/courier-mta
#
DEPENDS+= couriertcpd>=${COURIER_VERSION}:../../net/couriertcpd
DEPENDS+= couriertcpd>=${COURIER_VERSION}nb1:../../net/couriertcpd
DEPENDS+= courier-maildir>=${COURIER_VERSION}:../../mail/courier-maildir
DEPENDS+= courier-mta>=${COURIER_VERSION}nb5:../../mail/courier-mta
DEPENDS+= courier-mta>=${COURIER_VERSION}nb6:../../mail/courier-mta

# The following packages must be from the same lineage as the version
# of Courier:
#
# mail/maildrop, mail/courier-imap, mail/sqwebmail
#
DEPENDS+= maildrop>=2.0.4nb2:../../mail/maildrop
DEPENDS+= courier-imap>=4.1.3:../../mail/courier-imap
DEPENDS+= courier-imap>=4.1.3nb1:../../mail/courier-imap
DEPENDS+= sqwebmail>=5.1.6nb1:../../mail/sqwebmail

EXTRACT_ONLY= # empty
Expand Down
3 changes: 2 additions & 1 deletion net/couriertcpd/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.8 2007/08/10 17:57:17 jlam Exp $
# $NetBSD: Makefile,v 1.9 2007/09/17 15:28:03 jlam Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/tcpd-/}
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
Expand Down
3 changes: 2 additions & 1 deletion net/couriertcpd/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.4 2007/08/10 17:57:17 jlam Exp $
$NetBSD: distinfo,v 1.5 2007/09/17 15:28:03 jlam Exp $

SHA1 (courier-0.56.0.tar.bz2) = 536f24db9f33f8d93445c03dd4edb50c7ec2f6b2
RMD160 (courier-0.56.0.tar.bz2) = ce8e2d99f5b7baf500d748c18fbd126df8331398
Size (courier-0.56.0.tar.bz2) = 7022057 bytes
SHA1 (patch-aa) = df4847bcf1127766f35cfecd65a293fa2bf7d6c9
12 changes: 12 additions & 0 deletions net/couriertcpd/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.3 2007/09/17 15:28:03 jlam Exp $

--- tcpd/libcouriertls.c.orig Tue May 22 10:59:26 2007
+++ tcpd/libcouriertls.c
@@ -419,6 +419,7 @@ SSL_CTX *tls_create(int isserver, const
ctx=SSL_CTX_new(protocol && strcmp(protocol, "SSL2") == 0
? SSLv2_method():
protocol && strcmp(protocol, "SSL3") == 0 ? SSLv3_method():
+ protocol && strcmp(protocol, "SSL23") == 0 ? SSLv23_method():
TLSv1_method());

if (!ctx)

0 comments on commit 2f710b3

Please sign in to comment.