Skip to content

Commit

Permalink
py-gobject3*: updated to 3.48.2
Browse files Browse the repository at this point in the history
3.48.2 - 2024-04-06
-------------------

* Fix support for fundamental (primitive) types, such as Gst.Bitmask
  :issue:`624` :mr:`304`

3.48.1 - 2024-03-10
-------------------

* Fix installation with pip failing in some environments with
  ModuleNotFoundError in g-ir-scanner :issue:`622` :mr:`302`

3.48.0 - 2024-03-09
-------------------

:Note: See 3.47.0 below for more details.

* test: fix some tests on macOS :mr:`296`
* docs: some dark mode fixes :mr:`291`


3.47.0 - 2024-02-12 (pre-release)
---------------------------------

:Note: This is an unstable release.

:Note: This is the first release using meson-python, and thus meson, instead of
  setuptools for PEP-517 installations i.e. when installing via pip or similar.
  Distro packagers can continue to use plain meson to build pygobject, but doing
  PEP-517 builds should also be possible with meson-python instead of
  setuptools.

* Drop setuptools in favor of meson-python :mr:`248` :mr:`253` :mr:`254` :mr:`255` :mr:`276`
* Fundamental type support :mr:`250`
* Fundamental type support for GValues :mr:`264`
* pygi-convert.sh: migrate FILE_CHOOSER_CONFIRMATION_* :mr:`266`
* gimodule, cairo: Use multi-phase initialization as per PEP-489 :mr:`271`
* Deprecate classes in gi.option module :mr:`272`
* Deprecate pygtkcompat :mr:`278`
* Add support for (optional) nullable GErrors :mr:`259`
* Fix CssProvider not valid in GTK2 :mr:`284`
* Fix double free if array item cannot be marshalled to Python :mr:`280`
* Raise exception if a callback property is encountered :mr:`269`
* build: Fix pycairo detection "script" for Windows :mr:`267`
* Replace deprecated ``pkgutil.find_loader`` call :mr:`252`
* Avoid segfault on property access for incompletely initialized objects :mr:`260`
* pygenum: When getting a member instance, use correct key for the lookup :mr:`262`

Project / Development / CI:

* Remove pborelli from the maintainer list :mr:`251`
* Add Arjan Molenaar to maintainers :mr:`256`
* Remove runtests script :mr:`257`
* test: build in a minimal environment without gtk :mr:`258`
* CI: add a job for creating sdists :mr:`294`

Documentation:

* Build documentation on GitLab Pages :mr:`287` :mr:`289`
* Update docs to use Furo theme :mr:`288`
* Various docs improvements: :mr:`274` :mr:`281` :mr:`282` :mr:`285` :mr:`286` :mr:`292`


3.44.2 - 2023-09-29
-------------------

* Add support for Python 3.12 (minor test fixes) :mr:`247`
* meson: define pycairo_dep in case pycairo=disabled :mr:`242`
* Complete the PEP-451 implementation in gi.importer :mr:`229`
* Replace usage of deprecated FFI closure API :mr:`241`
* Fix invalid marshalling in some cases for boxed values, for example with
  Gtk.StyleContext.get_property() :mr:`213`
* overrides: Allow Gdk.{Color,RGBA} instances to be compared with other objects :mr:`233`
* docs: Fix build failure due to extlinks with Sphinx 6 :mr:`244`


3.46.0 - 2023-09-10
-------------------

* build: Drop Python 3.7 support :mr:`238`
* build: Require glib 2.64 and gobject-introspection 1.64 :mr:`243`
* Add support for Python 3.12 (minor test fixes) :mr:`247`
* Drop GTK 2 support (after being effectively unsupported for 12 years) :mr:`182`
* meson: Require meson 0.56.0 :mr:`220`
* meson: Set PYTHONPATH in devenv :mr:`235`
* meson: define pycairo_dep in case pycairo=disabled :mr:`242`
* meson: Use pycairo from target python before pkg-config :mr:`223`
* Complete the PEP-451 implementation in gi.importer :mr:`229`
* Replace usage of deprecated FFI closure API :mr:`241`
* Fix invalid marshalling in some cases for boxed values, for example with
  Gtk.StyleContext.get_property() :mr:`213`
* Consistent setting of enum and flag property :mr:`192`
* Fix docstring for methods that return an array and have a length (out) argument :mr:`249`
* overrides: Fix incompatibility for CssProvider.load_from_data() (GTK 4.10) :mr:`231`
* overrides: Allow Gdk.{Color,RGBA} instances to be compared with other objects :mr:`233`
* overrides: Add overrides for Gdk.FileList in Gdk-4.0 :mr:`245`
* docs: Fix underline too short warning :mr:`246`
* docs: Fix build failure due to extlinks with Sphinx 6 :mr:`244`
* docs: List additional projects using PyGObject :mr:`230`
* docs: Update Development Environment Docs :mr:`232`
* docs: Update docs and code examples to GTK 4 :mr:`215`
  • Loading branch information
adam committed Apr 25, 2024
1 parent f6276eb commit 347a14e
Show file tree
Hide file tree
Showing 4 changed files with 22 additions and 27 deletions.
20 changes: 9 additions & 11 deletions devel/py-gobject3/Makefile
Original file line number Diff line number Diff line change
@@ -1,36 +1,34 @@
# $NetBSD: Makefile,v 1.51 2024/04/07 07:33:50 wiz Exp $
# $NetBSD: Makefile,v 1.52 2024/04/25 10:06:10 adam Exp $

PKGREVISION= 3
.include "Makefile.common"

PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/^py//:S/-/3-/}
EGG_NAME= ${DISTNAME:S/pygobject/PyGObject/}

COMMENT= Python bindings for glib2 gobject

MESON_ARGS+= -Dpython=${PYTHONBIN:Q}
MESON_ARGS+= -Dtests=false
TEST_TARGET= check
#MESON_ARGS+= -Dpython=${PYTHONBIN:Q}
#MESON_ARGS+= -Dtests=false
#TEST_TARGET= check

TOOL_DEPENDS+= ${PYPKGPREFIX}-meson_python>=0.12.1:../../devel/py-meson_python

PYTHON_VERSIONS_INCOMPATIBLE= 27

# Leave for py-gobject3-common:
post-install:
${RM} \
${DESTDIR}${PREFIX}/include/pygobject-3.0/pygobject.h \
${DESTDIR}${PREFIX}/lib/pkgconfig/pygobject-3.0.pc
${RM} ${DESTDIR}${PREFIX}/include/python${PYVERSSUFFIX}/pygobject/pygobject-3.0/pygobject.h

BUILDLINK_API_DEPENDS.glib2= glib2>=2.48.0
.include "../../devel/glib2/buildlink3.mk"
BUILDLINK_API_DEPENDS.gobject-introspection= gobject-introspection>=1.46.0
.include "../../devel/gobject-introspection/buildlink3.mk"
.include "../../devel/libffi/buildlink3.mk"
.include "../../devel/py-gobject3-common/buildlink3.mk"
.include "../../devel/meson/build.mk"
#.include "../../devel/meson/build.mk"
# https://bugzilla.gnome.org/show_bug.cgi?id=685094
# https://bugzilla.gnome.org/show_bug.cgi?id=707196
.include "../../graphics/py-cairo/buildlink3.mk"
BUILDLINK_API_DEPENDS.cairo+= cairo>=1.18
.include "../../graphics/cairo/buildlink3.mk"
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"
9 changes: 5 additions & 4 deletions devel/py-gobject3/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.21 2024/04/17 11:57:36 wiz Exp $
# $NetBSD: Makefile.common,v 1.22 2024/04/25 10:06:10 adam Exp $
# used by devel/py-gobject3/Makefile
# used by devel/py-gobject3-common/Makefile

DISTNAME= pygobject-3.44.1
DISTNAME= pygobject-3.48.2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/pygobject/${PKGVERSION_NOREV:R}/}
EXTRACT_SUFX= .tar.xz
Expand All @@ -11,8 +11,9 @@ MAINTAINER?= [email protected]
HOMEPAGE= https://pygobject.readthedocs.io/
LICENSE= gnu-lgpl-v2.1

USE_LANGUAGES= c c99
USE_TOOLS+= pkg-config
USE_CC_FEATURES= c99
USE_LANGUAGES= c
USE_TOOLS+= pkg-config

DISTINFO_FILE= ../../devel/py-gobject3/distinfo
#PATCHDIR= ../../devel/py-gobject3/patches
Expand Down
12 changes: 4 additions & 8 deletions devel/py-gobject3/PLIST
Original file line number Diff line number Diff line change
@@ -1,11 +1,7 @@
@comment $NetBSD: PLIST,v 1.13 2022/01/28 14:22:15 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/PyGObject-${PKGVERSION}.egg-info
@comment $NetBSD: PLIST,v 1.14 2024/04/25 10:06:10 adam Exp $
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/gi/__init__.py
${PYSITELIB}/gi/__init__.pyc
${PYSITELIB}/gi/__init__.pyo
Expand Down
8 changes: 4 additions & 4 deletions devel/py-gobject3/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.27 2023/06/06 10:41:43 adam Exp $
$NetBSD: distinfo,v 1.28 2024/04/25 10:06:10 adam Exp $

BLAKE2s (pygobject-3.44.1.tar.xz) = c52ab90e8b213b28d8646f9407cc90222ea142a0de2660467629012b4ae55045
SHA512 (pygobject-3.44.1.tar.xz) = 5f2ff4a068e7e24dcc32f8c43ba58660c85a0fabdd9ff0bac4ddf1ca82bd0fc962ce5cb3ab25b991c212d45e5e89dac67c3259c5423a7d7fd70b2ac1f56e5327
Size (pygobject-3.44.1.tar.xz) = 559432 bytes
BLAKE2s (pygobject-3.48.2.tar.xz) = 78f24d543826c57024d6c3228d66464b96503a2d8fbb4c791f52e8a6e6300e10
SHA512 (pygobject-3.48.2.tar.xz) = 11619f73be5894fae82b261779f33390d1aec51b02bcf285c58f3c76ee46dfc1b3f435e4662176fde5ca899aee5afc453f8f0ba28e15e15330a52354cf737d45
Size (pygobject-3.48.2.tar.xz) = 556244 bytes

0 comments on commit 347a14e

Please sign in to comment.