Skip to content

Commit

Permalink
Update to 0.98.12, from Leonard Schmidt in PR 28327.
Browse files Browse the repository at this point in the history
Changes since previous version:
        Fixed a bug that was causing 2xscale/3xscale to be broken
        when clipping the leftmost and rightmost 8 columns.

        Added an iNES header correction entry for JustBreed.

        Modified the MMC5 "ELROM" board emulation to not emulate WRAM.

        Corrected various pieces of code that were causing compiler warnings.

        When the PPU is in a "dead" state after starting up, the graphics
        buffer is now cleared.  Previously, particularly in the Windows port, when
        a game was closed, and a new game was loaded, the last image from
        the previous game would be displayed for a short time.

        Removed some debugging code that shouldn't have been enabled in 0.98.11.
  • Loading branch information
0-wiz-0 committed Nov 19, 2004
1 parent 638da30 commit 3c267ad
Show file tree
Hide file tree
Showing 3 changed files with 14 additions and 16 deletions.
5 changes: 2 additions & 3 deletions emulators/fceu/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.4 2004/10/03 00:14:40 tv Exp $
# $NetBSD: Makefile,v 1.5 2004/11/19 18:58:37 wiz Exp $
#

DISTNAME= fceu-0.98.11.src
DISTNAME= fceu-0.98.12.src
PKGNAME= ${DISTNAME:S/.src//}
PKGREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://fceultra.sourceforge.net/releases/
EXTRACT_SUFX= .tar.bz2
Expand Down
8 changes: 4 additions & 4 deletions emulators/fceu/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.5 2004/08/22 11:56:46 kristerw Exp $
$NetBSD: distinfo,v 1.6 2004/11/19 18:58:37 wiz Exp $

SHA1 (fceu-0.98.11.src.tar.bz2) = 60caac7bb9dd40920fd28ef3d1a823979c17692e
Size (fceu-0.98.11.src.tar.bz2) = 556643 bytes
SHA1 (fceu-0.98.12.src.tar.bz2) = 713faaad9f7d4b5e8dd1cb8a172e2f1ced85c1ec
Size (fceu-0.98.12.src.tar.bz2) = 559571 bytes
SHA1 (patch-aa) = df9e098102d4c22c2699d5c5bdec79d72b8bac0c
SHA1 (patch-ab) = 593c40bfe03e8ae8835113972a58a1cf46e882a9
SHA1 (patch-ac) = 8a5297b11484c6eaf5d70a391bb486ff58475f35
SHA1 (patch-ad) = 2a253539f9103b75a09f31d51427e8849a3b0249
SHA1 (patch-ae) = 4116f1df12b81f1a7a99b61f5aea7acaa5db0d6b
SHA1 (patch-ae) = d088b473376460ce29b17abd5dc4521513c55057
17 changes: 8 additions & 9 deletions emulators/fceu/patches/patch-ae
Original file line number Diff line number Diff line change
@@ -1,19 +1,18 @@
$NetBSD: patch-ae,v 1.1 2004/08/22 11:56:46 kristerw Exp $

--- src/movie.c.orig Sun Aug 22 13:44:10 2004
+++ src/movie.c Sun Aug 22 13:44:49 2004
@@ -154,6 +154,7 @@
--- src/movie.c.orig 2004-11-13 13:41:55.000000000 +0000
+++ src/movie.c 2004-11-13 13:42:39.000000000 +0000
@@ -154,7 +154,7 @@

void FCEUMOV_AddJoy(uint8 *js)
{
+ int tmpfix;
int x,y;
- int x,y;
+ int x,y,tmpfix;

if(!current) return; /* Not playback nor recording. */
@@ -190,7 +191,7 @@
tmp >>= 5;
@@ -191,7 +191,7 @@
tmp &= 0x3;
ti=0;

- int tmpfix = tmp;
+ tmpfix = tmp;
while(tmp--) { nextts |= fgetc(slots[-1 - current]) << (ti * 8); ti++; }
Expand Down

0 comments on commit 3c267ad

Please sign in to comment.