Skip to content

Commit

Permalink
tlf: Fix building with latest hamlib.
Browse files Browse the repository at this point in the history
  • Loading branch information
alarixnia committed May 5, 2022
1 parent e926e79 commit 3ec8c4f
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 1 deletion.
3 changes: 2 additions & 1 deletion ham/tlf/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.10 2021/10/26 10:48:40 nia Exp $
$NetBSD: distinfo,v 1.11 2022/05/05 13:37:18 nia Exp $

BLAKE2s (tlf-0.9.31-2.tar.gz) = 13aaff43d448c6deff3ffafede6e051b6c0a19b09538c49092c063743cad2da7
SHA512 (tlf-0.9.31-2.tar.gz) = 18340b6b580bd63b76c848ea8e92466dc2833b1fb693c5960e707325cd3220c3f269624d99de8d7a4a10f7df3331ee2d19ca68d9e34ca4dda2c5af4e8dd2581e
Expand All @@ -8,3 +8,4 @@ SHA1 (patch-ab) = 4cb7a8ed026d2a9bfed5dbe3ea6ce3d275ffc621
SHA1 (patch-ac) = dca763b7c9da4ed936fe686972d93f139d99c2e7
SHA1 (patch-ad) = 8d980f329644f91c2a2b33bd7af9f7f1f75e22c5
SHA1 (patch-ae) = 4b9203a3e20bba5a074c681dc6b02f827aceca75
SHA1 (patch-src_sendqrg.c) = 1dba63621e4e78c24292e552c0a3068818478428
35 changes: 35 additions & 0 deletions ham/tlf/patches/patch-src_sendqrg.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
$NetBSD: patch-src_sendqrg.c,v 1.1 2022/05/05 13:37:18 nia Exp $

Fix building with latest hamlib.

--- src/sendqrg.c.orig 2007-12-18 15:08:05.000000000 +0000
+++ src/sendqrg.c
@@ -116,13 +116,13 @@ int init_tlf_rig (void)
else {
if (strlen(rigportname) > 1) {
rigportname[strlen(rigportname)-1] = '\0'; // remove '\n'
- strncpy(my_rig->state.rigport.pathname, rigportname, FILPATHLEN);
+ strncpy(my_rig->state.rigport.pathname, rigportname, HAMLIB_FILPATHLEN);
}
else {
if (rig_port == 0)
- strncpy(my_rig->state.rigport.pathname, "/dev/ttyS0", FILPATHLEN);
+ strncpy(my_rig->state.rigport.pathname, "/dev/ttyS0", HAMLIB_FILPATHLEN);
else
- strncpy(my_rig->state.rigport.pathname, "/dev/ttyS1", FILPATHLEN);
+ strncpy(my_rig->state.rigport.pathname, "/dev/ttyS1", HAMLIB_FILPATHLEN);
}

}
@@ -132,9 +132,9 @@ int init_tlf_rig (void)
if (dcd_type != RIG_DCD_NONE)
my_rig->state.dcdport.type.dcd = dcd_type;
if (ptt_file)
- strncpy(my_rig->state.pttport.pathname, ptt_file, FILPATHLEN);
+ strncpy(my_rig->state.pttport.pathname, ptt_file, HAMLIB_FILPATHLEN);
if (dcd_file)
- strncpy(my_rig->state.dcdport.pathname, dcd_file, FILPATHLEN);
+ strncpy(my_rig->state.dcdport.pathname, dcd_file, HAMLIB_FILPATHLEN);

my_rig->state.rigport.parm.serial.rate = serial_rate ;

0 comments on commit 3ec8c4f

Please sign in to comment.