Skip to content

Commit

Permalink
Changes 0.68.1:
Browse files Browse the repository at this point in the history
* rfc2045mkboundary.c was broken in 0.68

Changes 0.68:
* rfc2045/rfc2045mkboundary.c (rfc2045_mk_boundary): truncate
the hostname portion of the boundary to 30 chars.
* courier/doc/courier.sgml: Remove descriptions of some configuration
files that were moved to the courier-authlib package a while ago.
They don't belong here any more.
* courier/submit.C: Use the authenticated address, instead of the
return address, for domain-based virtual configuration.
* courier/libs/cfilename.c (config_has_vhost): Checks whether
vhost.[ip] exists.
* courier/module.esmtp/courieresmtpd.c (main): Only set a message's
virtual host if vhost.[ip] exists.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): Make sure the
input buffer is null-terminated.
* courier/submit.C (getrcpts): If there's no vhost setting from the
sender's IP address (this includes local mail!) if vhost.domain exists,
use [domain] as the virtual host.
* Remove config_search(), which simply called config_localfilename().
Change all current callers to call config_localfilename().
* courier/libs/cfilename.c (config_set_local_vhost): saves a string
that gets appended as a suffix, by config_localfilename(), and if that
filename exists, that's returned as the filename, otherwise it's the
original string without the suffix. config_get_local_vhost() returns
the suffix string.
to config_set_local_vhost().
* courier/libs/comsubmitclient.c (submit_fork): If
config_get_local_vhost(), add a -vhost parameter to submit().
* courier/submit.C (cppmain): -vhost sets config_set_local_vhost().
* courier/submit2.C (closectl): New COMCTLFILE_VHOST parameter in the
config file, taken from the vhost setting.
* courier/libs/comctlfile.c (ctlfile_setvhost): If COMCTLFILE_VHOST is
set, call ctlfile_setvhost(), return an indication if the vhost has
changed. Absence of a COMCTLFILE_VHOST treated as a discrete "(null)"
setting.
* courier/module.esmtp/esmtpclient.c (esmtpchild): If ctlfile_setvhost()
then disconnect the current socket, if one is open.
* courier/module.esmtp/esmtpclient.c (get_sourceaddr): The IP address
specified in ipout or ip6out overrides SOURCE_ADDRESS and
SOURCE_ADDRESS_IPV6 environment variable.
* courier/module.local/localmail.c (main): Call ctlfile_setvhost().
* courier/module.uucp/uucp.c (uux): Call ctlfile_setvhost().
* courier/module.dsn/dsn.c (main): Call ctlfile_setvhost().
* liblock/mail.c (dotlock_exists): Quell a compiler warning.
* courier/courierd.dist.in SOURCE_ADDRESS: Add a note that this setting
is deprecated.
  • Loading branch information
adam committed Jun 9, 2012
1 parent 2ab857c commit 3f27b2d
Show file tree
Hide file tree
Showing 22 changed files with 82 additions and 106 deletions.
8 changes: 3 additions & 5 deletions mail/courier-maildir/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.24 2012/03/03 00:14:26 wiz Exp $
# $NetBSD: Makefile,v 1.25 2012/06/09 11:45:38 adam Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/-maildir-/}
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
Expand All @@ -23,18 +22,17 @@ USE_LANGUAGES= c c++
# This package doesn't need to depend on courier-authlib -- just fake
# out the top-level configure script that thinks it needs
# courierauthconfig.
#
CONFIGURE_ENV+= ac_cv_path_COURIERAUTHCONFIG=${TRUE:Q}

# These are files required by the Courier configure scripts.
WRKSRC_FILES= courier/courier.c config.guess config.sub \
configure depcomp install-sh ltmain.sh missing \
sysconftool
WRKSRC_FILES+= Makefile.in courier.spec.in courier.lpspec.in \
dbobj.h.in dbobj.config.in courier.sysvinit.in
dbobj.h.in dbobj.config.in courier.service.in \
courier.sysvinit.in

# These are subdirectories containing libraries used by courier-maildir.
#
WRKSRC_SUBDIRS= bdbobj numlib liblock unicode rfc822 maildir

EXTRACT_ELEMENTS= ${WRKSRC_FILES:S/^/${DISTNAME}\//}
Expand Down
8 changes: 4 additions & 4 deletions mail/courier-maildir/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.15 2010/11/10 10:40:15 adam Exp $
$NetBSD: distinfo,v 1.16 2012/06/09 11:45:38 adam Exp $

SHA1 (courier-0.65.2.tar.bz2) = 784893216ea6c43c91606fa550cfdff13060855d
RMD160 (courier-0.65.2.tar.bz2) = 6a81f74c85f9e78e6514f840598dde634fe070ce
Size (courier-0.65.2.tar.bz2) = 7152680 bytes
SHA1 (courier-0.68.1.tar.bz2) = fbd7cd0bc88876dc12d02b9404cea95877805ebe
RMD160 (courier-0.68.1.tar.bz2) = 3f062aae0d34a71055a5ff5ad172ca191ab3f0e4
Size (courier-0.68.1.tar.bz2) = 7024234 bytes
6 changes: 2 additions & 4 deletions mail/courier-mta/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.35 2012/03/03 00:13:28 wiz Exp $
# $NetBSD: Makefile,v 1.36 2012/06/09 11:45:38 adam Exp $

DISTNAME= courier-${COURIER_VERSION}
PKGNAME= ${DISTNAME:S/-/-mta-/}
PKGREVISION= 2
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/}
EXTRACT_SUFX= .tar.bz2
Expand Down Expand Up @@ -50,7 +49,6 @@ CONFIGURE_ARGS+= --with-transport=${COURIER_TRANSPORTS:M*:Q}
# This argument is actually here just to make the "webmail" configure
# script work. The value is not actually used since in reality, we are
# using the sqwebmail package to provide the Courier webmail component.
#
CONFIGURE_ARGS+= --enable-mimetypes=/nonexistent

INSTALL_DIRS= webadmin courier
Expand Down Expand Up @@ -78,7 +76,7 @@ SUBST_STAGE.courier= pre-configure

SUBST_CLASSES+= perms
SUBST_FILES.perms= courier/perms.sh.in
SUBST_SED.perms+= -e "s,@REAL_ROOT_USER@,"${REAL_ROOT_USER}",g" \
SUBST_SED.perms= -e "s,@REAL_ROOT_USER@,"${REAL_ROOT_USER}",g" \
-e "s,@ROOT_USER@,"${ROOT_USER}",g" \
-e "s,@ROOT_GROUP@,"${ROOT_GROUP}",g"
SUBST_STAGE.perms= pre-configure
Expand Down
5 changes: 2 additions & 3 deletions mail/courier-mta/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: Makefile.common,v 1.13 2010/11/10 10:40:15 adam Exp $
# $NetBSD: Makefile.common,v 1.14 2012/06/09 11:45:38 adam Exp $
#
# used by mail/courier-imap/Makefile
# used by mail/courier-maildir/Makefile
# used by mail/maildrop/Makefile
# used by mail/sqwebmail/Makefile
# used by net/couriertcpd/Makefile

COURIER_VERSION= 0.65.2
COURIER_VERSION= 0.68.1
LICENSE= gnu-gpl-v3

.include "../../mk/bsd.prefs.mk"
Expand Down Expand Up @@ -34,7 +34,6 @@ USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localstatedir=${COURIER_STATEDIR}
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}

CONFIGURE_ARGS+= --disable-root-check
CONFIGURE_ARGS+= --enable-unicode
CONFIGURE_ARGS+= --enable-utf7-folder-encoding
Expand Down
7 changes: 1 addition & 6 deletions mail/courier-mta/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2010/11/05 14:12:11 adam Exp $
@comment $NetBSD: PLIST,v 1.9 2012/06/09 11:45:38 adam Exp $
bin/cancelmsg
bin/courier-config
bin/couriermlm
Expand Down Expand Up @@ -171,7 +171,6 @@ share/doc/courier/courierfilter.html
share/doc/courier/courierldapaliasd.html
share/doc/courier/couriermlm.html
share/doc/courier/courierperlfilter.html
share/doc/courier/cvs.html
share/doc/courier/documentation.html
share/doc/courier/dot-courier.html
share/doc/courier/dot-forward.html
Expand Down Expand Up @@ -222,10 +221,6 @@ share/examples/courier/locallowercase
share/examples/courier/maildrop
share/examples/courier/maildropfilter
share/examples/courier/mailer.conf
share/examples/courier/rfcerr2045.txt
share/examples/courier/rfcerr2046.txt
share/examples/courier/rfcerr2047.txt
share/examples/courier/rfcerrheader.txt
share/examples/courier/smtpaccess/default
share/examples/courier/webmlmrc.dist
share/examples/rc.d/courier
Expand Down
32 changes: 16 additions & 16 deletions mail/courier-mta/distinfo
Original file line number Diff line number Diff line change
@@ -1,20 +1,20 @@
$NetBSD: distinfo,v 1.16 2011/11/26 17:14:42 joerg Exp $
$NetBSD: distinfo,v 1.17 2012/06/09 11:45:38 adam Exp $

SHA1 (courier-0.65.2.tar.bz2) = 784893216ea6c43c91606fa550cfdff13060855d
RMD160 (courier-0.65.2.tar.bz2) = 6a81f74c85f9e78e6514f840598dde634fe070ce
Size (courier-0.65.2.tar.bz2) = 7152680 bytes
SHA1 (patch-aa) = eaf5ade8fb49254aeeb66a3dc07368d1559d62e8
SHA1 (patch-ab) = 0152fc7e178cd6634142e05606b5cfa66bfa163d
SHA1 (patch-ac) = 78ce4535d6a0d88d00cf0199c879786cde0eb1c1
SHA1 (patch-ad) = a93db864d07813fe80f6345528ec0ae472fde0a7
SHA1 (patch-ae) = e52ab2f6a4e253dc4a28291db6744ea2593f2fc3
SHA1 (patch-af) = 17afc29c101568e87d941a1f87860523d02b5ac9
SHA1 (patch-ag) = 1bedd756d9932365896da82704941cdbc06e1dfd
SHA1 (patch-ah) = d3ee8e92a2927d25f77791db6468b17e6d0e0cf0
SHA1 (patch-ai) = 1337870d95bb46882980553ffba6ec6956bc9147
SHA1 (patch-aj) = cf666ac5c05e9fb5aef9c23d534edefa745ab547
SHA1 (courier-0.68.1.tar.bz2) = fbd7cd0bc88876dc12d02b9404cea95877805ebe
RMD160 (courier-0.68.1.tar.bz2) = 3f062aae0d34a71055a5ff5ad172ca191ab3f0e4
Size (courier-0.68.1.tar.bz2) = 7024234 bytes
SHA1 (patch-aa) = 26af5d3ffd188fb7ab6ce18ef3241305e3c2363a
SHA1 (patch-ab) = b65ceddc722962592af713c20fcf99da76b6af50
SHA1 (patch-ac) = 225b0c418758e38e4f144100b1b2a34362008c33
SHA1 (patch-ad) = 4a086c2d72106913989aa248d4d70b932a67eb90
SHA1 (patch-ae) = 25cf54b4764da79d7c2a4ee40189b93542a2d1ff
SHA1 (patch-af) = d5222c55039eb1060d1486d1d776e9f7afe9a991
SHA1 (patch-ag) = fc9bfb34ce7a93647076c2305d206fd36ce54d9a
SHA1 (patch-ah) = ef516d4da2acaffe72dd32a859ef03c2593a7b1e
SHA1 (patch-ai) = ee3ae11ec6342afcd2284f4607b6f15412c1ac15
SHA1 (patch-aj) = 9c4e9525f05ca73cb7358e4e0b341ef3e9aa08a5
SHA1 (patch-al) = 1c7935b46b7affafa86e4a858ba6a79b7fbebbc5
SHA1 (patch-an) = 7c8693271f18b59515ff19ff6b447f2fd28416f4
SHA1 (patch-ax) = cd7fc4f373e83c1d6777103dc075455f98d24f51
SHA1 (patch-an) = 2b78be9a0e8a9daf528da83007ba865f9b8cc402
SHA1 (patch-ax) = 8978eacb3aa13559905849e9a7038441c0dfef22
SHA1 (patch-ay) = d4b391e76167cd27012f928587d5feb57ea1b4ff
SHA1 (patch-courier_cdfilters.C) = 1f9169de45355cd9a4ecb7e8ddac30df05d368d0
10 changes: 1 addition & 9 deletions mail/courier-mta/options.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.10 2008/02/21 15:50:29 jlam Exp $
# $NetBSD: options.mk,v 1.11 2012/06/09 11:45:38 adam Exp $

# Global and legacy options

Expand All @@ -9,7 +9,6 @@ PKG_SUGGESTED_OPTIONS= courier-dsn courier-esmtp courier-local inet6

.include "../../mk/bsd.options.mk"

######################################################################
###
### delivery sender notification mail transport
###
Expand All @@ -26,7 +25,6 @@ CONF_FILES_PERMS+= ${EGDIR}/${_file_} \
. endfor
.endif

######################################################################
###
### ESMTP mail transport
###
Expand All @@ -52,7 +50,6 @@ CONF_FILES_PERMS+= ${EGDIR}/esmtpauthclient \
${COURIER_USER} ${COURIER_GROUP} 0600
.endif

######################################################################
###
### fax mail transport
###
Expand All @@ -77,7 +74,6 @@ CONF_FILES_PERMS+= ${EGDIR}/faxrc.dist ${PKG_SYSCONFDIR}/faxrc \
${COURIER_USER} ${COURIER_GROUP} 0640
.endif

######################################################################
###
### local mail tranport
###
Expand All @@ -90,7 +86,6 @@ CONF_FILES_PERMS+= ${EGDIR}/module.local \
${COURIER_FILE_PERMS}
.endif

######################################################################
###
### UUCP mail transport
###
Expand All @@ -112,7 +107,6 @@ PKG_FAIL_REASON+= "[courier/options.mk] No mail transports specified."
.endif


######################################################################
###
### IPv6 support (used by Courier ESMTP client)
###
Expand All @@ -122,7 +116,6 @@ CONFIGURE_ARGS+= --with-ipv6
CONFIGURE_ARGS+= --without-ipv6
.endif

######################################################################
###
### LDAP alias lookup support
###
Expand All @@ -141,7 +134,6 @@ FILES_SUBST+= COURIERLDAPALIASD=
CONFIGURE_ARGS+= --without-ldapaliasd
.endif

######################################################################
###
### Support using the GNU TLS tools for creating certificates; otherwise,
### default to using OpenSSL.
Expand Down
24 changes: 12 additions & 12 deletions mail/courier-mta/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
$NetBSD: patch-aa,v 1.7 2012/06/09 11:45:38 adam Exp $

--- courier/Makefile.in.orig 2007-11-23 22:26:43.000000000 -0500
--- courier/Makefile.in.orig 2011-04-04 13:07:49.000000000 +0000
+++ courier/Makefile.in
@@ -47,16 +47,16 @@ build_triplet = @build@
@@ -46,16 +46,16 @@ build_triplet = @build@
host_triplet = @host@
target_triplet = @target@
pkglibexec_PROGRAMS = aliasexp$(EXEEXT) aliascombine$(EXEEXT) \
Expand All @@ -24,10 +24,10 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
@EXTRASBIN@ $(am__empty)
cmdlib_PROGRAMS = submitmkdir$(EXEEXT) courierd$(EXEEXT) @EXTRACMDLIB@
subdir = .
@@ -477,29 +477,26 @@ BUILT_SOURCES = prefix.h exec_prefix.h s
@@ -473,29 +473,26 @@ DISTCLEANFILES = uidgid
BUILT_SOURCES = prefix.h exec_prefix.h sysconfdir.h localstatedir.h \
libexecdir.h bindir.h sbindir.h datadir.h filtersocketdir.h \
uidgid.h configargs.h sort.h webmlmdhandlerslist.H
RFCERRTXTIN = rfcerrheader.txt
RFCERRTXTNOIN = rfcerr2045.txt rfcerr2046.txt rfcerr2047.txt
-extrapkglib = makedatprog courierpop3login pcpd
+extrapkglib =
webmaildir = $(libexecdir)/courier/webmail
Expand All @@ -51,8 +51,8 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
+sysconf_DATA = \
courierd.dist @LDAPALIASRC@ \
- imapd.dist imapd-ssl.dist pop3d.dist pop3d-ssl.dist \
- quotawarnmsg.example $(RFCERRTXTNOIN) $(RFCERRTXTIN) webmlmrc.dist
+ $(RFCERRTXTNOIN) $(RFCERRTXTIN) webmlmrc.dist
- quotawarnmsg.example webmlmrc.dist
+ webmlmrc.dist

databindir = $(datadir)
-databin_SCRIPTS = courierctl.start makedat makealiases makehosteddomains \
Expand All @@ -61,7 +61,7 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $

mlmdatadir = $(datadir)/couriermlm
mlmdata_DATA = \
@@ -555,7 +552,7 @@ mlmdata_DATA = \
@@ -551,7 +548,7 @@ mlmdata_DATA = \
webmlmsublist.tmpl.html \
webmlm.tmpl.html

Expand All @@ -70,7 +70,7 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
cmdlibdir = @libexecdir@/courier

# Subdirectories
@@ -1896,6 +1893,12 @@ couriertls$(EXEEXT): ../tcpd/couriertls$
@@ -1890,6 +1887,12 @@ couriertls$(EXEEXT): ../tcpd/couriertls$
courierpop3login$(EXEEXT): ../imap/pop3login$(EXEEXT)
cp -f ../imap/pop3login$(EXEEXT) courierpop3login$(EXEEXT)

Expand All @@ -83,7 +83,7 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
sort.h:
echo '#define SORT "$(SORT)"' >sort.h

@@ -2051,39 +2054,21 @@ dist-hook:
@@ -2045,39 +2048,21 @@ dist-hook:

install-exec-hook:
for d in $(bindir) $(sbindir) $(libexecdir) $(libexecdir)/courier \
Expand Down Expand Up @@ -125,7 +125,7 @@ $NetBSD: patch-aa,v 1.6 2010/06/15 23:01:23 pettai Exp $
test -f $(DESTDIR)$(sysconfdir)/enablefiltering && exit 0; \
echo esmtp >$(DESTDIR)$(sysconfdir)/enablefiltering
test -f $(DESTDIR)$(sysconfdir)/aliases/system && exit 0; \
@@ -2095,10 +2080,6 @@ install-data-hook:
@@ -2089,10 +2074,6 @@ install-data-hook:
rm -f $(DESTDIR)$(bindir)/rmail
$(LN_S) sendmail $(DESTDIR)$(bindir)/rmail
-$(mkinstalldirs) $(DESTDIR)@mandir@/man8
Expand Down
4 changes: 2 additions & 2 deletions mail/courier-mta/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.6 2010/06/15 23:01:23 pettai Exp $
$NetBSD: patch-ab,v 1.7 2012/06/09 11:45:38 adam Exp $

--- courier/configure.orig 2007-11-24 03:26:42.000000000 +0000
+++ courier/configure
@@ -18398,9 +18398,9 @@ done
@@ -16102,9 +16102,9 @@ done

if test "$testmode" = "0"
then
Expand Down
4 changes: 2 additions & 2 deletions mail/courier-mta/patches/patch-ac
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.6 2010/06/15 23:01:23 pettai Exp $
$NetBSD: patch-ac,v 1.7 2012/06/09 11:45:38 adam Exp $

--- courier/doc/Makefile.in.orig 2007-11-17 19:48:53.000000000 -0500
+++ courier/doc/Makefile.in
Expand Down Expand Up @@ -98,7 +98,7 @@ $NetBSD: patch-ac,v 1.6 2010/06/15 23:01:23 pettai Exp $
$(man1dir)/rmail.1 $(man1dir)/dotforward.1 \
$(man8dir)/makesmtpaccess-msa.8 \
$(man8dir)/esmtpd-msa.8
@@ -1215,8 +1186,7 @@ preline.1: preline.1.in
@@ -1216,8 +1187,7 @@ preline.1: preline.1.in

install-man-extra:
cd $(DESTDIR)$(man8dir) ; \
Expand Down
6 changes: 3 additions & 3 deletions mail/courier-mta/patches/patch-ad
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.5 2010/06/15 23:01:23 pettai Exp $
$NetBSD: patch-ad,v 1.6 2012/06/09 11:45:38 adam Exp $

--- courier/filters/Makefile.in.orig 2007-11-17 19:49:01.000000000 -0500
+++ courier/filters/Makefile.in
@@ -283,11 +283,12 @@ SUBDIRS = libfilter perlfilter
@@ -282,11 +282,12 @@ SUBDIRS = libfilter perlfilter
CLEANFILES = $(htmldoc_DATA) $(man_MANS) filtersocketdir.h filteractivedir.h \
pidfile.h permissions.dat

Expand All @@ -16,7 +16,7 @@ $NetBSD: patch-ad,v 1.5 2010/06/15 23:01:23 pettai Exp $
filtersocketdir = $(localstatedir)/filters
allfiltersocketdir = $(localstatedir)/allfilters
filterconfdir = $(sysconfdir)/filters
@@ -1083,16 +1084,12 @@ install-exec-hook:
@@ -1080,16 +1081,12 @@ install-exec-hook:
install-data-hook:
-$(mkinstalldirs) $(DESTDIR)$(filtersocketdir)
-$(mkinstalldirs) $(DESTDIR)$(allfiltersocketdir)
Expand Down
4 changes: 2 additions & 2 deletions mail/courier-mta/patches/patch-ae
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.2 2007/08/10 17:57:04 jlam Exp $
$NetBSD: patch-ae,v 1.3 2012/06/09 11:45:38 adam Exp $

--- courier/filters/filterctl.in.orig 2004-01-31 23:46:27.000000000 -0500
+++ courier/filters/filterctl.in
@@ -11,8 +11,9 @@ libexecdir="@libexecdir@"
@@ -10,8 +10,9 @@ libexecdir="@libexecdir@"
sysconfdir="@sysconfdir@"
localstatedir="@localstatedir@"
piddir="@piddir@"
Expand Down
4 changes: 2 additions & 2 deletions mail/courier-mta/patches/patch-af
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-af,v 1.4 2010/06/15 23:01:23 pettai Exp $
$NetBSD: patch-af,v 1.5 2012/06/09 11:45:38 adam Exp $

--- courier/filters/perlfilter/Makefile.in.orig Sat Jul 21 20:31:15 2007
+++ courier/filters/perlfilter/Makefile.in
@@ -234,7 +234,8 @@ top_srcdir = @top_srcdir@
@@ -233,7 +233,8 @@ top_srcdir = @top_srcdir@
EXTRA_DIST = perlfilter-wrapper.pl perlfilter-example.pl
BUILT_SOURCES = filtersocketdir.h wrapperpl.h xsinit.c
CLEANFILES = $(BUILT_SOURCES) permissions.dat
Expand Down
6 changes: 3 additions & 3 deletions mail/courier-mta/patches/patch-ag
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.3 2008/02/19 18:45:24 jlam Exp $
$NetBSD: patch-ag,v 1.4 2012/06/09 11:45:38 adam Exp $

--- courier/module.esmtp/mkesmtpdcert.in.orig 2007-11-04 16:17:03.000000000 -0500
+++ courier/module.esmtp/mkesmtpdcert.in
@@ -9,7 +9,13 @@
@@ -8,7 +8,13 @@
# ESMTP STARTTLS. Normally this script would get called by an automatic
# package installation routine.

Expand All @@ -17,7 +17,7 @@ $NetBSD: patch-ag,v 1.3 2008/02/19 18:45:24 jlam Exp $
then
test -x @OPENSSL@ || exit 0
else
@@ -32,7 +38,7 @@ cleanup() {
@@ -31,7 +37,7 @@ cleanup() {

cd @mydatadir@

Expand Down
Loading

0 comments on commit 3f27b2d

Please sign in to comment.