Skip to content

Commit

Permalink
Rearrange sequence so that "wrapper" occurs between "tools" and
Browse files Browse the repository at this point in the history
"extract".  This allows all user-definable targets (pre-*, do-*,
post-*) to have access to the wrapper scripts.
  • Loading branch information
johnnylam88 committed Jul 21, 2006
1 parent 3d2f631 commit 4011c5c
Show file tree
Hide file tree
Showing 7 changed files with 24 additions and 17 deletions.
6 changes: 4 additions & 2 deletions mk/bsd.pkg.barrier.mk
Original file line number Diff line number Diff line change
@@ -1,18 +1,20 @@
# $NetBSD: bsd.pkg.barrier.mk,v 1.6 2006/07/07 21:24:27 jlam Exp $
# $NetBSD: bsd.pkg.barrier.mk,v 1.7 2006/07/21 14:21:28 jlam Exp $

_COOKIE.barrier= ${WRKDIR}/.barrier_cookie

# _BARRIER_PRE_TARGETS is a list of the targets that must be built before
# the "barrier" target invokes a new make.
#
_BARRIER_PRE_TARGETS= patch
_BARRIER_PRE_TARGETS= tools

# _BARRIER_POST_TARGETS is a list of the targets that must be built after
# the "barrier" target invokes a new make. This list is specially
# ordered so that if more than one is specified on the command-line,
# then pkgsrc will still do the right thing.
#
_BARRIER_POST_TARGETS= wrapper
_BARRIER_POST_TARGETS+= extract
_BARRIER_POST_TARGETS+= patch
_BARRIER_POST_TARGETS+= configure
_BARRIER_POST_TARGETS+= build
_BARRIER_POST_TARGETS+= test
Expand Down
4 changes: 2 additions & 2 deletions mk/bsd.pkg.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: bsd.pkg.mk,v 1.1873 2006/07/20 17:16:43 rillig Exp $
# $NetBSD: bsd.pkg.mk,v 1.1874 2006/07/21 14:21:28 jlam Exp $
#
# This file is in the public domain.
#
Expand All @@ -12,9 +12,9 @@
# checksum
# depends
# tools
# wrapper
# extract
# patch
# wrapper
# configure
# build
#
Expand Down
4 changes: 2 additions & 2 deletions mk/configure/configure.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: configure.mk,v 1.6 2006/07/15 23:58:52 rillig Exp $
# $NetBSD: configure.mk,v 1.7 2006/07/21 14:21:28 jlam Exp $
#
# CONFIGURE_SCRIPT is the path to the script to run in order to
# configure the software for building. If the path is relative,
Expand Down Expand Up @@ -39,7 +39,7 @@ _BUILD_DEFS+= CONFIGURE_ENV CONFIGURE_ARGS
### configure is a public target to configure the sources for building.
###
_CONFIGURE_TARGETS+= check-vulnerable
_CONFIGURE_TARGETS+= wrapper
_CONFIGURE_TARGETS+= patch
_CONFIGURE_TARGETS+= acquire-configure-lock
_CONFIGURE_TARGETS+= ${_COOKIE.configure}
_CONFIGURE_TARGETS+= release-configure-lock
Expand Down
11 changes: 5 additions & 6 deletions mk/extract/extract.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: extract.mk,v 1.11 2006/07/07 21:24:28 jlam Exp $
# $NetBSD: extract.mk,v 1.12 2006/07/21 14:21:28 jlam Exp $
#
# The following variables may be set by the package Makefile and
# specify how extraction happens:
Expand Down Expand Up @@ -43,10 +43,7 @@ _COOKIE.extract= ${WRKDIR}/.extract_done
### extract is a public target to perform extraction.
###
_EXTRACT_TARGETS+= check-vulnerable
_EXTRACT_TARGETS+= checksum
_EXTRACT_TARGETS+= makedirs
_EXTRACT_TARGETS+= depends
_EXTRACT_TARGETS+= tools
_EXTRACT_TARGETS+= wrapper
_EXTRACT_TARGETS+= acquire-extract-lock
_EXTRACT_TARGETS+= ${_COOKIE.extract}
_EXTRACT_TARGETS+= release-extract-lock
Expand All @@ -56,8 +53,10 @@ _EXTRACT_TARGETS+= release-extract-lock
. if exists(${_COOKIE.extract})
extract:
@${DO_NADA}
. else
. elif exists(${_COOKIE.barrier})
extract: ${_EXTRACT_TARGETS}
. else
extract: barrier
. endif
.endif

Expand Down
6 changes: 4 additions & 2 deletions mk/patch/patch.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: patch.mk,v 1.9 2006/07/13 14:02:34 jlam Exp $
# $NetBSD: patch.mk,v 1.10 2006/07/21 14:21:28 jlam Exp $
#
# The following variables may be set in a package Makefile and control
# how pkgsrc patches are applied.
Expand Down Expand Up @@ -63,8 +63,10 @@ _PATCH_TARGETS+= release-patch-lock
. if exists(${_COOKIE.patch})
patch:
@${DO_NADA}
. else
. elif exists(${_COOKIE.barrier})
patch: ${_PATCH_TARGETS}
. else
patch: barrier
. endif
.endif

Expand Down
6 changes: 5 additions & 1 deletion mk/tools/bsd.tools.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: bsd.tools.mk,v 1.43 2006/07/13 14:02:34 jlam Exp $
# $NetBSD: bsd.tools.mk,v 1.44 2006/07/21 14:21:28 jlam Exp $
#
# Copyright (c) 2005, 2006 The NetBSD Foundation, Inc.
# All rights reserved.
Expand Down Expand Up @@ -62,6 +62,10 @@ _COOKIE.tools= ${WRKDIR}/.tools_done
### tools is a public target to create a private directory of tools
### specified by USE_TOOLS.
###
_TOOLS_TARGETS+= check-vulnerable
_TOOLS_TARGETS+= checksum
_TOOLS_TARGETS+= makedirs
_TOOLS_TARGETS+= depends
_TOOLS_TARGETS+= acquire-tools-lock
_TOOLS_TARGETS+= ${_COOKIE.tools}
_TOOLS_TARGETS+= release-tools-lock
Expand Down
4 changes: 2 additions & 2 deletions mk/wrapper/bsd.wrapper.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: bsd.wrapper.mk,v 1.48 2006/07/07 21:24:29 jlam Exp $
# $NetBSD: bsd.wrapper.mk,v 1.49 2006/07/21 14:21:28 jlam Exp $
#
# Copyright (c) 2005 The NetBSD Foundation, Inc.
# All rights reserved.
Expand Down Expand Up @@ -781,7 +781,7 @@ _COOKIE.wrapper= ${WRKDIR}/.wrapper_done
wrapper:
@${DO_NADA}
. elif exists(${_COOKIE.barrier})
wrapper: check-vulnerable patch acquire-wrapper-lock ${_COOKIE.wrapper} release-wrapper-lock
wrapper: check-vulnerable tools acquire-wrapper-lock ${_COOKIE.wrapper} release-wrapper-lock
. else
wrapper: barrier
. endif
Expand Down

0 comments on commit 4011c5c

Please sign in to comment.