-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Update net/couriertcpd to version 0.58.0. Changes from version 0.57.1
include: + Add a new option "gnutls" to support using GNUTLS instead of OpenSSL. + Add full DESTDIR support. + Fix CONFLICT with courier-imap -- we conflict with courier-imap<4.1.1, not 4.11.
- Loading branch information
1 parent
d795b5f
commit 41d16b9
Showing
3 changed files
with
43 additions
and
24 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,7 @@ | ||
# $NetBSD: Makefile,v 1.13 2008/01/18 05:08:40 tnn Exp $ | ||
# $NetBSD: Makefile,v 1.14 2008/02/19 18:45:41 jlam Exp $ | ||
|
||
DISTNAME= courier-${COURIER_VERSION} | ||
PKGNAME= ${DISTNAME:S/-/tcpd-/} | ||
PKGREVISION= 1 | ||
CATEGORIES= net | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=courier/} | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
@@ -11,22 +10,14 @@ MAINTAINER= [email protected] | |
COMMENT= Courier TCP socket and TLS servers | ||
HOMEPAGE= http://www.courier-mta.org/ | ||
|
||
CONFLICTS= courier-imap<4.11 | ||
CONFLICTS= courier-imap<4.1.1 | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
USE_LANGUAGES= c c++ | ||
|
||
PKG_OPTIONS_VAR= PKG_OPTIONS.couriertcpd | ||
PKG_SUPPORTED_OPTIONS= inet6 | ||
PKG_SUGGESTED_OPTIONS= inet6 | ||
|
||
.include "../../mk/bsd.options.mk" | ||
|
||
.if !empty(PKG_OPTIONS:Minet6) | ||
CONFIGURE_ARGS+= --with-ipv6 | ||
.else | ||
CONFIGURE_ARGS+= --without-ipv6 | ||
.endif | ||
.include "options.mk" | ||
|
||
.include "../../mail/courier-mta/Makefile.common" | ||
|
||
|
@@ -60,17 +51,17 @@ MAKE_DIRS+= ${COURIER_STATEDIR} | |
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/tcpd/couriertcpd \ | ||
${PREFIX}/sbin/couriertcpd | ||
${DESTDIR}${PREFIX}/sbin/couriertcpd | ||
${INSTALL_MAN} ${WRKSRC}/tcpd/couriertcpd.1 \ | ||
${PREFIX}/${PKGMANDIR}/man1/couriertcpd.1 | ||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/couriertcpd.1 | ||
${INSTALL_DATA} ${WRKSRC}/tcpd/couriertcpd.html \ | ||
${DOCDIR}/couriertcpd.html | ||
${DESTDIR}${DOCDIR}/couriertcpd.html | ||
|
||
${INSTALL_PROGRAM} ${WRKSRC}/tcpd/couriertls \ | ||
${PREFIX}/bin/couriertls | ||
${DESTDIR}${PREFIX}/bin/couriertls | ||
${INSTALL_MAN} ${WRKSRC}/tcpd/couriertls.1 \ | ||
${PREFIX}/${PKGMANDIR}/man1/couriertls.1 | ||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/couriertls.1 | ||
${INSTALL_DATA} ${WRKSRC}/tcpd/couriertls.html \ | ||
${DOCDIR}/couriertls.html | ||
${DESTDIR}${DOCDIR}/couriertls.html | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
$NetBSD: distinfo,v 1.7 2007/10/15 15:37:05 jlam Exp $ | ||
$NetBSD: distinfo,v 1.8 2008/02/19 18:45:41 jlam Exp $ | ||
|
||
SHA1 (courier-0.57.1.tar.bz2) = 5e602d4a4d5dd33b17146c7f54467ac6352e9340 | ||
RMD160 (courier-0.57.1.tar.bz2) = 28b9f409e281403280b69f3a4f4be8b9e4f74dc2 | ||
Size (courier-0.57.1.tar.bz2) = 7098660 bytes | ||
SHA1 (courier-0.58.0.tar.bz2) = 964d81e6de5390678c9f10dddbc176273b925f6d | ||
RMD160 (courier-0.58.0.tar.bz2) = 940fb7967d154aeeb462691beb508155b3df4e29 | ||
Size (courier-0.58.0.tar.bz2) = 7123136 bytes |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
# $NetBSD: options.mk,v 1.1 2008/02/19 18:45:41 jlam Exp $ | ||
|
||
PKG_OPTIONS_VAR= PKG_OPTIONS.couriertcpd | ||
PKG_SUPPORTED_OPTIONS= inet6 | ||
PKG_OPTIONS_REQUIRED_GROUPS= tls | ||
PKG_OPTIONS_GROUP.tls= gnutls ssl | ||
PKG_SUGGESTED_OPTIONS= inet6 ssl | ||
|
||
.include "../../mk/bsd.options.mk" | ||
|
||
### | ||
### Build with OpenSSL or GNU TLS as the underlying crypto library. | ||
### | ||
.if !empty(PKG_OPTIONS:Mssl) | ||
. include "../../security/openssl/buildlink3.mk" | ||
.elif !empty(PKG_OPTIONS:Mgnutls) | ||
. include "../../security/gnutls/buildlink3.mk" | ||
CONFIGURE_ARGS+= --with-gnutls | ||
.endif | ||
|
||
### | ||
### IPv6 support. | ||
### | ||
.if !empty(PKG_OPTIONS:Minet6) | ||
CONFIGURE_ARGS+= --with-ipv6 | ||
.else | ||
CONFIGURE_ARGS+= --without-ipv6 | ||
.endif |