Skip to content

Commit

Permalink
biology/sra-tools: Update to 3.1.1
Browse files Browse the repository at this point in the history
Numerous fixes and enhancements since 3.0.6
Changes: https://github.com/ncbi/sra-tools/commits/master/

All previous patches upstreamed
Rewrote DESCR to be more introductory
  • Loading branch information
bacon committed Nov 19, 2024
1 parent 33d8391 commit 424528d
Show file tree
Hide file tree
Showing 10 changed files with 72 additions and 56 deletions.
23 changes: 7 additions & 16 deletions biology/sra-tools/DESCR
Original file line number Diff line number Diff line change
@@ -1,16 +1,7 @@
SRA tools is a toolkit for using data in the INSDC Sequence Read
Archives. SRAs operated by the International Nucleotide Sequence
Database Collaboration house sequence reads and alignments generated
by "next-gen" sequencers. SRA tools allows conversion of .sra
files, which INSDC SRAs maintain, from/to other formats that the
'next-gen' sequencers generate including:

* csfasta/csqual (ABI SOLiD)
* fastq (and fasta for writing)
* hdf5 (PacBio, reading only)
* qseq (older Illumina)
* sam (writing only) / bam (reading only)
* sff

The toolkit uses the NCBI-VDB back-end enabling seamless access to
remote SRA data and local SRA files.
The SRA Toolkit and SDK from NCBI is a collection of tools and
libraries for using data in the INSDC (International Nucleotide
Sequence Database Collaboration) SRA (Sequence Read Archives). The
SRA house sequence reads and alignments generated by DNA/RNA
sequencers. The SRA Toolkit facilitates downloading sequence data,
performing filtering and conversions on-the-fly, thus saving enormous
amounts of time, bandwidth, and storage.
40 changes: 12 additions & 28 deletions biology/sra-tools/Makefile
Original file line number Diff line number Diff line change
@@ -1,11 +1,9 @@
# $NetBSD: Makefile,v 1.8 2024/11/14 22:18:47 wiz Exp $
# $NetBSD: Makefile,v 1.9 2024/11/19 20:22:31 bacon Exp $

DISTNAME= sra-tools-3.0.6
PKGREVISION= 6
DISTNAME= sra-tools-3.1.1
CATEGORIES= biology
MASTER_SITES= ${MASTER_SITE_GITHUB:=outpaddling/}
GITHUB_TAG= 984f1493e8612cd59a269569bf8c06e25e4e604c
GITHUB_SUBMODULES+= outpaddling ncbi-vdb 38972fc ncbi-vdb
MASTER_SITES= ${MASTER_SITE_GITHUB:=ncbi/}
GITHUB_SUBMODULES+= ncbi ncbi-vdb 3.1.1 ncbi-vdb

OWNER= [email protected]
HOMEPAGE= https://github.com/ncbi/sra-tools
Expand All @@ -18,17 +16,16 @@ ONLY_FOR_PLATFORM= *-*-aarch64 *-*-x86_64
USE_LANGUAGES= c c++
USE_TOOLS+= bash bison cmake

# The config.c and file-path.posix.cpp substs follow
# static patches. Run "make clean patch" before updating
# those patches so this subst does not get added to them.
# SUBST edits may follow static patches. Run "make clean patch" before
# updating those patches so SUBST changes do not get added to them.
SUBST_CLASSES+= etcdir
SUBST_STAGE.etcdir= pre-configure
SUBST_SED.etcdir+= -e 's|"/etc/ncbi"|"${PREFIX}/etc/ncbi"|g'
SUBST_FILES.etcdir+= ncbi-vdb/libs/kfg/config.c

SUBST_CLASSES+= binpath
SUBST_STAGE.binpath= pre-configure
SUBST_SED.binpath+= -e 's|/usr/local/bin|${PREFIX}/bin|g'
SUBST_SED.binpath+= -e 's|/usr/local|${PREFIX}|g'
SUBST_FILES.binpath+= tools/external/driver-tool/file-path.posix.cpp

SUBST_CLASSES+= submoddir
Expand All @@ -38,15 +35,13 @@ SUBST_FILES.submoddir+= CMakeLists.txt

REPLACE_BASH= */*.sh */*/*.sh */*/*/*.sh */*/*/*/*.sh

USE_CMAKE= yes
CMAKE_CONFIGURE_ARGS+= -DVDB_LIBDIR:STRING=${WRKSRC}/ncbi-vdb/build/lib
CMAKE_CONFIGURE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
CMAKE_CONFIGURE_ARGS+= -DVDB_LIBDIR:STRING=${WRKSRC}/ncbi-vdb/build/lib
CMAKE_CONFIGURE_ARGS+= -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON
BUILDLINK_TRANSFORM.NetBSD+= rm:-ldl # ncbi-vdb/CMakeLists.posix.txt

EXAMPLESDIR= ${PREFIX}/share/examples/sra-tools

.include "../../mk/bsd.prefs.mk"

# macOS does not support @rpath
.if ${OPSYS} == Darwin
SUBST_CLASSES+= srarpath
SUBST_STAGE.srarpath= post-configure
Expand All @@ -58,26 +53,15 @@ pre-configure:
.if ${OPSYS} == NetBSD
# Incorrect gcc/x86_64/byteswap.h found before correct bsd/byteswap.h
# Adding #ifndef __NetBSD__ to gcc/x86_64/byteswap.h doesn't work
# Still needed as of sra-tools 3.1.1
${RM} -f ${WRKSRC}/ncbi-vdb/interfaces/cc/gcc/x86_64/byteswap.h
.endif
cd ${WRKSRC}/ncbi-vdb/build && cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON ..
.if ${OPSYS} == Darwin
# Unsure how to prevent cmake from emitting @rpath in the first place
# No instances of @rpath or -install_name in any files before cmake
for f in ${WRKSRC}/ncbi-vdb/build/libs/ncbi-vdb/CMakeFiles/*/link.txt; do \
${SED} -e 's|@rpath|${PREFIX}/lib|g' $${f} > $${f}.tmp && ${MV} -f $${f}.tmp $${f}; \
done
.endif
cd ${WRKSRC}/ncbi-vdb/build && ${MAKE}

post-install:
${STRIP} ${DESTDIR}${PREFIX}/bin/*.${PKGVERSION_NOREV}
${MV} ${DESTDIR}${PREFIX}/share/examples ${DESTDIR}${PREFIX}/share/examples-sratools
${MKDIR} ${DESTDIR}${EXAMPLESDIR}
${MV} ${DESTDIR}${PREFIX}/share/examples-sratools/* ${DESTDIR}${EXAMPLESDIR}
${RMDIR} ${DESTDIR}${PREFIX}/share/examples-sratools
${MV} ${DESTDIR}${PREFIX}/share/examples-python ${DESTDIR}${EXAMPLESDIR}/python
# FIXME: Can we prevent build from detecting java?
${STRIP} ${DESTDIR}${PREFIX}/lib/*.${PKGVERSION_NOREV}
${RM} -rf ${DESTDIR}${PREFIX}/jar
${RM} -rf ${DESTDIR}${PREFIX}/share/examples-java
${RM} -rf ${DESTDIR}${PREFIX}/share/javadoc
Expand Down
2 changes: 1 addition & 1 deletion biology/sra-tools/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2023/08/29 00:00:24 bacon Exp $
@comment $NetBSD: PLIST,v 1.2 2024/11/19 20:22:32 bacon Exp $
bin/abi-dump
bin/abi-dump.3
bin/abi-dump.${PKGVERSION}
Expand Down
16 changes: 9 additions & 7 deletions biology/sra-tools/distinfo
Original file line number Diff line number Diff line change
@@ -1,12 +1,14 @@
$NetBSD: distinfo,v 1.1 2023/08/29 00:00:24 bacon Exp $
$NetBSD: distinfo,v 1.2 2024/11/19 20:22:32 bacon Exp $

BLAKE2s (outpaddling-ncbi-vdb-38972fc.tar.gz) = 600ac8ff4f2fbea9d2f06edc0277087e1559636226756eae415826dfbdb1fb5a
SHA512 (outpaddling-ncbi-vdb-38972fc.tar.gz) = 0cda01bf2faf59aa16c4a402bcc132d4a2fc948240f6e13b2f1d3d93c4f900a837ebf8c24ee8089e88ed4de90a8ab441a4176f8193052fd7b538e27384bcb118
Size (outpaddling-ncbi-vdb-38972fc.tar.gz) = 18978410 bytes
BLAKE2s (sra-tools-3.0.6-984f1493e8612cd59a269569bf8c06e25e4e604c.tar.gz) = 2a13546011d4ea0a000a7e1e5fdfdf1d915b6adbac8fd818967ebf4c1670dba5
SHA512 (sra-tools-3.0.6-984f1493e8612cd59a269569bf8c06e25e4e604c.tar.gz) = 9b1e671c92ba1006392160258c5b6fba85ba7dba59a23e9ed8b534ca31b46ed9e6cf2c92ea69dc2897f5a4aa9da31f5c8981cebb442236d11bcef76b854dbec9
Size (sra-tools-3.0.6-984f1493e8612cd59a269569bf8c06e25e4e604c.tar.gz) = 44961381 bytes
BLAKE2s (ncbi-ncbi-vdb-3.1.1.tar.gz) = 60e10ac43b3bfbeac580fa1680ba86291b7f2656c950e6f13d0f2021a6894029
SHA512 (ncbi-ncbi-vdb-3.1.1.tar.gz) = ccfeb38abf8eb80d54394b4a32d851e78408d9019d1ca4b53c71681e2e9ffec904d222b2d0d32fc98fe527f66c84764ae73a8d63dada7f3b5a33c51dc3f84462
Size (ncbi-ncbi-vdb-3.1.1.tar.gz) = 19055901 bytes
BLAKE2s (sra-tools-3.1.1.tar.gz) = de0665b9ec114fad64b052eda29e521612ea6dddaf5555a6ed32078222834553
SHA512 (sra-tools-3.1.1.tar.gz) = df8ae5fca3761712306db6a98074d1b1e1a02a78c09c861852a16a9bc576fc39dd6e5afe0f1572e4901786fd3a757675fe0af7e79bb85d9eac021e69e88c48f1
Size (sra-tools-3.1.1.tar.gz) = 45754110 bytes
SHA1 (patch-build_env.cmake) = 14add56e66e5578fd0d51ce55329285e0981ac4e
SHA1 (patch-ncbi-vdb_libs_kproc_bsd_sysmgr.c) = f49eb28f8bfeb528c1d7c2e9d184502b9eba273c
SHA1 (patch-ngs_ngs-java_CMakeLists.txt) = 44b822381fd564d045406cc926f807adae9fbe59
SHA1 (patch-ngs_ngs-python_examples_CMakeLists.txt) = a8a01d17a27c060c08311ab8571ae10af265781d
SHA1 (patch-ngs_ngs-sdk_examples_CMakeLists.txt) = 6a4b09afe4b919eeb9bd144635695437e5a3b57f
SHA1 (patch-tools_external_driver-tool_sratools.cpp) = c490d83f03471e6e8e34b8e88534469ed45b2886
2 changes: 1 addition & 1 deletion biology/sra-tools/patches/patch-build_env.cmake
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-build_env.cmake,v 1.1 2023/08/29 00:00:25 bacon Exp $
$NetBSD: patch-build_env.cmake,v 1.2 2024/11/19 20:22:32 bacon Exp $

# static standard libs are not standard nor easy to install on Alma Linux

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ncbi-vdb_libs_kproc_bsd_sysmgr.c,v 1.1 2023/08/29 00:00:25 bacon Exp $
$NetBSD: patch-ncbi-vdb_libs_kproc_bsd_sysmgr.c,v 1.2 2024/11/19 20:22:32 bacon Exp $

# Add NetBSD pthread_main_np() stand-in

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-ngs_ngs-java_CMakeLists.txt,v 1.1 2023/08/29 00:00:25 bacon Exp $
$NetBSD: patch-ngs_ngs-java_CMakeLists.txt,v 1.2 2024/11/19 20:22:32 bacon Exp $

# Disable java

Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-ngs_ngs-python_examples_CMakeLists.txt,v 1.1 2024/11/19 20:22:32 bacon Exp $

# Canonicalize python examples dir

--- ngs/ngs-python/examples/CMakeLists.txt.orig 2024-11-18 12:08:54.646596198 +0000
+++ ngs/ngs-python/examples/CMakeLists.txt
@@ -54,7 +54,7 @@ if( Python3_EXECUTABLE )
RunAndDiff( RefTest "SRR1121656" )
endif()

- set( INSTALL_DEST ${CMAKE_INSTALL_PREFIX}/share/examples-python )
+ set( INSTALL_DEST ${CMAKE_INSTALL_PREFIX}/share/examples/sra-tools/python )

install(FILES ${SOURCES} expected.txt
DESTINATION ${INSTALL_DEST} )
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
$NetBSD: patch-ngs_ngs-sdk_examples_CMakeLists.txt,v 1.1 2024/11/19 20:22:32 bacon Exp $

# Canonicalize examples dir

--- ngs/ngs-sdk/examples/CMakeLists.txt.orig 2024-11-18 12:10:46.495627136 +0000
+++ ngs/ngs-sdk/examples/CMakeLists.txt
@@ -62,14 +62,14 @@ if ( SINGLE_CONFIG )
install(
FILES FragTest.cpp AlignTest.cpp AlignSliceTest.cpp PileupTest.cpp RefTest.cpp DumpReferenceFASTA.cpp
expected.txt
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/sra-tools
)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/Makefile.install
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/sra-tools
RENAME Makefile
)
install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/README.install
- DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/examples/sra-tools
RENAME README.txt
)
endif()
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: patch-tools_external_driver-tool_sratools.cpp,v 1.1 2023/08/29 00:00:25 bacon Exp $
$NetBSD: patch-tools_external_driver-tool_sratools.cpp,v 1.2 2024/11/19 20:22:32 bacon Exp $

# Add NetBSD pthread_main_np() stand-in

Expand Down

0 comments on commit 424528d

Please sign in to comment.