-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
mycroft
committed
Aug 29, 1998
1 parent
a73fbf0
commit 43ef5bd
Showing
6 changed files
with
101 additions
and
130 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,9 @@ | ||
# $NetBSD: Makefile,v 1.13 1998/08/23 19:29:51 tron Exp $ | ||
# $NetBSD: Makefile,v 1.14 1998/08/29 04:08:12 mycroft Exp $ | ||
# | ||
|
||
DISTNAME= xmame-0.33b6.1 | ||
DISTNAME= xmame-0.34b1.1 | ||
CATEGORIES= emulators games x11 | ||
MASTER_SITES= ftp://drake.dit.upm.es/pub/emulators/mame/ | ||
MASTER_SITES= ftp://drake.dit.upm.es/xmame/ftpsite/ | ||
EXTRACT_SUFX= .tgz | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -12,30 +12,33 @@ HOMEPAGE= http://drake.dit.upm.es/~mame/ | |
RUN_DEPENDS= unzip:../../archivers/unzip | ||
DEPENDS+= xpm-3.4k:../../graphics/xpm | ||
|
||
CONFLICTS= xmame-0.30.1 | ||
CONFLICTS= xmame-0.30.1 xmame-0.33b6.1 | ||
|
||
USE_X11= yes | ||
USE_GMAKE= yes | ||
MAKE_ENV+= OPSYS=${OPSYS} ARCH=${ARCH} DESTDIR=${DESTDIR} \ | ||
INSTALL_MAN="${INSTALL_MAN}" \ | ||
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \ | ||
NETBSD_JOYSTICK="${NETBSD_JOYSTICK}" | ||
MAKEFILE= makefile.unix | ||
ALL_TARGET= xmame.xwindows | ||
|
||
MAMEDIR= ${PREFIX}/share/mame | ||
MAMEDIR= ${PREFIX}/share/xmame | ||
.if exists(/usr/include/machine/joystick.h) | ||
NETBSD_JOYSTICK= yes | ||
.else | ||
NETBSD_JOYSTICK= no | ||
.endif | ||
|
||
post-patch: | ||
${CP} ${WRKSRC}/makefile.unix ${WRKSRC}/Makefile | ||
${SED} 's|@MAMEDIR@|${MAMEDIR}|' ${WRKSRC}/doc/xmamerc.dist >${WRKSRC}/doc/xmamerc | ||
${MV} ${WRKSRC}/src/unix/netbsd_i386.c ${WRKSRC}/src/unix/netbsd.c | ||
(cd ${WRKSRC}/doc && ${SED} 's|@MAMEDIR@|${MAMEDIR}|' xmamerc.dist >xmamerc) | ||
(cd ${WRKSRC}/src/unix && ${MV} netbsd_i386.c netbsd.c) | ||
|
||
post-install: | ||
do-install: | ||
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${ALL_TARGET} ${PREFIX}/bin/xmame) | ||
(cd ${WRKSRC}/doc && ${INSTALL_MAN} xmame.man ${PREFIX}/man/man6/xmame.6) | ||
${MKDIR} ${MAMEDIR} | ||
${CP} ${WRKSRC}/doc/xmamerc ${MAMEDIR}/xmamerc | ||
(cd ${WRKSRC}/doc && ${INSTALL_DATA} xmamerc ${MAMEDIR}/xmamerc) | ||
@${ECHO} Remember to set MAMEDIR to ${MAMEDIR}. | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
$NetBSD: md5,v 1.3 1998/08/07 13:21:29 agc Exp $ | ||
$NetBSD: md5,v 1.4 1998/08/29 04:08:13 mycroft Exp $ | ||
|
||
MD5 (xmame-0.33b6.1.tgz) = 6d0a801031f33ae5610005ed82e7e35f | ||
MD5 (xmame-0.34b1.1.tgz) = 83fb9b6a57743d59a1ca1fe54950d4c0 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,21 +1,10 @@ | ||
$NetBSD: patch-ab,v 1.3 1998/08/07 10:40:37 agc Exp $ | ||
|
||
--- src/unix/Makefile.orig Fri Jun 5 07:32:04 1998 | ||
+++ src/unix/Makefile Sat Jul 4 07:37:41 1998 | ||
@@ -25,6 +25,7 @@ | ||
--- src/unix/Makefile.orig Sun Aug 23 17:31:13 1998 | ||
+++ src/unix/Makefile Fri Aug 28 23:37:29 1998 | ||
@@ -16,6 +16,7 @@ | ||
|
||
$(TRG): $(ALLOBJS) | ||
ar -rcv $@ $(UOBJS) | ||
$(TARGET): $(OBJS) | ||
ar -rcv $@ $(OBJS) | ||
+ ranlib $@ | ||
|
||
$(OBJDIR)/%.o: %.c xmame.h | ||
$(CC) $(DEFS) -I../../src/ $(MS) $(JS) $(CFLAGS) -o $@ -c $< | ||
@@ -42,7 +43,7 @@ | ||
$(OBJDIR)/irix.o: irix.c xmame.h sound.h | ||
$(OBJDIR)/hpux.o: hpux.c xmame.h sound.h | ||
$(OBJDIR)/aix.o: aix.c xmame.h sound.h | ||
-$(OBJDIR)/netbsd_i386.o: netbsd_i386.c xmame.h sound.h | ||
+$(OBJDIR)/netbsd.o: netbsd.c xmame.h sound.h | ||
$(OBJDIR)/sndserver.o: sndserver.c xmame.h | ||
$(OBJDIR)/svgalib.o: svgalib.c linux.c xmame.h sound.h | ||
$(OBJDIR)/ultrix.c: ultrix.c xmame.h sound.h | ||
$(OBJDIR)/%.o: %.c xmame.h sound.h | ||
$(CC) -I../../src/ $(CFLAGS) -o $@ -c $< |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
@comment $NetBSD: PLIST,v 1.2 1998/07/04 12:05:07 mycroft Exp $ | ||
@comment $NetBSD: PLIST,v 1.3 1998/08/29 04:08:13 mycroft Exp $ | ||
bin/xmame | ||
man/man6/xmame.6 | ||
share/mame/xmamerc | ||
@dirrm share/mame | ||
share/xmame/xmamerc | ||
@dirrm share/xmame |