-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Import of golem-0.0.5: Fast and lightweight yet customizable window m…
…anager. Golem is an X11 Window Manager. Design goals are that it be fast and lightweight, as well as very customizable in any way that will not prevent the first goal from being realized. Notable features: - Small memory footprint - Multiple disjoint large virtual desktops - Xinerama support for multimonitor screens - Supports various focusing styles (sloppy, pointer, click) - Useful stuff for multiscreen displays (special focus cycling modes, etc) - Window decoration customization (theming) with multiple decoration styles (dgroups) - Hotkeys - Plugins Package submited by Erik Reid via pkgsrc-wip with modifications by me.
- Loading branch information
salo
committed
May 15, 2003
1 parent
8e9a97d
commit 49220ac
Showing
8 changed files
with
452 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
Golem is an X11 Window Manager. Design goals are that it be fast | ||
and lightweight, as well as very customizable in any way that will | ||
not prevent the first goal from being realized. | ||
|
||
Notable features: | ||
- Small memory footprint | ||
- Multiple disjoint large virtual desktops | ||
- Xinerama support for multimonitor screens | ||
- Supports various focusing styles (sloppy, | ||
pointer, click) | ||
- Useful stuff for multiscreen displays | ||
(special focus cycling modes, etc) | ||
- Window decoration customization (theming) | ||
with multiple decoration styles (dgroups) | ||
- Hotkeys | ||
- Plugins |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 2003/05/15 11:19:39 salo Exp $ | ||
# | ||
|
||
DISTNAME= golem-0.0.5 | ||
CATEGORIES= wm | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=golem/} | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://golem.sourceforge.net/ | ||
COMMENT= Fast and lightweight yet customizable window manager | ||
|
||
USE_BUILDLINK2= YES | ||
USE_PKGINSTALL= YES | ||
USE_GMAKE= YES | ||
USE_X11= YES | ||
GNU_CONFIGURE= YES | ||
|
||
CONFIGURE_ARGS= --enable-i18n | ||
|
||
.if exists(${X11BASE}/include/X11/extensions/Xinerama.h) | ||
CONFIGURE_ARGS+= --enable-xinerama | ||
.endif | ||
|
||
GOLEM_WITH_SOUND?= NO | ||
|
||
.if !empty(GOLEM_WITH_SOUND:M[Yy][Ee][Ss]) | ||
BUILD_DEFS= GOLEM_WITH_SOUND | ||
CONFIGURE_ARGS+= --enable-sound | ||
PLIST_SUBST= NOT_SOUND= | ||
.include "../../audio/esound/buildlink2.mk" | ||
.else | ||
PLIST_SUBST= NOT_SOUND="@comment " | ||
.endif | ||
|
||
CFLAGS= -DPKG_SYSCONFDIR=\"\\\"${PKG_SYSCONFDIR}\\\"\" | ||
|
||
EGDIR= ${PREFIX}/share/examples/golem | ||
CONF_FILES= ${EGDIR}/golemrc.default ${PKG_SYSCONFDIR}/golemrc | ||
|
||
post-patch: | ||
@${SED} ${FILES_SUBST_SED} ${WRKSRC}/sample.golem/golemrc > \ | ||
${WRKSRC}/golemrc | ||
${RM} -f ${WRKSRC}/sample.golem/golemrc* | ||
|
||
post-install: | ||
${INSTALL_DATA_DIR} ${EGDIR} | ||
${INSTALL_DATA} ${WRKSRC}/golemrc ${EGDIR}/golemrc.default | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,273 @@ | ||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/05/15 11:19:43 salo Exp $ | ||
bin/golem | ||
bin/golem.install | ||
lib/golem/plugins/animations.so | ||
lib/golem/plugins/box_iconify.so | ||
lib/golem/plugins/gnome.so | ||
lib/golem/plugins/mwm_hints.so | ||
lib/golem/plugins/pager.so | ||
lib/golem/plugins/pier.so | ||
lib/golem/plugins/setroot.so | ||
lib/golem/plugins/simple_menus.so | ||
${NOT_SOUND}lib/golem/plugins/sound.so | ||
lib/golem/plugins/start_slide.so | ||
lib/golem/plugins/wmclass_defs.so | ||
man/man1/golem.1 | ||
share/examples/golem/golemrc.default | ||
share/golem/plugins/animations/rc | ||
share/golem/plugins/box_iconify/rc | ||
share/golem/plugins/box_iconify/tile.xpm | ||
share/golem/plugins/gnome/rc | ||
share/golem/plugins/mwm_hints/rc | ||
share/golem/plugins/pager/rc | ||
share/golem/plugins/pier/daemon.xpm | ||
share/golem/plugins/pier/netscape.xpm | ||
share/golem/plugins/pier/rc | ||
share/golem/plugins/setroot/rc | ||
share/golem/plugins/simple_menus/rc | ||
${NOT_SOUND}share/golem/plugins/sound/rc | ||
share/golem/plugins/start_slide/README | ||
share/golem/plugins/start_slide/rc | ||
share/golem/plugins/wmclass_defs/rc | ||
share/golem/themes/AbsoluteE/bar_focused_far.xpm | ||
share/golem/themes/AbsoluteE/bar_focused_mid.xpm | ||
share/golem/themes/AbsoluteE/bar_focused_near.xpm | ||
share/golem/themes/AbsoluteE/bar_normal_far.xpm | ||
share/golem/themes/AbsoluteE/bar_normal_mid.xpm | ||
share/golem/themes/AbsoluteE/bar_normal_near.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_far.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_far_foc.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_mid.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_mid_foc.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_near.xpm | ||
share/golem/themes/AbsoluteE/border_horiz_near_foc.xpm | ||
share/golem/themes/AbsoluteE/border_vert_far.xpm | ||
share/golem/themes/AbsoluteE/border_vert_far_foc.xpm | ||
share/golem/themes/AbsoluteE/border_vert_mid.xpm | ||
share/golem/themes/AbsoluteE/border_vert_mid_foc.xpm | ||
share/golem/themes/AbsoluteE/border_vert_near.xpm | ||
share/golem/themes/AbsoluteE/border_vert_near_foc.xpm | ||
share/golem/themes/AbsoluteE/forplug/setroot/bg.jpg | ||
share/golem/themes/AbsoluteE/forplug/setroot/bg_2.jpg | ||
share/golem/themes/AbsoluteE/forplug/setroot/bg_v.jpg | ||
share/golem/themes/AbsoluteE/forplug/setroot/rc | ||
share/golem/themes/AbsoluteE/rc | ||
share/golem/themes/MudGolem/README | ||
share/golem/themes/MudGolem/forplug/pager/focpagedwin.xpm | ||
share/golem/themes/MudGolem/forplug/pager/nonsel.xpm | ||
share/golem/themes/MudGolem/forplug/pager/pagedwin.xpm | ||
share/golem/themes/MudGolem/forplug/pager/rc | ||
share/golem/themes/MudGolem/forplug/pager/sel.xpm | ||
share/golem/themes/MudGolem/forplug/pier/rc | ||
share/golem/themes/MudGolem/forplug/pier/tile.xpm | ||
share/golem/themes/MudGolem/forplug/setroot/Enigmas-Oven-2.jpg | ||
share/golem/themes/MudGolem/forplug/setroot/rc | ||
share/golem/themes/MudGolem/forplug/simple_menus/rc | ||
share/golem/themes/MudGolem/forplug/simple_menus/submenu.xpm | ||
share/golem/themes/MudGolem/forplug/start_slide/bg.xpm | ||
share/golem/themes/MudGolem/forplug/start_slide/logo.xpm | ||
share/golem/themes/MudGolem/forplug/start_slide/rc | ||
share/golem/themes/MudGolem/forplug/start_slide/trim.xpm | ||
share/golem/themes/MudGolem/forplug/wmclass_defs/rc | ||
share/golem/themes/MudGolem/images/foc/bar_bottom.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_bottom_far.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_bottom_near.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_left.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_right.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_top.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_top_far.xpm | ||
share/golem/themes/MudGolem/images/foc/bar_top_near.xpm | ||
share/golem/themes/MudGolem/images/foc/button.xpm | ||
share/golem/themes/MudGolem/images/foc/left_button.xpm | ||
share/golem/themes/MudGolem/images/foc/title_left.xpm | ||
share/golem/themes/MudGolem/images/foc/title_left_far.xpm | ||
share/golem/themes/MudGolem/images/foc/title_left_near.xpm | ||
share/golem/themes/MudGolem/images/foc/title_top.xpm | ||
share/golem/themes/MudGolem/images/foc/title_top_far.xpm | ||
share/golem/themes/MudGolem/images/foc/title_top_near.xpm | ||
share/golem/themes/MudGolem/images/pressed/button.xpm | ||
share/golem/themes/MudGolem/images/pressed/left_button.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_bottom.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_bottom_far.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_bottom_near.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_left.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_right.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_top.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_top_far.xpm | ||
share/golem/themes/MudGolem/images/unf/bar_top_near.xpm | ||
share/golem/themes/MudGolem/images/unf/button.xpm | ||
share/golem/themes/MudGolem/images/unf/left_button.xpm | ||
share/golem/themes/MudGolem/images/unf/title_left.xpm | ||
share/golem/themes/MudGolem/images/unf/title_left_far.xpm | ||
share/golem/themes/MudGolem/images/unf/title_left_near.xpm | ||
share/golem/themes/MudGolem/images/unf/title_top.xpm | ||
share/golem/themes/MudGolem/images/unf/title_top_far.xpm | ||
share/golem/themes/MudGolem/images/unf/title_top_near.xpm | ||
share/golem/themes/MudGolem/rc | ||
share/golem/themes/MudGolem/styles/common.rc | ||
share/golem/themes/MudGolem/styles/default.rc | ||
share/golem/themes/MudGolem/styles/leftside.rc | ||
share/golem/themes/MudGolem/styles/small.rc | ||
share/golem/themes/eBlueSteel/forplug/pier/rc | ||
share/golem/themes/eBlueSteel/forplug/pier/tile.xpm | ||
share/golem/themes/eBlueSteel/forplug/setroot/All-Good-People-4.jpg | ||
share/golem/themes/eBlueSteel/forplug/setroot/Enigmas-Oven-2.jpg | ||
share/golem/themes/eBlueSteel/forplug/setroot/rc | ||
share/golem/themes/eBlueSteel/forplug/simple_menus/rc | ||
share/golem/themes/eBlueSteel/forplug/simple_menus/submenu.xpm | ||
share/golem/themes/eBlueSteel/forplug/start_slide/black.xpm | ||
share/golem/themes/eBlueSteel/forplug/start_slide/logo.xpm | ||
share/golem/themes/eBlueSteel/forplug/start_slide/rc | ||
share/golem/themes/eBlueSteel/forplug/start_slide/trim.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_bottom.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_bottom_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_bottom_near.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_left.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_left_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_right.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_right_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_top.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_top_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/border_top_near.xpm | ||
share/golem/themes/eBlueSteel/images/foc/delete.xpm | ||
share/golem/themes/eBlueSteel/images/foc/iconify.xpm | ||
share/golem/themes/eBlueSteel/images/foc/title.xpm | ||
share/golem/themes/eBlueSteel/images/foc/title_slant.xpm | ||
share/golem/themes/eBlueSteel/images/foc/top_far_empty.xpm | ||
share/golem/themes/eBlueSteel/images/foc/top_steel.xpm | ||
share/golem/themes/eBlueSteel/images/foc/trim_bottom_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/trim_left_near.xpm | ||
share/golem/themes/eBlueSteel/images/foc/trim_right_far.xpm | ||
share/golem/themes/eBlueSteel/images/foc/trim_top_mid.xpm | ||
share/golem/themes/eBlueSteel/images/foc/zoom.xpm | ||
share/golem/themes/eBlueSteel/images/pressed/delete.xpm | ||
share/golem/themes/eBlueSteel/images/pressed/iconify.xpm | ||
share/golem/themes/eBlueSteel/images/pressed/zoom.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_bottom.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_bottom_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_bottom_near.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_left.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_left_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_right.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_right_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_top.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_top_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/border_top_near.xpm | ||
share/golem/themes/eBlueSteel/images/unf/delete.xpm | ||
share/golem/themes/eBlueSteel/images/unf/iconify.xpm | ||
share/golem/themes/eBlueSteel/images/unf/title.xpm | ||
share/golem/themes/eBlueSteel/images/unf/title_slant.xpm | ||
share/golem/themes/eBlueSteel/images/unf/top_far_empty.xpm | ||
share/golem/themes/eBlueSteel/images/unf/top_steel.xpm | ||
share/golem/themes/eBlueSteel/images/unf/trim_bottom_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/trim_left_near.xpm | ||
share/golem/themes/eBlueSteel/images/unf/trim_right_far.xpm | ||
share/golem/themes/eBlueSteel/images/unf/trim_top_mid.xpm | ||
share/golem/themes/eBlueSteel/images/unf/zoom.xpm | ||
share/golem/themes/eBlueSteel/rc | ||
share/golem/themes/eBlueSteel/styles/common.rc | ||
share/golem/themes/eBlueSteel/styles/default.rc | ||
share/golem/themes/eBlueSteel/styles/small.rc | ||
share/golem/themes/eBlueSteel/styles/transient.rc | ||
share/golem/themes/eBlueSteel/styles/verysmall.rc | ||
share/golem/themes/eBlueSteel/vixar.ttf | ||
share/golem/themes/microGUI/bar_left_top.xpm | ||
share/golem/themes/microGUI/bar_left_top_unfoc.xpm | ||
share/golem/themes/microGUI/bar_vert.xpm | ||
share/golem/themes/microGUI/bottom.xpm | ||
share/golem/themes/microGUI/bottom_far.xpm | ||
share/golem/themes/microGUI/bottom_near.xpm | ||
share/golem/themes/microGUI/close.xpm | ||
share/golem/themes/microGUI/close_clicked.xpm | ||
share/golem/themes/microGUI/close_unfoc.xpm | ||
share/golem/themes/microGUI/forplug/pager/focpagedwin.xpm | ||
share/golem/themes/microGUI/forplug/pager/pagedwin.xpm | ||
share/golem/themes/microGUI/forplug/pager/rc | ||
share/golem/themes/microGUI/forplug/pier/rc | ||
share/golem/themes/microGUI/forplug/pier/tile.xpm | ||
share/golem/themes/microGUI/forplug/start_slide/greybg.xpm | ||
share/golem/themes/microGUI/forplug/start_slide/logo.xpm | ||
share/golem/themes/microGUI/forplug/start_slide/rc | ||
share/golem/themes/microGUI/forplug/start_slide/trim.xpm | ||
share/golem/themes/microGUI/maximize.xpm | ||
share/golem/themes/microGUI/maximize_clicked.xpm | ||
share/golem/themes/microGUI/maximize_unfoc.xpm | ||
share/golem/themes/microGUI/minimize.xpm | ||
share/golem/themes/microGUI/minimize_clicked.xpm | ||
share/golem/themes/microGUI/minimize_unfoc.xpm | ||
share/golem/themes/microGUI/rc | ||
share/golem/themes/microGUI/top_blue.xpm | ||
share/golem/themes/microGUI/top_blue_unfoc.xpm | ||
share/golem/themes/microGUI/top_bluetowhite.xpm | ||
share/golem/themes/microGUI/top_bluetowhite_unfoc.xpm | ||
share/golem/themes/microGUI/top_far.xpm | ||
share/golem/themes/microGUI/top_near.xpm | ||
share/golem/themes/microGUI/top_near_unfoc.xpm | ||
share/golem/themes/microGUI/top_white.xpm | ||
share/golem/themes/microGUI/transient_top.xpm | ||
share/golem/themes/microGUI/transient_top_far.xpm | ||
share/golem/themes/microGUI/transient_top_near.xpm | ||
share/golem/themes/twm/barchecker.xpm | ||
share/golem/themes/twm/bborder.xpm | ||
share/golem/themes/twm/bborder_unf.xpm | ||
share/golem/themes/twm/forplug/simple_menus/rc | ||
share/golem/themes/twm/iconify.xpm | ||
share/golem/themes/twm/lborder.xpm | ||
share/golem/themes/twm/lborder_unf.xpm | ||
share/golem/themes/twm/rborder.xpm | ||
share/golem/themes/twm/rborder_unf.xpm | ||
share/golem/themes/twm/rc | ||
share/golem/themes/twm/resize.xpm | ||
share/golem/themes/twm/topbar.xpm | ||
@dirrm share/golem/themes/twm/forplug/simple_menus | ||
@dirrm share/golem/themes/twm/forplug | ||
@dirrm share/golem/themes/twm | ||
@dirrm share/golem/themes/microGUI/forplug/start_slide | ||
@dirrm share/golem/themes/microGUI/forplug/pier | ||
@dirrm share/golem/themes/microGUI/forplug/pager | ||
@dirrm share/golem/themes/microGUI/forplug | ||
@dirrm share/golem/themes/microGUI | ||
@dirrm share/golem/themes/eBlueSteel/styles | ||
@dirrm share/golem/themes/eBlueSteel/images/unf | ||
@dirrm share/golem/themes/eBlueSteel/images/pressed | ||
@dirrm share/golem/themes/eBlueSteel/images/foc | ||
@dirrm share/golem/themes/eBlueSteel/images | ||
@dirrm share/golem/themes/eBlueSteel/forplug/start_slide | ||
@dirrm share/golem/themes/eBlueSteel/forplug/simple_menus | ||
@dirrm share/golem/themes/eBlueSteel/forplug/setroot | ||
@dirrm share/golem/themes/eBlueSteel/forplug/pier | ||
@dirrm share/golem/themes/eBlueSteel/forplug | ||
@dirrm share/golem/themes/eBlueSteel | ||
@dirrm share/golem/themes/MudGolem/styles | ||
@dirrm share/golem/themes/MudGolem/images/unf | ||
@dirrm share/golem/themes/MudGolem/images/pressed | ||
@dirrm share/golem/themes/MudGolem/images/foc | ||
@dirrm share/golem/themes/MudGolem/images | ||
@dirrm share/golem/themes/MudGolem/forplug/wmclass_defs | ||
@dirrm share/golem/themes/MudGolem/forplug/start_slide | ||
@dirrm share/golem/themes/MudGolem/forplug/simple_menus | ||
@dirrm share/golem/themes/MudGolem/forplug/setroot | ||
@dirrm share/golem/themes/MudGolem/forplug/pier | ||
@dirrm share/golem/themes/MudGolem/forplug/pager | ||
@dirrm share/golem/themes/MudGolem/forplug | ||
@dirrm share/golem/themes/MudGolem | ||
@dirrm share/golem/themes/AbsoluteE/forplug/setroot | ||
@dirrm share/golem/themes/AbsoluteE/forplug | ||
@dirrm share/golem/themes/AbsoluteE | ||
@dirrm share/golem/themes | ||
@dirrm share/golem/plugins/wmclass_defs | ||
@dirrm share/golem/plugins/start_slide | ||
${NOT_SOUND}@dirrm share/golem/plugins/sound | ||
@dirrm share/golem/plugins/simple_menus | ||
@dirrm share/golem/plugins/setroot | ||
@dirrm share/golem/plugins/pier | ||
@dirrm share/golem/plugins/pager | ||
@dirrm share/golem/plugins/mwm_hints | ||
@dirrm share/golem/plugins/gnome | ||
@dirrm share/golem/plugins/box_iconify | ||
@dirrm share/golem/plugins/animations | ||
@dirrm share/golem/plugins | ||
@dirrm share/golem | ||
@dirrm share/examples/golem | ||
@dirrm lib/golem/plugins | ||
@dirrm lib/golem |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2003/05/15 11:19:39 salo Exp $ | ||
|
||
SHA1 (golem-0.0.5.tar.gz) = 5939acf109502a2f962e20fa933b31970fb2ed74 | ||
Size (golem-0.0.5.tar.gz) = 748348 bytes | ||
SHA1 (patch-aa) = 2c2bb75dce922316a3360cc4e0fdcfdc97209527 | ||
SHA1 (patch-ab) = b9dc76afd9aecc96699944951d592c99b9d60c2f | ||
SHA1 (patch-ac) = c3e61f79f0783aaaa06723f53029a7b67b1a2a9c | ||
SHA1 (patch-ad) = ca2f91ea4587148543811729c8afc8e474b1c1ba |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
$NetBSD: patch-aa,v 1.1.1.1 2003/05/15 11:19:43 salo Exp $ | ||
|
||
--- Makefile.in.orig 2001-12-25 14:27:16.000000000 -0700 | ||
+++ Makefile.in 2003-04-07 02:16:44.000000000 -0600 | ||
@@ -1,5 +1,5 @@ | ||
# Makefile for golem | ||
-SUBDIRS= src @BUILD_PLUGINS@ doc util | ||
+SUBDIRS= src @BUILD_PLUGINS@ util | ||
|
||
@SET_MAKE@ | ||
|
||
@@ -56,7 +56,7 @@ | ||
|
||
install-man: | ||
@INSTALL@ -d $(mandir)/man1 | ||
- @INSTALL@ -m 444 doc/golem.1.gz $(mandir)/man1/ | ||
+ @INSTALL@ -m 444 doc/golem.mdoc $(mandir)/man1/golem.1 | ||
|
||
install: all install-bin install-data install-man | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
$NetBSD: patch-ab,v 1.1.1.1 2003/05/15 11:19:43 salo Exp $ | ||
|
||
--- src/rcfile.y.orig 2002-05-22 01:06:25.000000000 +0200 | ||
+++ src/rcfile.y 2003-05-15 11:46:30.000000000 +0200 | ||
@@ -536,7 +536,7 @@ | ||
*/ | ||
fp = fopen(rcfn, "r"); | ||
if (!fp) { | ||
- snprintf(filedir, MAXPATHLEN, "%s/golem/", DATADIR); | ||
+ snprintf(filedir, MAXPATHLEN, "%s/", PKG_SYSCONFDIR); | ||
snprintf(rcfn, sizeof(rcfn), "%s%s", filedir, filename); | ||
fp = fopen(rcfn, "r"); | ||
if (!fp) |
Oops, something went wrong.