Skip to content

Commit

Permalink
audio/din: Update to 57
Browse files Browse the repository at this point in the history
Changes since 56:

DIN Is Noise 57:

	:( fixed crash if Scale notes label on Settings page was clicked :)
  :( fixed reset of note polygon radius in Mondrian :)
  :( fixed lingering close button when switching ui screens using keyboard short cuts :)

  /*
      auto pause can now pause auto rotation or pause auto flip
      direction of rotation of launched drones

        set at Auto pause section in Menu > Drone Params > Defaults
  *\

  /* 0 limit on drone master volume, AM and FM depths *\

  /*
    change of keyboard shortcuts for better drone handling on the
    microtonal keyboard

    middle mouse click to set drone scale / rotate center (pink cross)
    to mouse cursor

    f - find drone center of selected drones
					voice phrase recorder shares this shortcut
						but only triggers if voice is active

    r - rotate selected drones about center

    t - scale selected drones about center

      hold SHIFT to scale only vertically (only volume changes)
      hold CTRL to scale only horizontally (only pitch changes)

    SPACE - freeze / thaw drones

    For selected drones:

      n - clear drone selection

      y, u - change AM depth and bpm
      o, p - change FM depth and bpm

      - - change handle size
      = - change trail length

      j - flip drone motion

            flips drone velocity

              try on launched drones after turning on
              Menu > Drone Defaults > Select on Creation

            and AM/FM direction

              try on drones of a drone pendulum
              or a drone mesh

  /*

  /*
    new keyboard shortcuts for mouse slider

      ` - toggle ~ on parameter spinner
      0 - toggle 0 on parameter spinner

  *\

  /*
    while moving drone center (the pink cross):

      SHIFT to move along vertical
      CTRL to move along horizontal
  *\

  /*
    On Gravity:

      tip -> mouse - gravity tracks mouse
      tip -> drone -  gravity tracks drone tip
                      instead of touching it

                        only works after
                        Tip to drone

  *\

  /*

    String of characters to bit pattern to box fill texture
    in Mondrian. A cheap experiment with polygon stippling
    in OpenGL.

      OFF by default
      Click Menu > Misc > Texture to toggle
      sd)s is default string. Change and see!
      Also change Step.

  */

  * improved drone AM and FM position set
  * improved Sine Mixer
  * improved binaural drones instrument
  * improved mouse slider
  * improved cursor cross hairs
  • Loading branch information
fraggerfox committed Sep 12, 2023
1 parent b3f7e3f commit 50506c1
Show file tree
Hide file tree
Showing 4 changed files with 30 additions and 8 deletions.
5 changes: 2 additions & 3 deletions audio/din/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.46 2023/05/06 19:08:58 ryoon Exp $
# $NetBSD: Makefile,v 1.47 2023/09/12 07:55:11 fox Exp $

DISTNAME= din-56
PKGREVISION= 2
DISTNAME= din-57
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/

Expand Down
5 changes: 4 additions & 1 deletion audio/din/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2022/05/07 07:26:41 fox Exp $
@comment $NetBSD: PLIST,v 1.11 2023/09/12 07:55:11 fox Exp $
bin/din
share/applications/din.desktop
share/din/factory/2600
Expand All @@ -12,6 +12,7 @@ share/din/factory/attack.crv
share/din/factory/attack.ed
share/din/factory/attack.lib
share/din/factory/audio_prefs
share/din/factory/bd.ins
share/din/factory/binaural-drone.help.tcl
share/din/factory/binaural-drones-waveform.crv
share/din/factory/binaural-drones-waveform.ed
Expand Down Expand Up @@ -370,6 +371,7 @@ share/din/factory/inner.crv
share/din/factory/inner_space.crv
share/din/factory/jag.fnt
share/din/factory/just-intonation.tuning
share/din/factory/kbkb.ins
share/din/factory/key.help.tcl
share/din/factory/keyboard-keyboard-waveform.crv
share/din/factory/keyboard-keyboard-waveform.ed
Expand All @@ -388,6 +390,7 @@ share/din/factory/microtonal-keyboard-waveform.crv
share/din/factory/microtonal-keyboard-waveform.ed
share/din/factory/midimap.help.tcl
share/din/factory/midimap.patch.tcl
share/din/factory/mkb.ins
share/din/factory/modulation.ed
share/din/factory/modv.crv
share/din/factory/modv.ed
Expand Down
9 changes: 5 additions & 4 deletions audio/din/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.31 2023/02/04 16:10:56 fox Exp $
$NetBSD: distinfo,v 1.32 2023/09/12 07:55:11 fox Exp $

BLAKE2s (din-56.tar.gz) = 61af2316274ee91892797be303819bab22291860b0c116d584d0ca1d1bb0f1ef
SHA512 (din-56.tar.gz) = 2e3e985abec9f0f097d51fb4cff5e991c5f80091586c0a4c47533c623dc9c13bae6b7f8a3d18bed1fc150e6527482b4ae03a9d1d9c444ae92b88204892ce7e04
Size (din-56.tar.gz) = 3716779 bytes
BLAKE2s (din-57.tar.gz) = 22e6611ca0c80ff57133997b4c9a77ce02c1bd31a878597192dcad8e895e124a
SHA512 (din-57.tar.gz) = 03dfa45fb8c58f3f8dc739ec3c4c31029c544d9f0b1cf3dbae61643e5accd951ad65ebf19c078bfb1d30d3a8ccea7ffec2f1cb44f38bab1b07cfd2071361590c
Size (din-57.tar.gz) = 3693381 bytes
SHA1 (patch-src_Makefile.am) = dd222d23a5a4c95a803c88d3467eb2a5fe7c09a0
SHA1 (patch-src_Makefile.in) = 3135bd8315cfdd65e7d885fc80f4baa89b7d94dc
SHA1 (patch-src_RtMidi.cpp) = ef74046633dd51666aeab206ec95b3266334a11b
19 changes: 19 additions & 0 deletions audio/din/patches/patch-src_RtMidi.cpp
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
$NetBSD: patch-src_RtMidi.cpp,v 1.1 2023/09/12 07:55:11 fox Exp $

Use process scheduling from NetBSD instead of pthread.

--- src/RtMidi.cpp.orig 2023-09-12 07:28:28.679052163 +0000
+++ src/RtMidi.cpp
@@ -3608,8 +3608,11 @@ void MidiOutJack :: sendMessage( const u
return;

while ( jack_ringbuffer_write_space(data->buff) < sizeof(nBytes) + size )
+#if defined(__NetBSD__)
+ sched_yield();
+#else
pthread_yield();
-
+#endif
// Write full message to buffer
jack_ringbuffer_write( data->buff, ( char * ) &nBytes, sizeof( nBytes ) );
jack_ringbuffer_write( data->buff, ( const char * ) message, nBytes );

0 comments on commit 50506c1

Please sign in to comment.