Skip to content

Commit

Permalink
Make this build and install under Linux:
Browse files Browse the repository at this point in the history
Do not define USE_BYACC, since not all Linuxen have byacc.  Patch a grammar
file accordingly.  Use -Wl,-rpath flags where necessary.

This should close PR pkg/19860.
  • Loading branch information
jschauma committed May 19, 2003
1 parent bb520a4 commit 50603c6
Show file tree
Hide file tree
Showing 6 changed files with 56 additions and 13 deletions.
6 changes: 3 additions & 3 deletions x11/openmotif/DEINSTALL
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: DEINSTALL,v 1.2 2002/01/10 12:10:45 jlam Exp $
# $NetBSD: DEINSTALL,v 1.3 2003/05/19 19:43:16 jschauma Exp $

X11BASE=@X11BASE@
MOTIF_RULES=${PKG_PREFIX}/lib/X11/config/Motif.rules
Expand Down Expand Up @@ -26,8 +26,8 @@ POST-DEINSTALL)
${RM} -f ${MOTIF_RULES} ${MOTIF_TMPL}
if [ ${PKG_PREFIX} = ${X11BASE} ]
then
${MV} -f ${MOTIF_RULES}.openmotif.bak ${MOTIF_RULES}
${MV} -f ${MOTIF_TMPL}.openmotif.bak ${MOTIF_TMPL}
${MV} -f ${MOTIF_RULES}.openmotif.bak ${MOTIF_RULES} 2>/dev/null
${MV} -f ${MOTIF_TMPL}.openmotif.bak ${MOTIF_TMPL} 2>/dev/null
fi

${RMDIR} -p ${PKG_PREFIX}/lib/X11/config 2>/dev/null || ${TRUE}
Expand Down
6 changes: 3 additions & 3 deletions x11/openmotif/INSTALL
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: INSTALL,v 1.3 2003/05/06 17:43:11 jmmv Exp $
# $NetBSD: INSTALL,v 1.4 2003/05/19 19:43:17 jschauma Exp $

X11BASE=@X11BASE@
MOTIF_RULES=${PKG_PREFIX}/lib/X11/config/Motif.rules
Expand All @@ -13,8 +13,8 @@ PRE-INSTALL)
POST-INSTALL)
if [ ${PKG_PREFIX} = ${X11BASE} ]
then
${MV} -f ${MOTIF_RULES} ${MOTIF_RULES}.openmotif.bak
${MV} -f ${MOTIF_TMPL} ${MOTIF_TMPL}.openmotif.bak
${MV} -f ${MOTIF_RULES} ${MOTIF_RULES}.openmotif.bak 2>/dev/null
${MV} -f ${MOTIF_TMPL} ${MOTIF_TMPL}.openmotif.bak 2>/dev/null
fi
${LN} -sf OpenMotif.rules ${MOTIF_RULES}
${LN} -sf OpenMotif.tmpl ${MOTIF_TMPL}
Expand Down
6 changes: 4 additions & 2 deletions x11/openmotif/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2003/02/23 13:11:24 jmmv Exp $
$NetBSD: distinfo,v 1.10 2003/05/19 19:43:17 jschauma Exp $

SHA1 (openmotif/openmotif2.1.30.tar.gz) = 34fc82fdf0e200525864665e179246ef64082dcc
Size (openmotif/openmotif2.1.30.tar.gz) = 17711487 bytes
Expand All @@ -18,7 +18,7 @@ SHA1 (patch-ac) = 9ca57238197458fb1729ba1c4300bf5ad82805a2
SHA1 (patch-ad) = 675b77555994293f69182c67c336683755a6b0f4
SHA1 (patch-ae) = 4bea5f3b09574d2c51a2b77e1daef78098e87c71
SHA1 (patch-af) = 10d4f98dd3a593c17ec6a59eb326c6f3d778c9cb
SHA1 (patch-ag) = 01c6c803889be6bf710331a855261621c4e0e3d0
SHA1 (patch-ag) = 7a46b6954ef1ce283122d0f42a987d359ca350c4
SHA1 (patch-ah) = db57ad992f2f68b2f4d5393be336cd47b9781746
SHA1 (patch-ai) = 548a08419a5e3511897407ca7ae0f0d5b9c163d7
SHA1 (patch-aj) = 10eeb1a20575e007de16a606bbccb3c663b2be75
Expand All @@ -32,3 +32,5 @@ SHA1 (patch-aq) = f06bde8d2151c3b60fce74e663b7eead965758a8
SHA1 (patch-ar) = 496fc6e3ba956f9103fbee6be221af44a26e2afd
SHA1 (patch-as) = f59bb1583bb3445e2420b667f6fb30595bca7ce6
SHA1 (patch-at) = d75e7b060797997f47f0da3099e53d5d8e5c6c68
SHA1 (patch-au) = 12691e159a788b4dca191f747eaacc18710d2696
SHA1 (patch-av) = 2729c9edbcbbb62016305a1f0293684b805ce50d
10 changes: 5 additions & 5 deletions x11/openmotif/patches/patch-ag
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.3 2002/01/10 12:10:46 jlam Exp $
$NetBSD: patch-ag,v 1.4 2003/05/19 19:43:17 jschauma Exp $

--- config/cf/host.def.orig Thu Jan 10 02:44:40 2002
+++ config/cf/host.def
@@ -1,17 +1,20 @@
--- config/cf/host.def.orig Mon May 19 14:04:32 2003
+++ config/cf/host.def Mon May 19 14:06:39 2003
@@ -1,17 +1,19 @@
#ifdef BeforeVendorCF

-#define TopLevelProject Motif
Expand All @@ -15,7 +15,7 @@ $NetBSD: patch-ag,v 1.3 2002/01/10 12:10:46 jlam Exp $
+#define X11ProjectRoot $(X11BASE)
#define VirtualBindingsPath $(LIBDIR)/bindings
#define ImportX11 YES
#define USE_BYACC YES
-#define USE_BYACC YES
#define NoMessageCatalog YES
#define ForceNormalLib YES
#define HasVarDirectory NO
Expand Down
25 changes: 25 additions & 0 deletions x11/openmotif/patches/patch-au
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
$NetBSD: patch-au,v 1.1 2003/05/19 19:43:17 jschauma Exp $

--- tools/wml/Uil.y.orig Mon May 19 13:57:46 2003
+++ tools/wml/Uil.y Mon May 19 13:58:48 2003
@@ -396,6 +396,7 @@
| WIDE_CHARACTER { $$ = $1; $$.b_type = sym_k_wchar_string_value; }
| FONTSET { $$ = $1; $$.b_type = sym_k_fontset_value; }
| WIDGET { $$ = $1; $$.b_type = sym_k_widget_ref_value; }
+ ;
/* End for fixing CR 5888 */

string_table_type
@@ -1058,10 +1059,11 @@
sar_private_error( &$$ );
}
}
+ ;

non_export_value
: COLOR_TABLE LEFT_PAREN color_list RIGHT_PAREN { sar_make_color_table( &$$, &$3, &$1); }
-
+ ;
/* END HaL fix CR 5427 */


16 changes: 16 additions & 0 deletions x11/openmotif/patches/patch-av
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
$NetBSD: patch-av,v 1.1 2003/05/19 19:43:17 jschauma Exp $

--- config/cf/linux.cf.orig Mon May 19 14:30:58 2003
+++ config/cf/linux.cf Mon May 19 14:30:22 2003
@@ -1,6 +1,11 @@
XCOMM platform: $TOG: linux.cf /main/36 1997/06/16 22:21:03 kaleb $
XCOMM platform: $XFree86: xc/config/cf/linux.cf,v 3.57.2.19 1999/09/04 09:12:27 dawes Exp $

+#define SharedLibraryLoadFlags -shared -Wl,-rpath,$(PREFIX)/lib -Wl,-rpath,$(X11PREFIX)/lib
+#ifndef ExtraLoadFlags
+#define ExtraLoadFlags -Wl,-rpath,$(PREFIX)/lib -Wl,-rpath,$(X11PREFIX)/lib
+#endif
+
#ifndef LinuxElfDefault
#define LinuxElfDefault YES
#endif

0 comments on commit 50603c6

Please sign in to comment.