Skip to content

Commit

Permalink
Fix the code in post-patch so that man pages correctly reference pages
Browse files Browse the repository at this point in the history
that have been prepended with "cyrus-".  Prepend a few more manpages with
"cyrus-" to prevent any likely future collisions with other packages.
Bump the PKGREVISON to 1.
  • Loading branch information
johnnylam88 committed May 27, 2004
1 parent 3ff39a1 commit 641d767
Show file tree
Hide file tree
Showing 2 changed files with 28 additions and 20 deletions.
36 changes: 22 additions & 14 deletions mail/cyrus-imapd22/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.9 2004/05/26 22:18:05 recht Exp $
# $NetBSD: Makefile,v 1.10 2004/05/27 05:09:04 jlam Exp $

DISTNAME= cyrus-imapd-2.2.4
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/OLD-VERSIONS/imap/
Expand Down Expand Up @@ -107,21 +108,28 @@ PERL5_PACKLIST= \
#
post-patch:
cd ${WRKSRC}/man; \
for file in deliver.8 imapd.8 master.8 pop3d.8; do \
${MV} $${file} cyrus-$${file}; \
${SED} -e "s|\(\$$(srcdir)/\)\($${file}\)|\1cyrus-\2|g" \
Makefile.in > Makefile.in.fixed; \
${MV} -f Makefile.in.fixed Makefile.in; \
set -- deliver 8 idled 8 imapd 8 lmtpd 8 master 8 nntpd 8 \
notifyd 8 pop3d 8 quota 8; \
while [ $$# -gt 0 ]; do \
man=$$1.$$2; \
for file in Makefile.in *.[0-9]; do \
${SED} -e "s|\(\$$(srcdir)/\)\($$man\)|\1cyrus-\2|g" \
-e "s|\(\\\fB\)\($$1($$2)\\\fR\)|\1cyrus-\2|g" \
$$file > $$file.fixed; \
${MV} -f $$file.fixed $$file; \
done; \
if [ -f $$man ]; then \
${MV} $$man cyrus-$$man; \
fi; \
shift 2; \
done
files=`${FIND} ${WRKSRC} -type f -exec ${GREP} -l \
-e /etc/imapd\.conf -e /etc/cyrus\.conf {} \;`; \
for file in $${files}; do \
${SED} -e "s|\(\\fB\)\($${name}($${suffix})\)|\1cyrus-\2|g" \
-e "s|\(\$$(srcdir)/\)\($${man}\)|\1cyrus-\2|g" \
-e "s|/etc/\(cyrus\.conf\)|${PKG_SYSCONFDIR}/\1|g" \
${FIND} ${WRKSRC} -type f -print | \
${XARGS} -n 1 ${GREP} -l -e /etc/imapd\.conf -e /etc/cyrus\.conf | \
while read file; do \
${SED} -e "s|/etc/\(cyrus\.conf\)|${PKG_SYSCONFDIR}/\1|g" \
-e "s|/etc/\(imapd\.conf\)|${PKG_SYSCONFDIR}/\1|g" \
$${file} > $${file}.fixed; \
${MV} -f $${file}.fixed $${file}; \
$$file > $$file.fixed; \
${MV} -f $$file.fixed $$file; \
done

post-install:
Expand Down
12 changes: 6 additions & 6 deletions mail/cyrus-imapd22/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2004/04/23 22:07:54 reed Exp $
@comment $NetBSD: PLIST,v 1.3 2004/05/27 05:09:04 jlam Exp $
bin/imtest
bin/installsieve
bin/lmtptest
Expand Down Expand Up @@ -99,19 +99,19 @@ man/man8/ctl_mboxlist.8
man/man8/cvt_cyrusdb.8
man/man8/cyr_expire.8
man/man8/cyrus-deliver.8
man/man8/cyrus-idled.8
man/man8/cyrus-imapd.8
man/man8/cyrus-lmtpd.8
man/man8/cyrus-master.8
man/man8/cyrus-nntpd.8
man/man8/cyrus-notifyd.8
man/man8/cyrus-pop3d.8
man/man8/cyrus-quota.8
man/man8/fetchnews.8
man/man8/fud.8
man/man8/idled.8
man/man8/ipurge.8
man/man8/lmtpd.8
man/man8/mbexamine.8
man/man8/mbpath.8
man/man8/nntpd.8
man/man8/notifyd.8
man/man8/quota.8
man/man8/reconstruct.8
man/man8/rmnews.8
man/man8/smmapd.8
Expand Down

0 comments on commit 641d767

Please sign in to comment.