-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
This release changes raw PostScript processing to avoid the non-rendering PostScript specials created by hyperref. A command-line switch to turn off raw PostScript rendering has been added. Finally, a few bugs has been fixed, such as correct decoding of the -T switch, a CRLF bug when reading configuration files in Windows, and a few bugs associated to subprocesses.
- Loading branch information
adam
committed
Mar 23, 2011
1 parent
81cf616
commit 6715d05
Showing
3 changed files
with
27 additions
and
11 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,9 @@ | ||
# $NetBSD: Makefile,v 1.15 2011/01/13 13:37:59 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.16 2011/03/23 10:09:44 adam Exp $ | ||
|
||
DISTNAME= dvipng-1.13 | ||
PKGREVISION= 1 | ||
DISTNAME= dvipng-1.14 | ||
CATEGORIES= graphics | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dvipng/} | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dvipng/} \ | ||
http://download.savannah.gnu.org/releases/dvipng/ | ||
|
||
MAINTAINER= [email protected] | ||
HOMEPAGE= http://savannah.nongnu.org/projects/dvipng/ | ||
|
@@ -12,10 +12,10 @@ LICENSE= gnu-lgpl-v3 | |
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
GNU_CONFIGURE= yes | ||
GNU_CONFIGURE= yes | ||
|
||
BUILD_TARGET= dvipng | ||
INSTALL_TARGET= install-dvigif | ||
BUILD_TARGET= dvipng | ||
INSTALL_TARGET= install-dvigif | ||
|
||
.include "../../fonts/t1lib/buildlink3.mk" | ||
.include "../../graphics/gd/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.4 2010/09/13 04:28:21 minskim Exp $ | ||
$NetBSD: distinfo,v 1.5 2011/03/23 10:09:44 adam Exp $ | ||
|
||
SHA1 (dvipng-1.13.tar.gz) = 626568203e3f799c99da0f3e31edecb13ce202b6 | ||
RMD160 (dvipng-1.13.tar.gz) = c615840bbc3f51cb81973e88484bc0838db1382d | ||
Size (dvipng-1.13.tar.gz) = 169309 bytes | ||
SHA1 (dvipng-1.14.tar.gz) = 778c7be5378eddf23200e47d92096ffe543528b6 | ||
RMD160 (dvipng-1.14.tar.gz) = df1ac7709c7a2c81dd28bfc5cfbaf69a35ba6f64 | ||
Size (dvipng-1.14.tar.gz) = 173686 bytes | ||
SHA1 (patch-special.c) = 9704c7e9a2483b8a246c1136343a90cd4ddd2f9b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
$NetBSD: patch-special.c,v 1.1 2011/03/23 10:09:45 adam Exp $ | ||
|
||
Fix #include | ||
|
||
--- special.c.orig 2011-03-23 09:08:08.000000000 +0000 | ||
+++ special.c | ||
@@ -26,7 +26,7 @@ | ||
|
||
#ifndef MIKTEX | ||
#ifndef WIN32 | ||
-#include <wait.h> | ||
+#include <sys/wait.h> | ||
#else /* WIN32 */ | ||
#include <fcntl.h> | ||
#include <io.h> |