Skip to content

Commit

Permalink
Convert to use the font hooks in the pkginstall framework. We no
Browse files Browse the repository at this point in the history
longer need to run mkfontdir ourselves, and those @exec/@unexec lines
may be removed from the PLISTs.
  • Loading branch information
johnnylam88 committed Dec 29, 2005
1 parent 07a6855 commit 67f9f82
Show file tree
Hide file tree
Showing 20 changed files with 45 additions and 102 deletions.
9 changes: 5 additions & 4 deletions fonts/efont-unicode/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2005/12/05 20:50:14 rillig Exp $
# $NetBSD: Makefile,v 1.9 2005/12/29 18:17:21 jlam Exp $

DISTNAME= efont-unicode-bdf-0.4.2
PKGNAME= ${DISTNAME:S/-bdf//}
Expand All @@ -11,7 +11,7 @@ HOMEPAGE= http://openlab.ring.gr.jp/efont/unicode/
COMMENT= Free unicode BDF font

USE_X11BASE= YES
USE_TOOLS+= gzip mkfontdir:run
USE_TOOLS+= bdftopcf gzip

MESSAGE_SUBST+= FONTDIR=${FONTDIR}
PLIST_SUBST+= FONTDIR=${FONTDIR:Q}
Expand All @@ -27,12 +27,14 @@ FONTS= b10 b10_b b10_bi b10_i\
h16 h16_b h16_bi h16_i\
h24 h24_b h24_bi h24_i
FONTDIR= lib/X11/fonts/efont
REQD_DIRS= ${FONTDIR}
FONTS_DIRS.x11= ${FONTDIR}

do-build:
@cd ${WRKSRC}; \
for FONT in ${FONTS}; do \
${ECHO} -n "Compiling font $${FONT} ... "; \
${X11BASE}/bin/bdftopcf $${FONT}.bdf | \
bdftopcf $${FONT}.bdf | \
${GZIP_CMD} -c >$${FONT}.pcf.gz; \
${ECHO} "done"; \
done
Expand All @@ -45,6 +47,5 @@ do-install:
${PREFIX}/${FONTDIR}; \
${ECHO} "done"; \
done
@cd ${PREFIX}/${FONTDIR}; ${X11BASE}/bin/mkfontdir

.include "../../mk/bsd.pkg.mk"
5 changes: 1 addition & 4 deletions fonts/efont-unicode/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/07/05 19:01:33 tron Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
${FONTDIR}/b10.pcf.gz
${FONTDIR}/b10_b.pcf.gz
${FONTDIR}/b10_bi.pcf.gz
Expand Down Expand Up @@ -39,6 +39,3 @@ ${FONTDIR}/h24.pcf.gz
${FONTDIR}/h24_b.pcf.gz
${FONTDIR}/h24_bi.pcf.gz
${FONTDIR}/h24_i.pcf.gz
@exec cd %D/${FONTDIR} && ${X11BASE}/bin/mkfontdir
@unexec rm -f %D/${FONTDIR}/fonts.dir
@dirrm ${FONTDIR}
14 changes: 3 additions & 11 deletions fonts/ja-elisat/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2005/11/08 18:22:09 jlam Exp $
# $NetBSD: Makefile,v 1.9 2005/12/29 18:17:21 jlam Exp $

DISTNAME= elisat10
PKGNAME= ja-elisat-1.0
Expand All @@ -13,8 +13,8 @@ WRKSRC= ${WRKDIR}
USE_X11BASE= YES
DOCDIR= ${PREFIX}/share/doc/elisat
FONTDIR= ${PREFIX}/lib/X11/fonts/local
#ALIAS= ${WRKDIR}/fonts.alias
USE_TOOLS+= gzip mkfontdir:run
FONTS_DIRS.x11= ${FONTDIR}
USE_TOOLS+= bdftopcf gzip

LICENSE= no-commercial-use

Expand All @@ -32,12 +32,4 @@ do-install:
${INSTALL_DATA_DIR} ${FONTDIR}; \
${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${FONTDIR}

post-install:
cd ${FONTDIR}; \
mkfontdir

post-deinstall:
cd ${FONTDIR}; \
mkfontdir

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ja-elisat/PLIST
Original file line number Diff line number Diff line change
@@ -1,10 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/03/15 20:35:39 kei Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/elisat10.pcf.gz
lib/X11/fonts/local/jpnhn4-iso.pcf.gz
lib/X11/fonts/local/jpnhn4-jis.pcf.gz
share/doc/elisat/elisa100.doc
share/doc/elisat/elisat10.doc
share/doc/elisat/elisat10.html
@dirrm share/doc/elisat
@exec mkfontdir %D/lib/X11/fonts/local
@unexec mkfontdir %D/lib/X11/fonts/local
13 changes: 3 additions & 10 deletions fonts/ja-elisau/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.10 2005/11/08 18:22:09 jlam Exp $
# $NetBSD: Makefile,v 1.11 2005/12/29 18:17:21 jlam Exp $

DISTNAME= elisau10
PKGNAME= ja-elisau-1.0
Expand All @@ -18,10 +18,11 @@ SITES_elisau10${EXTRACT_SUFX}= \
SITES_clR5x8.bdf= ftp://ftp.jp.NetBSD.org/pub/NetBSD-jp/tut-jp/fonts/

WRKSRC= ${WRKDIR}
USE_TOOLS+= gzip mkfontdir:run patch
USE_TOOLS+= bdftopcf gzip patch
USE_X11BASE= YES
DOCDIR= ${PREFIX}/share/doc/elisau
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}
DISTPATCH= ${WRKSRC}/clR5x8-s5x8.diff

LICENSE= no-commercial-use
Expand All @@ -45,12 +46,4 @@ do-install:
${INSTALL_DATA_DIR} ${FONTDIR}; \
${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${FONTDIR}

post-install:
cd ${FONTDIR}; \
mkfontdir

post-deinstall:
cd ${FONTDIR}; \
mkfontdir

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ja-elisau/PLIST
Original file line number Diff line number Diff line change
@@ -1,9 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/03/15 20:36:57 kei Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/clR5x8.pcf.gz
lib/X11/fonts/local/elisau10.pcf.gz
share/doc/elisau/elisa100.doc
share/doc/elisau/elisau10.doc
share/doc/elisau/hosoku.txt
@dirrm share/doc/elisau
@exec mkfontdir %D/lib/X11/fonts/local
@unexec mkfontdir %D/lib/X11/fonts/local
13 changes: 3 additions & 10 deletions fonts/ja-kaname/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2005/11/08 18:22:09 jlam Exp $
# $NetBSD: Makefile,v 1.9 2005/12/29 18:17:21 jlam Exp $

DISTNAME= kaname_k12_bdf
PKGNAME= ja-kaname-0.0.0.20030112
Expand All @@ -10,9 +10,10 @@ COMMENT= 12x12 dots X11 bitmap font for JIS X 0208

WRKSRC= ${WRKDIR}
USE_X11BASE= YES
USE_TOOLS+= gzip mkfontdir:run
USE_TOOLS+= bdftopcf gzip
DOCDIR= ${PREFIX}/share/doc/kaname
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}

#LICENSE= no-commercial-use

Expand All @@ -31,12 +32,4 @@ do-install:
${INSTALL_DATA_DIR} ${FONTDIR}; \
${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${FONTDIR}

post-install:
cd ${FONTDIR}; \
mkfontdir

post-deinstall:
cd ${FONTDIR}; \
mkfontdir

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ja-kaname/PLIST
Original file line number Diff line number Diff line change
@@ -1,10 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/03/15 20:38:31 kei Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/knmhn12x.pcf.gz
lib/X11/fonts/local/knmzn12x.pcf.gz
share/doc/kaname/readme.kaname_bdf
share/doc/kaname/kaname.doc
share/doc/kaname/readme.knm
share/doc/kaname/gijutsu-siryou.doc
@dirrm share/doc/kaname
@exec mkfontdir %D/lib/X11/fonts/local
@unexec mkfontdir %D/lib/X11/fonts/local
13 changes: 3 additions & 10 deletions fonts/ja-naga10/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2005/11/08 18:22:09 jlam Exp $
# $NetBSD: Makefile,v 1.7 2005/12/29 18:17:21 jlam Exp $

DISTNAME= knj10-1.1
PKGNAME= ja-naga10-1.1
Expand All @@ -12,9 +12,10 @@ HOMEPAGE= http://hp.vector.co.jp/authors/VA013391/fonts/#naga10
COMMENT= 10x10 dots X11 bitmap font for JIS X 0208

USE_X11BASE= YES
USE_TOOLS+= gzip mkfontdir:run
USE_TOOLS+= bdftopcf gzip patch
DOCDIR= ${PREFIX}/share/doc
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}

post-extract:
cd ${WRKDIR}; \
Expand All @@ -40,12 +41,4 @@ do-install:
${INSTALL_DATA_DIR} ${FONTDIR}; \
${INSTALL_DATA} ${WRKSRC}/*.pcf.gz ${FONTDIR}

post-install:
cd ${FONTDIR}; \
mkfontdir

post-deinstall:
cd ${FONTDIR}; \
mkfontdir

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ja-naga10/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/03/15 20:43:09 kei Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/5x10B.pcf.gz
lib/X11/fonts/local/5x10a.pcf.gz
lib/X11/fonts/local/5x10rk.pcf.gz
Expand All @@ -11,5 +11,3 @@ lib/X11/fonts/local/maru10.pcf.gz
lib/X11/fonts/local/min10.pcf.gz
share/doc/README.6x12
share/doc/README.naga10
@exec mkfontdir %D/lib/X11/fonts/local
@unexec mkfontdir %D/lib/X11/fonts/local
4 changes: 2 additions & 2 deletions fonts/kcfonts/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.5 2005/11/08 18:22:09 jlam Exp $
# $NetBSD: Makefile,v 1.6 2005/12/29 18:17:21 jlam Exp $

DISTNAME= kcfonts-1.05
CATEGORIES= fonts
Expand All @@ -9,6 +9,6 @@ COMMENT= Kuo Chauo Chinese Fonts collection

WRKSRC= ${WRKDIR}
USE_X11BASE= yes
USE_TOOLS+= mkfontdir:run
FONTS_DIRS.x11= lib/X11/fonts/local

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/kcfonts/PLIST
Original file line number Diff line number Diff line change
@@ -1,8 +1,6 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/07/18 16:19:03 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/fonts.alias
lib/X11/fonts/local/kc8x15.pcf.gz
lib/X11/fonts/local/kc12x24.pcf.gz
lib/X11/fonts/local/kc15f.pcf.gz
lib/X11/fonts/local/kc24f.pcf.gz
@exec %D/bin/mkfontdir %D/lib/X11/fonts/local
@unexec %D/bin/mkfontdir %D/lib/X11/fonts/local
10 changes: 4 additions & 6 deletions fonts/ko-baekmuk/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.11 2005/12/05 20:50:14 rillig Exp $
# $NetBSD: Makefile,v 1.12 2005/12/29 18:17:21 jlam Exp $
#

DISTNAME= baekmuk-2.0
Expand All @@ -14,7 +14,7 @@ COMMENT= X11 fonts for KSX 1001 Korean standard (baekmuk foundry)
CONFLICTS+= ksc5601fonts-[0-9]*

USE_X11BASE= yes
USE_TOOLS+= gzip mkfontdir:run
USE_TOOLS+= gzip

MAKE_ENV+= FONTDIR=${FONTDIR:Q} GZIP_CMD=${GZIP_CMD:Q}

Expand All @@ -29,7 +29,8 @@ BAEKMUK_BDF= batang10.bdf batang10b.bdf batang12.bdf batang12b.bdf \
gulim20b.bdf gulim24.bdf gulim24b.bdf hline10.bdf hline12.bdf \
hline14.bdf hline16.bdf hline18.bdf hline20.bdf hline24.bdf

FONTDIR=${PREFIX}/lib/X11/fonts/local
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}

post-extract:
${MKDIR} ${WRKSRC}
Expand All @@ -40,7 +41,4 @@ pre-install:
[ -d ${FONTDIR} ] || ${INSTALL_DATA_DIR} ${FONTDIR}
cp ${WRKSRC}/../fonts.alias ${FONTDIR}

post-install:
(cd ${FONTDIR}; mkfontdir)

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ko-baekmuk/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2002/07/26 19:09:32 junyoung Exp $
@comment $NetBSD: PLIST,v 1.4 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/batang10.pcf.gz
lib/X11/fonts/local/batang10b.pcf.gz
lib/X11/fonts/local/batang12.pcf.gz
Expand Down Expand Up @@ -42,5 +42,3 @@ lib/X11/fonts/local/hline16.pcf.gz
lib/X11/fonts/local/hline18.pcf.gz
lib/X11/fonts/local/hline20.pcf.gz
lib/X11/fonts/local/hline24.pcf.gz
@exec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
@unexec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
10 changes: 4 additions & 6 deletions fonts/ko-hanyang/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2005/12/05 20:50:14 rillig Exp $
# $NetBSD: Makefile,v 1.7 2005/12/29 18:17:21 jlam Exp $
#

DISTNAME= hanyang-font-pcf
Expand All @@ -13,7 +13,7 @@ COMMENT= X11 fonts for KSC 5601 standard
CONFLICTS+= ksc5601fonts-[0-9]*

USE_X11BASE= yes
USE_TOOLS+= gzip mkfontdir:run
USE_TOOLS+= gzip
EXTRACT_ONLY= # empty

MAKE_ENV+= FONTDIR=${FONTDIR:Q} GZIP_CMD=${GZIP_CMD:Q}
Expand All @@ -23,7 +23,8 @@ EXTRACT_ONLY+= hanyang-font-pcf.tar.gz
HANYANG_PCF= hgm10.pcf hgm12.pcf hgm14.pcf hgm16.pcf hgm18.pcf hgm20.pcf \
hmm10.pcf hmm12.pcf hmm14.pcf hmm16.pcf hmm18.pcf hmm20.pcf

FONTDIR=${PREFIX}/lib/X11/fonts/local
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}

post-extract:
${MKDIR} ${WRKSRC}
Expand All @@ -38,7 +39,4 @@ post-build:
pre-install:
[ -d ${FONTDIR} ] || ${INSTALL_DATA_DIR} ${FONTDIR}

post-install:
(cd ${FONTDIR}; mkfontdir)

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ko-hanyang/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2002/02/05 22:03:56 skrll Exp $
@comment $NetBSD: PLIST,v 1.3 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/hgm10.pcf.gz
lib/X11/fonts/local/hgm12.pcf.gz
lib/X11/fonts/local/hgm14.pcf.gz
Expand All @@ -11,5 +11,3 @@ lib/X11/fonts/local/hmm14.pcf.gz
lib/X11/fonts/local/hmm16.pcf.gz
lib/X11/fonts/local/hmm18.pcf.gz
lib/X11/fonts/local/hmm20.pcf.gz
@exec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
@unexec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
10 changes: 4 additions & 6 deletions fonts/ko-kaist/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.8 2005/12/05 20:50:14 rillig Exp $
# $NetBSD: Makefile,v 1.9 2005/12/29 18:17:21 jlam Exp $
#

DISTNAME= ko-kaist-20010718
Expand All @@ -13,12 +13,13 @@ COMMENT= X11 fonts for Korean KSC 5601 standard (kaist foundry)
CONFLICTS+= ksc5601fonts-[0-9]*

USE_X11BASE= yes
USE_TOOLS+= gzip gunzip mkfontdir:run
USE_TOOLS+= gzip gunzip
EXTRACT_ONLY= # empty

MAKE_ENV+= FONTDIR=${FONTDIR:Q} GZIP_CMD=${GZIP_CMD:Q}

FONTDIR=${PREFIX}/lib/X11/fonts/local
FONTDIR= ${PREFIX}/lib/X11/fonts/local
FONTS_DIRS.x11= ${FONTDIR}

do-extract:
${MKDIR} ${WRKSRC}
Expand All @@ -31,7 +32,4 @@ do-extract:
pre-install:
[ -d ${FONTDIR} ] || ${INSTALL_DATA_DIR} ${FONTDIR}

post-install:
(cd ${FONTDIR}; mkfontdir)

.include "../../mk/bsd.pkg.mk"
4 changes: 1 addition & 3 deletions fonts/ko-kaist/PLIST
Original file line number Diff line number Diff line change
@@ -1,7 +1,5 @@
@comment $NetBSD: PLIST,v 1.2 2002/02/05 22:03:56 skrll Exp $
@comment $NetBSD: PLIST,v 1.3 2005/12/29 18:17:21 jlam Exp $
lib/X11/fonts/local/kaist-newmj16.pcf.gz
lib/X11/fonts/local/kaist-newmj18.pcf.gz
lib/X11/fonts/local/ks_iyagi16.pcf.gz
lib/X11/fonts/local/ks_philgi16.pcf.gz
@exec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
@unexec ${X11BASE}/bin/mkfontdir %D/lib/X11/fonts/local
Loading

0 comments on commit 67f9f82

Please sign in to comment.