Skip to content

Commit

Permalink
Add obpager-1.8 to pkgsrc:
Browse files Browse the repository at this point in the history
OBPager is a lightweight pager applet or dockapp. It requires a netwm
compatible window manager such as OpenBox. OBPager shows windows in active
virtual desktops and allows the user to switch desktops by clicking on the
pager dockapp.
  • Loading branch information
tnn2 committed Jun 20, 2007
1 parent 86433a6 commit 6b6e138
Show file tree
Hide file tree
Showing 6 changed files with 88 additions and 0 deletions.
4 changes: 4 additions & 0 deletions wm/obpager/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
OBPager is a lightweight pager applet or dockapp. It requires a netwm
compatible window manager such as OpenBox. OBPager shows windows in active
virtual desktops and allows the user to switch desktops by clicking on the
pager dockapp.
25 changes: 25 additions & 0 deletions wm/obpager/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/06/20 18:09:24 tnn Exp $
#

DISTNAME= obpager-1.8
CATEGORIES= wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=obpager/}

MAINTAINER= [email protected]
HOMEPAGE= http://obpager.sourceforge.net/
COMMENT= Lightweight pager applet for OpenBox

USE_LANGUAGES= c++
NO_CONFIGURE= yes
USE_TOOLS+= gmake

CPPFLAGS+= -I${X11BASE}/include/X11
CPPFLAGS+= -I${X11BASE}/include/X11/extensions

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obpager ${PREFIX}/bin

.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXext/buildlink3.mk"
.include "../../x11/xextproto/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
2 changes: 2 additions & 0 deletions wm/obpager/PLIST
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/06/20 18:09:24 tnn Exp $
bin/obpager
7 changes: 7 additions & 0 deletions wm/obpager/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2007/06/20 18:09:24 tnn Exp $

SHA1 (obpager-1.8.tar.gz) = e97ecf8f44d5b787cdb5bfa853ab76eac919323a
RMD160 (obpager-1.8.tar.gz) = 45ca48aa8745fae522e7b0caf7b5a99d956e5413
Size (obpager-1.8.tar.gz) = 23773 bytes
SHA1 (patch-aa) = 2f701f8e3b8f81335ba2ad2478d2b3faf66b2126
SHA1 (patch-ab) = 7640ba0f05b27ffd7411fb9d6004511d5b6262f5
38 changes: 38 additions & 0 deletions wm/obpager/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/06/20 18:09:24 tnn Exp $

--- Makefile.orig 2004-09-01 16:23:44.000000000 +0200
+++ Makefile
@@ -13,12 +13,10 @@ INSTALLDIR = /usr/local/bin
# Set the compilation flags and such
CXX = g++
CDEFS = -D_REENTRANT
-CPPFLAGS = -ggdb -Wall
-#CPPFLAGS = -ggdb -Wall -O2
-INCLUDES = -I/usr/X11R6/include/X11 -I/usr/X11R6/include/X11/extensions -I./src
-COMPILE = $(CXX) $(CDEFS) $(INCLUDES) $(CPPFLAGS)
+INCLUDES = -I./src
+COMPILE = $(CXX) $(CXXFLAGS) $(CDEFS) $(INCLUDES) $(CPPFLAGS)
LINK = $(CXX) $(LDFLAGS) $(LDLIBS)
-LDLIBS = -L/usr/X11R6/lib -lX11 -lXext
+LDLIBS = -lX11 -lXext



@@ -50,7 +48,7 @@ $(EXECUTABLE): $(OBJS)

install:
@echo "Installing obpager...." ;\
- install $(EXECUTABLE) $(INSTALLDIR)
+ install $(EXECUTABLE) $(PREFIX)/bin


# For deps, copy gcc's dependency output to a ".d" file in the deps dir, then append additional deps to this file.
@@ -89,7 +87,7 @@ $(OBJDIR)/%.o : %.cc
mkdir $(DEPDIR) 2>/dev/null ; mkdir $(DEPDIR)/src 2>/dev/null ; \
$(COMPILE) -MMD -o $@ -c $< ; \
cp $(OBJDIR)/$*.d $(DEPDIR)/$*.d ; \
- sed -s -e 's/^[^:]\+: *//' -e 's/ *\\$$//' -e 's/^ *//' -e 's/ \+/ :\n/g' -e 's/$$/ :/' < $(OBJDIR)/$*.d >> $(DEPDIR)/$*.d ; \
+ sed -e 's/^[^:]\+: *//' -e 's/ *\\$$//' -e 's/^ *//' -e 's/ \+/ :\n/g' -e 's/$$/ :/' < $(OBJDIR)/$*.d >> $(DEPDIR)/$*.d ; \
rm -f $(OBJDIR)/$*.d


12 changes: 12 additions & 0 deletions wm/obpager/patches/patch-ab
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/06/20 18:09:24 tnn Exp $

--- src/main.cc.orig 2007-06-20 19:54:23.000000000 +0200
+++ src/main.cc
@@ -26,6 +26,7 @@

#include <sys/types.h>
#include <unistd.h>
+#include <errno.h>


// Include the headers for the pager class and also the spiffy custom exception class

0 comments on commit 6b6e138

Please sign in to comment.