Skip to content

Commit

Permalink
Updated devel/ocaml-lwt to version 5.7.0.
Browse files Browse the repository at this point in the history
I've removed superfluous dependencies from the package. Upstream changes
are many, so I'll add only the ones that break API (for the rest, see
the CHANGES file in the distribution):

* Lwt_result.catch now takes a function (unit -> 'a t)
  rather than a promise ('a t).
* Remove the deprecated Lwt.result type (use Stdlib.result instead).
* Remove the deprecated Lwt.make_value and Lwt.make_result functions
  (use Ok and Error instead).
* Remove the deprecated and unsafe waiter_of_wakener
  (keep the waiter around when you create the wakener instead).
* Remove the deprecated Lwt_stream.on_termination and
  Lwt_stream.on_terminate (bind to Lwt_stream.closed instead).
* Remove the deprecated Lwt_stream.result type (use Stdlib.result instead).
* Remove the deprecated Lwt_stream.map_exn function (use wrap_exn instead).
  • Loading branch information
jaapb committed Nov 5, 2023
1 parent 00e079b commit 6cecefd
Show file tree
Hide file tree
Showing 4 changed files with 9 additions and 13 deletions.
6 changes: 1 addition & 5 deletions devel/ocaml-lwt/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.46 2022/05/24 18:59:26 jaapb Exp $
# $NetBSD: Makefile,v 1.47 2023/11/05 21:31:38 jaapb Exp $
#

.include "Makefile.common"
Expand All @@ -23,9 +23,5 @@ MAKE_ENV+= LWT_DISCOVER_ARGUMENTS="--use-pthread true --use-libev true --verbose
.include "../../devel/ocaml-cppo/buildlink3.mk"
.include "../../devel/ocaml-dune-configurator/buildlink3.mk"
.include "../../devel/ocaml-findlib/buildlink3.mk"
.include "../../devel/ocaml-migrate-parsetree/buildlink3.mk"
.include "../../devel/ocaml-mmap/buildlink3.mk"
.include "../../devel/ocaml-ocplib-endian/buildlink3.mk"
.include "../../devel/ocaml-result/buildlink3.mk"
.include "../../devel/ocaml-seq/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
4 changes: 2 additions & 2 deletions devel/ocaml-lwt/Makefile.common
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.11 2022/08/17 19:20:30 tnn Exp $
# $NetBSD: Makefile.common,v 1.12 2023/11/05 21:31:38 jaapb Exp $

# used by devel/ocaml-lwt_ppx/Makefile
# used by devel/ocaml-lwt_react/Makefile

LWT_VERSION= 5.5.0
LWT_VERSION= 5.7.0
DISTNAME= lwt-${LWT_VERSION}

LICENSE= mit
Expand Down
4 changes: 2 additions & 2 deletions devel/ocaml-lwt/buildlink3.mk
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: buildlink3.mk,v 1.17 2022/05/02 14:02:09 jaapb Exp $
# $NetBSD: buildlink3.mk,v 1.18 2023/11/05 21:31:38 jaapb Exp $

BUILDLINK_TREE+= ocaml-lwt

.if !defined(OCAML_LWT_BUILDLINK3_MK)
OCAML_LWT_BUILDLINK3_MK:=

BUILDLINK_API_DEPENDS.ocaml-lwt+= ocaml-lwt>=5.0.0
BUILDLINK_ABI_DEPENDS.ocaml-lwt+= ocaml-lwt>=5.5.0
BUILDLINK_ABI_DEPENDS.ocaml-lwt+= ocaml-lwt>=5.7.0
BUILDLINK_PKGSRCDIR.ocaml-lwt?= ../../devel/ocaml-lwt

#.include "../../devel/libev/buildlink3.mk"
Expand Down
8 changes: 4 additions & 4 deletions devel/ocaml-lwt/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.27 2022/05/02 14:02:09 jaapb Exp $
$NetBSD: distinfo,v 1.28 2023/11/05 21:31:38 jaapb Exp $

BLAKE2s (lwt-5.5.0.tar.gz) = a40e1051fe796056644de8c781f5f562700033cf32741d47007f11b6c8468d57
SHA512 (lwt-5.5.0.tar.gz) = 8951b94555e930634375816d71815b9d85daad6ffb7dab24864661504d11be26575ab0b237196c54693efa372a9b69cdc1d5068a20a250dc0bbb4a3c03c5fda1
Size (lwt-5.5.0.tar.gz) = 313884 bytes
BLAKE2s (lwt-5.7.0.tar.gz) = a08fe493e8f621a743b935984e2c9e37de9ffaf480e80d989997b8f28312a7a7
SHA512 (lwt-5.7.0.tar.gz) = 42e629920783428673b99c9d7a639237c9e6b35079b5d907bc67e7ea506acf9edadc48cec580bdcfd2410ed9412bf5e6bcc8b09de2fa7d35ce1490973d05ddd1
Size (lwt-5.7.0.tar.gz) = 313632 bytes
SHA1 (patch-src_unix_unix__c_unix__stat__job__utils.c) = ca86829f5330a26b5bc8514bf4081fa71b8b32d4

0 comments on commit 6cecefd

Please sign in to comment.