-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Stop py-X from installing a configuration file under /etc
Spotted by joerg@'s bulk builds PKGREVISION++
- Loading branch information
adrianp
committed
May 19, 2007
1 parent
7166e5e
commit 6ef8706
Showing
4 changed files
with
37 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,8 +1,9 @@ | ||
# $NetBSD: Makefile,v 1.1.1.1 2007/01/03 14:51:07 adrianp Exp $ | ||
# $NetBSD: Makefile,v 1.2 2007/05/19 01:14:07 adrianp Exp $ | ||
# | ||
|
||
DISTNAME= PyX-0.9 | ||
PKGNAME= ${PYPKGPREFIX}-X-0.9 | ||
PKGREVISION= 1 | ||
CATEGORIES= textproc | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pyx/} | ||
|
||
|
@@ -15,6 +16,22 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://pyx.sourceforge.net/ | ||
COMMENT= Package for the creation of PostScript and PDF files | ||
|
||
CONF_FILES= ${PREFIX}/share/examples/PyX/pyxrc \ | ||
${PKG_SYSCONFDIR}/pyxrc | ||
|
||
SUBST_CLASSES+= conf | ||
SUBST_STAGE.conf= post-patch | ||
SUBST_MESSAGE.conf= Fixing configuration files. | ||
SUBST_FILES.conf= setup.py | ||
SUBST_SED.conf+= -e "s|@PKG_SYSCONFDIR@|${PKG_SYSCONFDIR}|g" | ||
|
||
pre-install: | ||
${CP} ${WRKSRC}/pyxrc ${WRKSRC}/pyxrc.default | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/PyX | ||
|
||
post-install: | ||
${CP} ${WRKSRC}/pyxrc.default ${PREFIX}/share/examples/PyX/pyxrc | ||
|
||
.include "../../lang/python/application.mk" | ||
.include "../../lang/python/extension.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2007/01/03 14:51:07 adrianp Exp $ | ||
$NetBSD: distinfo,v 1.2 2007/05/19 01:14:07 adrianp Exp $ | ||
|
||
SHA1 (PyX-0.9.tar.gz) = 79daf941f0ad36126471567879aaf6f94d21ccc4 | ||
RMD160 (PyX-0.9.tar.gz) = 095148e1cf5af028724ba3abf52794741e72d084 | ||
Size (PyX-0.9.tar.gz) = 351451 bytes | ||
SHA1 (patch-aa) = 789d1a8209334f4258c4e404cdf0b0daf1d4f18f |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,13 @@ | ||
$NetBSD: patch-aa,v 1.1 2007/05/19 01:14:07 adrianp Exp $ | ||
|
||
--- setup.py.orig 2006-03-09 16:49:55.000000000 +0000 | ||
+++ setup.py | ||
@@ -75,7 +75,7 @@ adddatafiles("sharedir", "share/pyx", [" | ||
|
||
# Note that on windows we can't install to absolute paths. Hence | ||
# we put the global pyxrc into the share directory as well. | ||
-adddatafiles("pyxrcdir", os.name != "nt" and "/etc" or "share/pyx", ["pyxrc"]) | ||
+adddatafiles("pyxrcdir", os.name != "nt" and "@PKG_SYSCONFDIR@" or "share/pyx", ["pyxrc.default"]) | ||
|
||
################################################################################ | ||
# extend install commands to overwrite siteconfig.py during build and install |