-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
While here, slightly clean up Makefile and fix conflict with itself by adding ${PYVERSSUFFIX} to pymol binary. Bump PKGREVISION.
- Loading branch information
Showing
2 changed files
with
11 additions
and
9 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,9 +1,9 @@ | ||
# $NetBSD: Makefile,v 1.20 2014/01/18 19:56:36 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.21 2014/02/17 14:32:28 wiz Exp $ | ||
|
||
DISTNAME= pymol-v1.5.0.1 | ||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/pymol-v/mol-/} | ||
EGG_NAME= pymol-1.5.0.1 | ||
PKGREVISION= 2 | ||
PKGREVISION= 3 | ||
CATEGORIES= biology | ||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pymol/} | ||
EXTRACT_SUFX= .tar.bz2 | ||
|
@@ -12,33 +12,35 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.pymol.org/ | ||
COMMENT= Molecular Visualization System | ||
|
||
USE_TOOLS+= csh:run | ||
|
||
DEPENDS+= ${PYPKGPREFIX}-numpy-[0-9]*:../../math/py-numpy | ||
|
||
PYTHON_VERSIONED_DEPENDENCIES= Pmw | ||
PYTHON_VERSIONS_INCOMPATIBLE= 33 | ||
|
||
WRKSRC= ${WRKDIR}/pymol | ||
|
||
USE_TOOLS+= csh:run | ||
|
||
CONFLICTS= pymol-[0-9]* | ||
PYTHON_SELF_CONFLICT= yes | ||
|
||
USE_LANGUAGES= c c++ | ||
|
||
REPLACE_CSH= test/vdiff | ||
REPLACE_PYTHON= test/cyg test/run test/show test/win.py | ||
REPLACE_PYTHON= test/cyg test/run test/show test/win.py modules/pmg_tk/startup/apbs_tools.py | ||
|
||
# not used | ||
CHECK_PORTABILITY_SKIP+= setup/* | ||
|
||
INSTALLATION_DIRS= bin | ||
|
||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX} | ||
|
||
# Gross hack | ||
PYSETUPBUILDTARGET= install ${_PYSETUPINSTALLARGS} | ||
|
||
post-install: | ||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} PYTHONPATH=${DESTDIR}${PREFIX}/${PYSITELIB} ${PYTHONBIN} setup2.py install ${_PYSETUPINSTALLARGS} | ||
${INSTALL_SCRIPT} ${WRKSRC}/pymol ${DESTDIR}${PREFIX}/bin/pymol | ||
${INSTALL_SCRIPT} ${WRKSRC}/pymol ${DESTDIR}${PREFIX}/bin/pymol${PYVERSSUFFIX} | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../graphics/freetype2/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters