-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix pidfile option handling (in configuration file case).
Bump PKGREVISION to 1.
- Loading branch information
Showing
3 changed files
with
39 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2008/08/26 15:01:54 seb Exp $ | ||
$NetBSD: distinfo,v 1.2 2008/08/26 17:18:14 seb Exp $ | ||
|
||
SHA1 (dbeacon-0.3.9.1.tar.gz) = d6131e723a251c01d245fcb3ead864f1348e2565 | ||
RMD160 (dbeacon-0.3.9.1.tar.gz) = 81ec4cfe1c2890c7cdb5afbbd98fd2d0cf2a57a3 | ||
Size (dbeacon-0.3.9.1.tar.gz) = 43893 bytes | ||
SHA1 (patch-aa) = a05a777dfcf7543eab85901c63ce85d927e03853 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
$NetBSD: patch-aa,v 1.1 2008/08/26 17:18:14 seb Exp $ | ||
|
||
--- dbeacon.cpp.orig 2007-07-13 13:52:14.000000000 +0000 | ||
+++ dbeacon.cpp | ||
@@ -176,7 +176,7 @@ bool daemonize = false; | ||
bool use_syslog = false; | ||
bool past_init = false; | ||
|
||
-const char *pidfile = NULL; | ||
+static string pidfile; | ||
|
||
static void next_event(timeval *); | ||
static void insert_event(uint32_t, uint32_t); | ||
@@ -464,8 +464,8 @@ int main(int argc, char **argv) { | ||
perror("Failed to daemon()ize."); | ||
return -1; | ||
} | ||
- if (pidfile) { | ||
- FILE *f = fopen(pidfile, "w"); | ||
+ if (!pidfile.empty()) { | ||
+ FILE *f = fopen(pidfile.c_str(), "w"); | ||
if (f) { | ||
fprintf(f, "%u\n", getpid()); | ||
fclose(f); | ||
@@ -1657,8 +1657,8 @@ void dumpBigBwStats(int) { | ||
|
||
void sendLeaveReport(int) { | ||
send_report(LEAVE_REPORT); | ||
- if (daemonize && pidfile) | ||
- unlink(pidfile); | ||
+ if (daemonize && !pidfile.empty()) | ||
+ unlink(pidfile.c_str()); | ||
exit(0); | ||
} | ||
|