Skip to content

Commit

Permalink
Fix pidfile option handling (in configuration file case).
Browse files Browse the repository at this point in the history
Bump PKGREVISION to 1.
  • Loading branch information
stoned committed Aug 26, 2008
1 parent f3a88a7 commit 78b9314
Show file tree
Hide file tree
Showing 3 changed files with 39 additions and 3 deletions.
4 changes: 2 additions & 2 deletions mbone/dbeacon/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.1.1.1 2008/08/26 15:01:54 seb Exp $
# $NetBSD: Makefile,v 1.2 2008/08/26 17:18:14 seb Exp $
#

DISTNAME= dbeacon-0.3.9.1
#PKGREVISION= 1
PKGREVISION= 1
CATEGORIES= mbone
MASTER_SITES= http://fivebits.net/files/dbeacon/

Expand Down
3 changes: 2 additions & 1 deletion mbone/dbeacon/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2008/08/26 15:01:54 seb Exp $
$NetBSD: distinfo,v 1.2 2008/08/26 17:18:14 seb Exp $

SHA1 (dbeacon-0.3.9.1.tar.gz) = d6131e723a251c01d245fcb3ead864f1348e2565
RMD160 (dbeacon-0.3.9.1.tar.gz) = 81ec4cfe1c2890c7cdb5afbbd98fd2d0cf2a57a3
Size (dbeacon-0.3.9.1.tar.gz) = 43893 bytes
SHA1 (patch-aa) = a05a777dfcf7543eab85901c63ce85d927e03853
35 changes: 35 additions & 0 deletions mbone/dbeacon/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
$NetBSD: patch-aa,v 1.1 2008/08/26 17:18:14 seb Exp $

--- dbeacon.cpp.orig 2007-07-13 13:52:14.000000000 +0000
+++ dbeacon.cpp
@@ -176,7 +176,7 @@ bool daemonize = false;
bool use_syslog = false;
bool past_init = false;

-const char *pidfile = NULL;
+static string pidfile;

static void next_event(timeval *);
static void insert_event(uint32_t, uint32_t);
@@ -464,8 +464,8 @@ int main(int argc, char **argv) {
perror("Failed to daemon()ize.");
return -1;
}
- if (pidfile) {
- FILE *f = fopen(pidfile, "w");
+ if (!pidfile.empty()) {
+ FILE *f = fopen(pidfile.c_str(), "w");
if (f) {
fprintf(f, "%u\n", getpid());
fclose(f);
@@ -1657,8 +1657,8 @@ void dumpBigBwStats(int) {

void sendLeaveReport(int) {
send_report(LEAVE_REPORT);
- if (daemonize && pidfile)
- unlink(pidfile);
+ if (daemonize && !pidfile.empty())
+ unlink(pidfile.c_str());
exit(0);
}

0 comments on commit 78b9314

Please sign in to comment.